Message ID | 1370521122-20268-4-git-send-email-mika.kuoppala@intel.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
On Thu, Jun 06, 2013 at 03:18:42PM +0300, Mika Kuoppala wrote: > As getting error state doesn't anymore require big kmallocs, > make error state accessible also from sysfs. > > Suggested-by: Daniel Vetter <daniel.vetter@ffwll.ch> > Signed-off-by: Mika Kuoppala <mika.kuoppala@intel.com> Don't forget the ability to clear an error-state in order to capture a fresh one. -Chris
On Thu, Jun 06, 2013 at 03:18:42PM +0300, Mika Kuoppala wrote: > As getting error state doesn't anymore require big kmallocs, > make error state accessible also from sysfs. > > Suggested-by: Daniel Vetter <daniel.vetter@ffwll.ch> > Signed-off-by: Mika Kuoppala <mika.kuoppala@intel.com> > --- > drivers/gpu/drm/i915/i915_sysfs.c | 49 +++++++++++++++++++++++++++++++++++++ > 1 file changed, 49 insertions(+) > > diff --git a/drivers/gpu/drm/i915/i915_sysfs.c b/drivers/gpu/drm/i915/i915_sysfs.c > index 6875b56..d4c754b 100644 > --- a/drivers/gpu/drm/i915/i915_sysfs.c > +++ b/drivers/gpu/drm/i915/i915_sysfs.c > @@ -409,6 +409,49 @@ static const struct attribute *gen6_attrs[] = { > NULL, > }; > > +static ssize_t error_state_read(struct file *filp, struct kobject *kobj, > + struct bin_attribute *attr, char *buf, > + loff_t off, size_t count) > +{ > + > + struct device *kdev = container_of(kobj, struct device, kobj); > + struct drm_minor *minor = container_of(kdev, struct drm_minor, kdev); > + struct drm_device *dev = minor->dev; > + struct i915_error_state_file_priv error_priv; > + struct drm_i915_error_state_buf error_str; > + ssize_t ret_count = 0; > + int ret; > + > + memset(&error_priv, 0, sizeof(error_priv)); > + > + ret = i915_error_state_buf_init(&error_str, count, off); > + if (ret) > + return ret; > + > + error_priv.dev = dev; > + i915_error_state_get(dev, &error_priv); > + > + ret = i915_error_state_to_str(&error_str, &error_priv); > + if (ret) > + goto out; > + > + ret_count = count < error_str.bytes ? count : error_str.bytes; > + > + memcpy(buf, error_str.buf, ret_count); > +out: > + i915_error_state_buf_release(&error_str); > + i915_error_state_put(&error_priv); > + > + return ret ?: ret_count; > +} > + > +static struct bin_attribute error_state_attr = { > + .attr.name = "i915_error_state", > + .attr.mode = 0444, Error state could easily leak sensitive information, so I think we should only allow root to read it. Also maybe a new name for it, i915_ is kinda meh ... I vote for gpu_error_state. -Daniel > + .size = 0, > + .read = error_state_read, > +}; > + > void i915_setup_sysfs(struct drm_device *dev) > { > int ret; > @@ -432,10 +475,16 @@ void i915_setup_sysfs(struct drm_device *dev) > if (ret) > DRM_ERROR("gen6 sysfs setup failed\n"); > } > + > + ret = sysfs_create_bin_file(&dev->primary->kdev.kobj, > + &error_state_attr); > + if (ret) > + DRM_ERROR("error_state sysfs setup failed\n"); > } > > void i915_teardown_sysfs(struct drm_device *dev) > { > + sysfs_remove_bin_file(&dev->primary->kdev.kobj, &error_state_attr); > sysfs_remove_files(&dev->primary->kdev.kobj, gen6_attrs); > device_remove_bin_file(&dev->primary->kdev, &dpf_attrs); > #ifdef CONFIG_PM > -- > 1.7.9.5 > > _______________________________________________ > Intel-gfx mailing list > Intel-gfx@lists.freedesktop.org > http://lists.freedesktop.org/mailman/listinfo/intel-gfx
diff --git a/drivers/gpu/drm/i915/i915_sysfs.c b/drivers/gpu/drm/i915/i915_sysfs.c index 6875b56..d4c754b 100644 --- a/drivers/gpu/drm/i915/i915_sysfs.c +++ b/drivers/gpu/drm/i915/i915_sysfs.c @@ -409,6 +409,49 @@ static const struct attribute *gen6_attrs[] = { NULL, }; +static ssize_t error_state_read(struct file *filp, struct kobject *kobj, + struct bin_attribute *attr, char *buf, + loff_t off, size_t count) +{ + + struct device *kdev = container_of(kobj, struct device, kobj); + struct drm_minor *minor = container_of(kdev, struct drm_minor, kdev); + struct drm_device *dev = minor->dev; + struct i915_error_state_file_priv error_priv; + struct drm_i915_error_state_buf error_str; + ssize_t ret_count = 0; + int ret; + + memset(&error_priv, 0, sizeof(error_priv)); + + ret = i915_error_state_buf_init(&error_str, count, off); + if (ret) + return ret; + + error_priv.dev = dev; + i915_error_state_get(dev, &error_priv); + + ret = i915_error_state_to_str(&error_str, &error_priv); + if (ret) + goto out; + + ret_count = count < error_str.bytes ? count : error_str.bytes; + + memcpy(buf, error_str.buf, ret_count); +out: + i915_error_state_buf_release(&error_str); + i915_error_state_put(&error_priv); + + return ret ?: ret_count; +} + +static struct bin_attribute error_state_attr = { + .attr.name = "i915_error_state", + .attr.mode = 0444, + .size = 0, + .read = error_state_read, +}; + void i915_setup_sysfs(struct drm_device *dev) { int ret; @@ -432,10 +475,16 @@ void i915_setup_sysfs(struct drm_device *dev) if (ret) DRM_ERROR("gen6 sysfs setup failed\n"); } + + ret = sysfs_create_bin_file(&dev->primary->kdev.kobj, + &error_state_attr); + if (ret) + DRM_ERROR("error_state sysfs setup failed\n"); } void i915_teardown_sysfs(struct drm_device *dev) { + sysfs_remove_bin_file(&dev->primary->kdev.kobj, &error_state_attr); sysfs_remove_files(&dev->primary->kdev.kobj, gen6_attrs); device_remove_bin_file(&dev->primary->kdev, &dpf_attrs); #ifdef CONFIG_PM
As getting error state doesn't anymore require big kmallocs, make error state accessible also from sysfs. Suggested-by: Daniel Vetter <daniel.vetter@ffwll.ch> Signed-off-by: Mika Kuoppala <mika.kuoppala@intel.com> --- drivers/gpu/drm/i915/i915_sysfs.c | 49 +++++++++++++++++++++++++++++++++++++ 1 file changed, 49 insertions(+)