@@ -99,7 +99,7 @@ SCAN_OPTIONS=--rebuild-sections
# Extra options to supply to gtkdoc-mkdb.
# e.g. MKDB_OPTIONS=--xml-mode --output-format=xml
-MKDB_OPTIONS=--xml-mode --output-format=xml
+MKDB_OPTIONS=--output-format=xml
# Extra options to supply to gtkdoc-mktmpl
# e.g. MKTMPL_OPTIONS=--only-section-tmpl
@@ -413,7 +413,7 @@ void igt_drop_root(void)
* @var: var lookup to to enable this wait
*
* Waits for a key press when run interactively and when the corresponding debug
- * var is set in the --interactive-debug=<var> variable. Multiple keys
+ * var is set in the --interactive-debug=<var> variable. Multiple keys
* can be specified as a comma-separated list or alternatively "all" if a wait
* should happen for all cases.
*
@@ -157,10 +157,10 @@
* test logic.
*
* - When adding a new feature test function which uses igt_skip() internally,
- * use the <prefix>_require_<feature_name> naming scheme. When you
+ * use the <prefix>_require_<feature_name> naming scheme. When you
* instead add a feature test function which returns a boolean, because your
* main test logic must take different actions depending upon the feature's
- * availability, then instead use the <prefix>_has_<feature_name>.
+ * availability, then instead use the <prefix>_has_<feature_name>.
*
* - As already mentioned eschew explicit error handling logic as much as
* possible. If your test absolutely has to handle the error of some function
@@ -142,7 +142,7 @@ static igt_debugfs_t *__igt_debugfs_singleton(void)
* @mode: mode bits as used by open()
*
* This opens a debugfs file as a Unix file descriptor. The filename should be
- * relative to the drm device's root, i.e without "drm/<minor>".
+ * relative to the drm device's root, i.e without "drm/<minor>".
*
* Returns:
* The Unix file descriptor for the debugfs file or -1 if that didn't work out.
@@ -165,7 +165,7 @@ int igt_debugfs_open(const char *filename, int mode)
* @mode: mode string as used by fopen()
*
* This opens a debugfs file as a libc FILE. The filename should be
- * relative to the drm device's root, i.e without "drm/<minor>".
+ * relative to the drm device's root, i.e without "drm/<minor>".
*
* Returns:
* The libc FILE pointer for the debugfs file or NULL if that didn't work out.
Avoid having to escape certain characters in documentation comments by not allowing docbook markup tags. Markdown formatting in documentation comments is still supported. Signed-off-by: Thomas Wood <thomas.wood@intel.com> --- docs/reference/intel-gpu-tools/Makefile.am | 2 +- lib/igt_aux.c | 2 +- lib/igt_core.c | 4 ++-- lib/igt_debugfs.c | 4 ++-- 4 files changed, 6 insertions(+), 6 deletions(-)