Message ID | 1454595941-16697-1-git-send-email-marius.c.vlad@intel.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
On Thu, Feb 04, 2016 at 04:25:41PM +0200, Marius Vlad wrote: > suspend-read-crc-pipe will perform a suspend and then skip the test in case the > pipe is not present on the platform. Skip the test before doing the suspend. > > > Signed-off-by: Marius Vlad <marius.c.vlad@intel.com> > --- > tests/kms_pipe_crc_basic.c | 1 + > 1 file changed, 1 insertion(+) > > diff --git a/tests/kms_pipe_crc_basic.c b/tests/kms_pipe_crc_basic.c > index 3c51ba0..dbb2919 100644 > --- a/tests/kms_pipe_crc_basic.c > +++ b/tests/kms_pipe_crc_basic.c > @@ -271,6 +271,7 @@ igt_main > test_read_crc(&data, i, TEST_SEQUENCE | TEST_NONBLOCK); > > igt_subtest_f("suspend-read-crc-pipe-%c", 'A'+i) { > + igt_skip_on(i >= data.display.n_pipes); We should place this into an igt_fixture at the top of the loop. Hitting igt_skip outside of any testcase means we'll skip all the subsequent ones without doing any work. Otoh this is a bit a bikeshed, so Reviewed-by: Daniel Vetter <daniel.vetter@ffwll.ch> either way. -Daniel > igt_system_suspend_autoresume(); > > test_read_crc(&data, i, 0); > -- > 2.7.0 > > _______________________________________________ > Intel-gfx mailing list > Intel-gfx@lists.freedesktop.org > http://lists.freedesktop.org/mailman/listinfo/intel-gfx
diff --git a/tests/kms_pipe_crc_basic.c b/tests/kms_pipe_crc_basic.c index 3c51ba0..dbb2919 100644 --- a/tests/kms_pipe_crc_basic.c +++ b/tests/kms_pipe_crc_basic.c @@ -271,6 +271,7 @@ igt_main test_read_crc(&data, i, TEST_SEQUENCE | TEST_NONBLOCK); igt_subtest_f("suspend-read-crc-pipe-%c", 'A'+i) { + igt_skip_on(i >= data.display.n_pipes); igt_system_suspend_autoresume(); test_read_crc(&data, i, 0);
suspend-read-crc-pipe will perform a suspend and then skip the test in case the pipe is not present on the platform. Skip the test before doing the suspend. Signed-off-by: Marius Vlad <marius.c.vlad@intel.com> --- tests/kms_pipe_crc_basic.c | 1 + 1 file changed, 1 insertion(+)