@@ -1696,7 +1696,7 @@ static int capture(void *data)
ktime_to_timeval(ktime_sub(ktime_get(),
error->i915->gt.last_init_time));
- error->params = i915;
+ error->params = i915_params;
#define DUP(T, x) dup_param(#T, &error->params.x);
I915_PARAMS_FOR_EACH(DUP);
#undef DUP
@@ -32,7 +32,7 @@
module_param_named_unsafe(name, i915_param(name), T, perm); \
MODULE_PARM_DESC(name, desc)
-struct i915_params i915 __read_mostly = {
+struct i915_params i915_params __read_mostly = {
.modeset = -1,
.panel_ignore_lid = 1,
.semaphores = -1,
@@ -76,9 +76,9 @@ struct i915_params {
};
#undef MEMBER
-extern struct i915_params i915 __read_mostly;
+extern struct i915_params i915_params __read_mostly;
-#define i915_param(n) i915.n
+#define i915_param(n) i915_params.n
#endif
Our global struct with params is named exactly the same way as new preferred name for the drm_i915_private function parameter. To avoid such name reuse and allow further cleanup of deprecated dev_priv lets use different name for the global. v2: rebased Signed-off-by: Michal Wajdeczko <michal.wajdeczko@intel.com> Cc: Chris Wilson <chris@chris-wilson.co.uk> Cc: Tvrtko Ursulin <tvrtko.ursulin@intel.com> Cc: Jani Nikula <jani.nikula@intel.com> Cc: Ville Syrjala <ville.syrjala@intel.com> --- drivers/gpu/drm/i915/i915_gpu_error.c | 2 +- drivers/gpu/drm/i915/i915_params.c | 2 +- drivers/gpu/drm/i915/i915_params.h | 4 ++-- 3 files changed, 4 insertions(+), 4 deletions(-)