Message ID | 20240605231918.2915961-1-seanjc@google.com (mailing list archive) |
---|---|
Headers | show |
Series | x86/cpu: KVM: Clean up PAT and VMX macros | expand |
On Wed, Jun 05, 2024, Sean Christopherson wrote: > The primary goal of this series is to clean up the VMX MSR macros and their > usage in KVM. > > The first half of the series touches memtype code that (obviously) impacts > areas well outside of KVM, in order to address several warts: > > (a) KVM is defining VMX specific macros for the architectural memtypes > (b) the PAT and MTRR code define similar, yet different macros > (c) that the PAT code not only has macros for the types (well, enums), > it also has macros for encoding the entire PAT MSR that can be used > by KVM. > > The memtype changes aren't strictly required for the KVM-focused changes in > the second half of the series, but splitting this into two series would > generating a number of conflicts that would be cumbersome to resolve after > the fact. > > I would like to take this through the KVM tree, as I don't expect the PAT/MTRR > code to see much change in the near future, and IIRC the original motiviation > of the VMX MSR cleanups was to prepare for KVM feature enabling (FRED maybe?). x86 folks, can I get Acks/reviews/NAKs on patches 1-2? I'd like to land this series in 6.12 as there is KVM feature enabling work that builds on top. It's not a hard dependency, but having these cleanups in place would make my life easier. Thanks!
On Wed, 05 Jun 2024 16:19:08 -0700, Sean Christopherson wrote: > The primary goal of this series is to clean up the VMX MSR macros and their > usage in KVM. > > The first half of the series touches memtype code that (obviously) impacts > areas well outside of KVM, in order to address several warts: > > (a) KVM is defining VMX specific macros for the architectural memtypes > (b) the PAT and MTRR code define similar, yet different macros > (c) that the PAT code not only has macros for the types (well, enums), > it also has macros for encoding the entire PAT MSR that can be used > by KVM. > > [...] Applied to kvm-x86 pat_vmx_msrs. I won't put anything else in this branch, on the off chance someone needs to pull in the PAT changes for something else. [01/10] x86/cpu: KVM: Add common defines for architectural memory types (PAT, MTRRs, etc.) https://github.com/kvm-x86/linux/commit/e7e80b66fb24 [02/10] x86/cpu: KVM: Move macro to encode PAT value to common header https://github.com/kvm-x86/linux/commit/beb2e446046f [03/10] KVM: x86: Stuff vCPU's PAT with default value at RESET, not creation https://github.com/kvm-x86/linux/commit/b6717d35d859 [04/10] KVM: VMX: Move MSR_IA32_VMX_BASIC bit defines to asm/vmx.h https://github.com/kvm-x86/linux/commit/d7bfc9ffd580 [05/10] KVM: VMX: Track CPU's MSR_IA32_VMX_BASIC as a single 64-bit value https://github.com/kvm-x86/linux/commit/9df398ff7d2a [06/10] KVM: nVMX: Use macros and #defines in vmx_restore_vmx_basic() https://github.com/kvm-x86/linux/commit/c97b106fa8aa [07/10] KVM: nVMX: Add a helper to encode VMCS info in MSR_IA32_VMX_BASIC https://github.com/kvm-x86/linux/commit/92e648042c23 [08/10] KVM VMX: Move MSR_IA32_VMX_MISC bit defines to asm/vmx.h https://github.com/kvm-x86/linux/commit/dc1e67f70f6d [09/10] KVM: VMX: Open code VMX preemption timer rate mask in its accessor https://github.com/kvm-x86/linux/commit/8f56b14e9fa0 [10/10] KVM: nVMX: Use macros and #defines in vmx_restore_vmx_misc() https://github.com/kvm-x86/linux/commit/566975f6ecd8 -- https://github.com/kvm-x86/linux/tree/next
On Fri, 2024-08-23 at 16:47 -0700, Sean Christopherson wrote: > Applied to kvm-x86 pat_vmx_msrs. I won't put anything else in this branch, on > the off chance someone needs to pull in the PAT changes for something else. > > [01/10] x86/cpu: KVM: Add common defines for architectural memory types (PAT, MTRRs, etc.) > https://github.com/kvm-x86/linux/commit/e7e80b66fb24 This one has both Acked-by and Reviewed-by tag from me. You can remove the former.
On Sat, Aug 24, 2024, Kai Huang wrote: > On Fri, 2024-08-23 at 16:47 -0700, Sean Christopherson wrote: > > Applied to kvm-x86 pat_vmx_msrs. I won't put anything else in this branch, on > > the off chance someone needs to pull in the PAT changes for something else. > > > > [01/10] x86/cpu: KVM: Add common defines for architectural memory types (PAT, MTRRs, etc.) > > https://github.com/kvm-x86/linux/commit/e7e80b66fb24 > > This one has both Acked-by and Reviewed-by tag from me. You can remove the > former. Eh, you get two for the price of one this time around. I don't want to rebase this entire branch just to fix that goof.