mbox series

[kvm-unit-tests,0/2] riscv: sbi: Rename sbi ecall wrappers

Message ID 20240830155337.335534-4-andrew.jones@linux.dev (mailing list archive)
Headers show
Series riscv: sbi: Rename sbi ecall wrappers | expand

Message

Andrew Jones Aug. 30, 2024, 3:53 p.m. UTC
Just some renaming to improve readability and also add another DBCN
test to ensure we only write a single byte with write-byte. Use the
"raw" ecall for that because sbi_dbcn_write_byte now takes a uint8_t.

Andrew Jones (2):
  sbi: Rename __*_sbi_ecall to sbi_*
  sbi: dbcn: Add write-byte test with more than byte given

 riscv/sbi.c | 48 ++++++++++++++++++++++++++++++------------------
 1 file changed, 30 insertions(+), 18 deletions(-)

Comments

Andrew Jones Sept. 3, 2024, 1:58 p.m. UTC | #1
On Fri, Aug 30, 2024 at 05:53:38PM GMT, Andrew Jones wrote:
> Just some renaming to improve readability and also add another DBCN
> test to ensure we only write a single byte with write-byte. Use the
> "raw" ecall for that because sbi_dbcn_write_byte now takes a uint8_t.
> 
> Andrew Jones (2):
>   sbi: Rename __*_sbi_ecall to sbi_*
>   sbi: dbcn: Add write-byte test with more than byte given
> 
>  riscv/sbi.c | 48 ++++++++++++++++++++++++++++++------------------
>  1 file changed, 30 insertions(+), 18 deletions(-)
> 
> -- 
> 2.45.2
>

Adding the missing 'riscv' prefixes to the patches and queued
https://gitlab.com/jones-drew/kvm-unit-tests/-/commits/riscv/sbi

Thanks,
drew