Message ID | 20231017232610.4008690-1-mizhang@google.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | KVM: x86: Update the variable naming in kvm_x86_ops.sched_in() | expand |
On Tue, 17 Oct 2023 23:26:10 +0000, Mingwei Zhang wrote: > Update the variable with name 'kvm' in kvm_x86_ops.sched_in() to 'vcpu' to > avoid confusions. Variable naming in KVM has a clear convention that 'kvm' > refers to pointer of type 'struct kvm *', while 'vcpu' refers to pointer of > type 'struct kvm_vcpu *'. > > Fix this 9-year old naming issue for fun. > > [...] Applied to kvm-x86 misc, thanks! [1/1] KVM: x86: Update the variable naming in kvm_x86_ops.sched_in() https://github.com/kvm-x86/linux/commit/5a989bbead4c -- https://github.com/kvm-x86/linux/tree/next
diff --git a/arch/x86/include/asm/kvm_host.h b/arch/x86/include/asm/kvm_host.h index 7c228ae05df0..394e1a31c02c 100644 --- a/arch/x86/include/asm/kvm_host.h +++ b/arch/x86/include/asm/kvm_host.h @@ -1703,7 +1703,7 @@ struct kvm_x86_ops { void (*request_immediate_exit)(struct kvm_vcpu *vcpu); - void (*sched_in)(struct kvm_vcpu *kvm, int cpu); + void (*sched_in)(struct kvm_vcpu *vcpu, int cpu); /* * Size of the CPU's dirty log buffer, i.e. VMX's PML buffer. A zero
Update the variable with name 'kvm' in kvm_x86_ops.sched_in() to 'vcpu' to avoid confusions. Variable naming in KVM has a clear convention that 'kvm' refers to pointer of type 'struct kvm *', while 'vcpu' refers to pointer of type 'struct kvm_vcpu *'. Fix this 9-year old naming issue for fun. Signed-off-by: Mingwei Zhang <mizhang@google.com> --- arch/x86/include/asm/kvm_host.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) base-commit: 437bba5ad2bba00c2056c896753a32edf80860cc