Message ID | d0d2c6fda0a21962eefcf28b37a603caa4be1819.1632171479.git.maciej.szmigiero@oracle.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | KVM: Scalable memslots implementation | expand |
On Mon, Sep 20, 2021, Maciej S. Szmigiero wrote: > @@ -1267,7 +1280,7 @@ search_memslots(struct kvm_memslots *slots, gfn_t gfn, int *index) > * itself isn't here as an inline because that would bloat other code too much. > */ > static inline struct kvm_memory_slot * > -__gfn_to_memslot(struct kvm_memslots *slots, gfn_t gfn) > +__gfn_to_memslot_approx(struct kvm_memslots *slots, gfn_t gfn, bool approx) This function name is a misnomer. The helper is not an "approx" version, it's an inner helper that takes an @approx param. Unless someone has a more clever name, the dreaded four underscores seems like the way to go. Warning away users is a good thing in this case... > { > struct kvm_memory_slot *slot; > int slot_index = atomic_read(&slots->last_used_slot); > @@ -1276,7 +1289,7 @@ __gfn_to_memslot(struct kvm_memslots *slots, gfn_t gfn) > if (slot) > return slot; > > - slot = search_memslots(slots, gfn, &slot_index); > + slot = search_memslots(slots, gfn, &slot_index, approx); > if (slot) { > atomic_set(&slots->last_used_slot, slot_index); > return slot; > @@ -1285,6 +1298,12 @@ __gfn_to_memslot(struct kvm_memslots *slots, gfn_t gfn) > return NULL; > } > There's a comment that doesn't show up in this diff that should also be moved, and opportunistically updated. > +static inline struct kvm_memory_slot * > +__gfn_to_memslot(struct kvm_memslots *slots, gfn_t gfn) > +{ > + return __gfn_to_memslot_approx(slots, gfn, false); > +} > + > static inline unsigned long > __gfn_to_hva_memslot(const struct kvm_memory_slot *slot, gfn_t gfn) > { E.g. this as fixup? diff --git a/arch/s390/kvm/kvm-s390.c b/arch/s390/kvm/kvm-s390.c index 540fa948baa5..2964c773b36c 100644 --- a/arch/s390/kvm/kvm-s390.c +++ b/arch/s390/kvm/kvm-s390.c @@ -1964,10 +1964,15 @@ static int kvm_s390_peek_cmma(struct kvm *kvm, struct kvm_s390_cmma_log *args, return 0; } +static int gfn_to_memslot_approx(struct kvm_memslots *slots, gfn_t gfn) +{ + return ____gfn_to_memslot(slots, cur_gfn, true); +} + static unsigned long kvm_s390_next_dirty_cmma(struct kvm_memslots *slots, unsigned long cur_gfn) { - struct kvm_memory_slot *ms = __gfn_to_memslot_approx(slots, cur_gfn, true); + struct kvm_memory_slot *ms = gfn_to_memslot_approx(slots, cur_gfn); int slotidx = ms - slots->memslots; unsigned long ofs = cur_gfn - ms->base_gfn; diff --git a/include/linux/kvm_host.h b/include/linux/kvm_host.h index 8fd9644f40b2..ec1a074c2f6e 100644 --- a/include/linux/kvm_host.h +++ b/include/linux/kvm_host.h @@ -1274,13 +1274,8 @@ search_memslots(struct kvm_memslots *slots, gfn_t gfn, int *index, bool approx) return NULL; } -/* - * __gfn_to_memslot() and its descendants are here because it is called from - * non-modular code in arch/powerpc/kvm/book3s_64_vio{,_hv}.c. gfn_to_memslot() - * itself isn't here as an inline because that would bloat other code too much. - */ static inline struct kvm_memory_slot * -__gfn_to_memslot_approx(struct kvm_memslots *slots, gfn_t gfn, bool approx) +____gfn_to_memslot(struct kvm_memslots *slots, gfn_t gfn, bool approx) { struct kvm_memory_slot *slot; int slot_index = atomic_read(&slots->last_used_slot); @@ -1298,10 +1293,15 @@ __gfn_to_memslot_approx(struct kvm_memslots *slots, gfn_t gfn, bool approx) return NULL; } +/* + * __gfn_to_memslot() and its descendants are here to allow arch code to inline + * the lookups in hot paths. gfn_to_memslot() itself isn't here as an inline + * because that would bloat other code too much. + */ static inline struct kvm_memory_slot * __gfn_to_memslot(struct kvm_memslots *slots, gfn_t gfn) { - return __gfn_to_memslot_approx(slots, gfn, false); + return ____gfn_to_memslot(slots, gfn, false); } static inline unsigned long
On 20.10.2021 01:38, Sean Christopherson wrote: > On Mon, Sep 20, 2021, Maciej S. Szmigiero wrote: >> @@ -1267,7 +1280,7 @@ search_memslots(struct kvm_memslots *slots, gfn_t gfn, int *index) >> * itself isn't here as an inline because that would bloat other code too much. >> */ >> static inline struct kvm_memory_slot * >> -__gfn_to_memslot(struct kvm_memslots *slots, gfn_t gfn) >> +__gfn_to_memslot_approx(struct kvm_memslots *slots, gfn_t gfn, bool approx) > > This function name is a misnomer. The helper is not an "approx" version, it's an > inner helper that takes an @approx param. Unless someone has a more clever name, > the dreaded four underscores seems like the way to go. Warning away users is a > good thing in this case... > >> { >> struct kvm_memory_slot *slot; >> int slot_index = atomic_read(&slots->last_used_slot); >> @@ -1276,7 +1289,7 @@ __gfn_to_memslot(struct kvm_memslots *slots, gfn_t gfn) >> if (slot) >> return slot; >> >> - slot = search_memslots(slots, gfn, &slot_index); >> + slot = search_memslots(slots, gfn, &slot_index, approx); >> if (slot) { >> atomic_set(&slots->last_used_slot, slot_index); >> return slot; >> @@ -1285,6 +1298,12 @@ __gfn_to_memslot(struct kvm_memslots *slots, gfn_t gfn) >> return NULL; >> } >> > > There's a comment that doesn't show up in this diff that should also be moved, > and opportunistically updated. > >> +static inline struct kvm_memory_slot * >> +__gfn_to_memslot(struct kvm_memslots *slots, gfn_t gfn) >> +{ >> + return __gfn_to_memslot_approx(slots, gfn, false); >> +} >> + >> static inline unsigned long >> __gfn_to_hva_memslot(const struct kvm_memory_slot *slot, gfn_t gfn) >> { > > E.g. this as fixup? > > diff --git a/arch/s390/kvm/kvm-s390.c b/arch/s390/kvm/kvm-s390.c > index 540fa948baa5..2964c773b36c 100644 > --- a/arch/s390/kvm/kvm-s390.c > +++ b/arch/s390/kvm/kvm-s390.c > @@ -1964,10 +1964,15 @@ static int kvm_s390_peek_cmma(struct kvm *kvm, struct kvm_s390_cmma_log *args, > return 0; > } > > +static int gfn_to_memslot_approx(struct kvm_memslots *slots, gfn_t gfn) > +{ > + return ____gfn_to_memslot(slots, cur_gfn, true); > +} > + > static unsigned long kvm_s390_next_dirty_cmma(struct kvm_memslots *slots, > unsigned long cur_gfn) > { > - struct kvm_memory_slot *ms = __gfn_to_memslot_approx(slots, cur_gfn, true); > + struct kvm_memory_slot *ms = gfn_to_memslot_approx(slots, cur_gfn); > int slotidx = ms - slots->memslots; > unsigned long ofs = cur_gfn - ms->base_gfn; > > diff --git a/include/linux/kvm_host.h b/include/linux/kvm_host.h > index 8fd9644f40b2..ec1a074c2f6e 100644 > --- a/include/linux/kvm_host.h > +++ b/include/linux/kvm_host.h > @@ -1274,13 +1274,8 @@ search_memslots(struct kvm_memslots *slots, gfn_t gfn, int *index, bool approx) > return NULL; > } > > -/* > - * __gfn_to_memslot() and its descendants are here because it is called from > - * non-modular code in arch/powerpc/kvm/book3s_64_vio{,_hv}.c. gfn_to_memslot() > - * itself isn't here as an inline because that would bloat other code too much. > - */ > static inline struct kvm_memory_slot * > -__gfn_to_memslot_approx(struct kvm_memslots *slots, gfn_t gfn, bool approx) > +____gfn_to_memslot(struct kvm_memslots *slots, gfn_t gfn, bool approx) > { > struct kvm_memory_slot *slot; > int slot_index = atomic_read(&slots->last_used_slot); > @@ -1298,10 +1293,15 @@ __gfn_to_memslot_approx(struct kvm_memslots *slots, gfn_t gfn, bool approx) > return NULL; > } > > +/* > + * __gfn_to_memslot() and its descendants are here to allow arch code to inline > + * the lookups in hot paths. gfn_to_memslot() itself isn't here as an inline > + * because that would bloat other code too much. > + */ > static inline struct kvm_memory_slot * > __gfn_to_memslot(struct kvm_memslots *slots, gfn_t gfn) > { > - return __gfn_to_memslot_approx(slots, gfn, false); > + return ____gfn_to_memslot(slots, gfn, false); > } > > static inline unsigned long > Looks sensible, will apply your proposed changes. Thanks, Maciej
diff --git a/arch/s390/kvm/kvm-s390.c b/arch/s390/kvm/kvm-s390.c index 3fd0f4afe742..540fa948baa5 100644 --- a/arch/s390/kvm/kvm-s390.c +++ b/arch/s390/kvm/kvm-s390.c @@ -1941,41 +1941,6 @@ static long kvm_s390_set_skeys(struct kvm *kvm, struct kvm_s390_skeys *args) /* for consistency */ #define KVM_S390_CMMA_SIZE_MAX ((u32)KVM_S390_SKEYS_MAX) -/* - * Similar to gfn_to_memslot, but returns the index of a memslot also when the - * address falls in a hole. In that case the index of one of the memslots - * bordering the hole is returned. - */ -static int gfn_to_memslot_approx(struct kvm_memslots *slots, gfn_t gfn) -{ - int start = 0, end = slots->used_slots; - int slot = atomic_read(&slots->last_used_slot); - struct kvm_memory_slot *memslots = slots->memslots; - - if (gfn >= memslots[slot].base_gfn && - gfn < memslots[slot].base_gfn + memslots[slot].npages) - return slot; - - while (start < end) { - slot = start + (end - start) / 2; - - if (gfn >= memslots[slot].base_gfn) - end = slot; - else - start = slot + 1; - } - - if (start >= slots->used_slots) - return slots->used_slots - 1; - - if (gfn >= memslots[start].base_gfn && - gfn < memslots[start].base_gfn + memslots[start].npages) { - atomic_set(&slots->last_used_slot, start); - } - - return start; -} - static int kvm_s390_peek_cmma(struct kvm *kvm, struct kvm_s390_cmma_log *args, u8 *res, unsigned long bufsize) { @@ -2002,8 +1967,8 @@ static int kvm_s390_peek_cmma(struct kvm *kvm, struct kvm_s390_cmma_log *args, static unsigned long kvm_s390_next_dirty_cmma(struct kvm_memslots *slots, unsigned long cur_gfn) { - int slotidx = gfn_to_memslot_approx(slots, cur_gfn); - struct kvm_memory_slot *ms = slots->memslots + slotidx; + struct kvm_memory_slot *ms = __gfn_to_memslot_approx(slots, cur_gfn, true); + int slotidx = ms - slots->memslots; unsigned long ofs = cur_gfn - ms->base_gfn; if (ms->base_gfn + ms->npages <= cur_gfn) { diff --git a/include/linux/kvm_host.h b/include/linux/kvm_host.h index c6963f6f1eb8..8fd9644f40b2 100644 --- a/include/linux/kvm_host.h +++ b/include/linux/kvm_host.h @@ -1231,10 +1231,14 @@ try_get_memslot(struct kvm_memslots *slots, int slot_index, gfn_t gfn) * Returns a pointer to the memslot that contains gfn and records the index of * the slot in index. Otherwise returns NULL. * + * With "approx" set returns the memslot also when the address falls + * in a hole. In that case one of the memslots bordering the hole is + * returned. + * * IMPORTANT: Slots are sorted from highest GFN to lowest GFN! */ static inline struct kvm_memory_slot * -search_memslots(struct kvm_memslots *slots, gfn_t gfn, int *index) +search_memslots(struct kvm_memslots *slots, gfn_t gfn, int *index, bool approx) { int start = 0, end = slots->used_slots; struct kvm_memory_slot *memslots = slots->memslots; @@ -1252,11 +1256,20 @@ search_memslots(struct kvm_memslots *slots, gfn_t gfn, int *index) start = slot + 1; } + if (approx && start >= slots->used_slots) { + *index = slots->used_slots - 1; + return &memslots[slots->used_slots - 1]; + } + slot = try_get_memslot(slots, start, gfn); if (slot) { *index = start; return slot; } + if (approx) { + *index = start; + return &memslots[start]; + } return NULL; } @@ -1267,7 +1280,7 @@ search_memslots(struct kvm_memslots *slots, gfn_t gfn, int *index) * itself isn't here as an inline because that would bloat other code too much. */ static inline struct kvm_memory_slot * -__gfn_to_memslot(struct kvm_memslots *slots, gfn_t gfn) +__gfn_to_memslot_approx(struct kvm_memslots *slots, gfn_t gfn, bool approx) { struct kvm_memory_slot *slot; int slot_index = atomic_read(&slots->last_used_slot); @@ -1276,7 +1289,7 @@ __gfn_to_memslot(struct kvm_memslots *slots, gfn_t gfn) if (slot) return slot; - slot = search_memslots(slots, gfn, &slot_index); + slot = search_memslots(slots, gfn, &slot_index, approx); if (slot) { atomic_set(&slots->last_used_slot, slot_index); return slot; @@ -1285,6 +1298,12 @@ __gfn_to_memslot(struct kvm_memslots *slots, gfn_t gfn) return NULL; } +static inline struct kvm_memory_slot * +__gfn_to_memslot(struct kvm_memslots *slots, gfn_t gfn) +{ + return __gfn_to_memslot_approx(slots, gfn, false); +} + static inline unsigned long __gfn_to_hva_memslot(const struct kvm_memory_slot *slot, gfn_t gfn) { diff --git a/virt/kvm/kvm_main.c b/virt/kvm/kvm_main.c index c3c71a9e85c9..14043a6edb88 100644 --- a/virt/kvm/kvm_main.c +++ b/virt/kvm/kvm_main.c @@ -2062,7 +2062,7 @@ struct kvm_memory_slot *kvm_vcpu_gfn_to_memslot(struct kvm_vcpu *vcpu, gfn_t gfn * search_memslots() instead of __gfn_to_memslot() to avoid * thrashing the VM-wide last_used_index in kvm_memslots. */ - slot = search_memslots(slots, gfn, &slot_index); + slot = search_memslots(slots, gfn, &slot_index, false); if (slot) { vcpu->last_used_slot = slot_index; return slot;