mbox series

[v5,0/4] power: supply: extension API

Message ID 20241205-power-supply-extensions-v5-0-f0f996db4347@weissschuh.net (mailing list archive)
Headers show
Series power: supply: extension API | expand

Message

Thomas Weißschuh Dec. 5, 2024, 8:46 p.m. UTC
Introduce a mechanism for drivers to extend the properties implemented
by a power supply.

Motivation
----------

Various drivers, mostly in platform/x86 extend the ACPI battery driver
with additional sysfs attributes to implement more UAPIs than are
exposed through ACPI by using various side-channels, like WMI,
nonstandard ACPI or EC communication.

While the created sysfs attributes look similar to the attributes
provided by the powersupply core, there are various deficiencies:

* They don't show up in uevent payload.
* They can't be queried with the standard in-kernel APIs.
* They don't work with triggers.
* The extending driver has to reimplement all of the parsing,
  formatting and sysfs display logic.
* Writing a extension driver is completely different from writing a
  normal power supply driver.
* ~Properties can not be properly overriden.~
  (Overriding is now explicitly forbidden)

The proposed extension API avoids all of these issues.
An extension is just a "struct power_supply_ext" with the same kind of
callbacks as in a normal "struct power_supply_desc".

The API is meant to be used via battery_hook_register(), the same way as
the current extensions.
Further usecases are fuel gauges and the existing battery_info
properties.

When testing, please enable lockdep to make sure the locking is correct.

The series is based on the linux-power-supply/for-next branch.

Contents
--------

* Patch 1 cleans up the logging messages of the ACPI battery hooks
* Patch 2 implements the extension API itself.
* Patch 3 adds extension support to test_power.c
* Patch 4 converts the in-tree cros_charge-control driver to the
  extension API.

Open issues
-----------

* As this is only useful with the hooks of CONFIG_ACPI_BATTERY, should
  it also be gated behind this or another config?
* Is an rw_semaphore acceptable?

[0] https://lore.kernel.org/lkml/20240528-cros_ec-charge-control-v2-0-81fb27e1cff4@weissschuh.net/

Signed-off-by: Thomas Weißschuh <linux@weissschuh.net>
---
Changes in v5:
- Drop already picked up patches
- Simplify power_supply_ext_has_property()
- Handle failure of power_supply_update_sysfs_and_hwmon()
- Reduce some locking scopes
- Add missing locking to power_supply_show_charge_behaviour()
- Improve sanity checks in power_supply_register_extension()
- Implement writeable property in test_power battery
- Rename ACPI battery hook messages for clarity
- Link to v4: https://lore.kernel.org/r/20241111-power-supply-extensions-v4-0-7240144daa8e@weissschuh.net

Changes in v4:
- Drop RFC state
- Integrate locking commit
- Reregister hwmon device
- Link to v3: https://lore.kernel.org/r/20240904-power-supply-extensions-v3-0-62efeb93f8ec@weissschuh.net

Changes in v3:
- Make naming more consistent
- Readd locking
- Allow multiple active extensions
- Allow passing a "void *ext_data" when registering
- Switch example driver from system76 to cros_charge-control
- Link to v2: https://lore.kernel.org/r/20240608-power-supply-extensions-v2-0-2dcd35b012ad@weissschuh.net

Changes in v2:
- Drop locking patch, let's figure out the API first
- Allow registration of multiple extensions
- Pass extension to extension callbacks as parameter
- Disallow property overlap between extensions and core psy
- Drop system76/pdx86 maintainers, as the system76 changes are only RFC
  state anyways
- Link to v1: https://lore.kernel.org/r/20240606-power-supply-extensions-v1-0-b45669290bdc@weissschuh.net

---
Thomas Weißschuh (4):
      ACPI: battery: Rename extensions to hook in messages
      power: supply: core: implement extension API
      power: supply: test-power: implement a power supply extension
      power: supply: cros_charge-control: implement a power supply extension

 drivers/acpi/battery.c                     |  14 +-
 drivers/power/supply/cros_charge-control.c | 217 ++++++++++++-----------------
 drivers/power/supply/power_supply.h        |  14 ++
 drivers/power/supply/power_supply_core.c   | 159 +++++++++++++++++++--
 drivers/power/supply/power_supply_sysfs.c  |  26 +++-
 drivers/power/supply/test_power.c          | 111 +++++++++++++++
 include/linux/power_supply.h               |  32 +++++
 7 files changed, 427 insertions(+), 146 deletions(-)
---
base-commit: 39f3bd9c9a27d526858da153090376decdf7bfea
change-id: 20240602-power-supply-extensions-07d949f509d9

Best regards,