Message ID | 20200128090636.13689-1-ludovic.barre@st.com (mailing list archive) |
---|---|
Headers | show |
Series | mmc: mmci: sdmmc: add sdr104 support | expand |
hi Ulf Just a "gentleman ping" on this series https://patchwork.kernel.org/project/linux-mmc/list/?series=234011 Regards Ludo Le 1/28/20 à 10:06 AM, Ludovic Barre a écrit : > To support the sdr104 mode, sdmmc variant needs: > -Hardware delay block support for sdmmc variant > with tuning procedure > -Voltage switch callbacks > -sdmmc revision 2.0 > > V2: > -regroup host->mmc_ops & mmc->ops assignment > -add timeout define > -rename prep_volt_switch to pre_sig_volt_switch > -rename volt_switch to post_sig_volt_switch > -add 'why' comment for "mmc: mmci: add volt_switch callbacks" > > Ludovic Barre (9): > mmc: mmci: sdmmc: replace sg_dma_xxx macros > mmc: mmci: sdmmc: rename sdmmc_priv struct to sdmmc_idma > mmc: mmci: add a reference at mmc_host_ops in mmci struct > mmc: mmci: add private pointer for variant > dt-bindings: mmc: mmci: add delay block base register for sdmmc > mmc: mmci: sdmmc: add execute tuning with delay block > mmc: mmci: add volt_switch callbacks > mmc: mmci: sdmmc: add voltage switch functions > mmc: mmci: add sdmmc variant revision 2.0 > > .../devicetree/bindings/mmc/mmci.txt | 2 + > drivers/mmc/host/mmci.c | 42 +++- > drivers/mmc/host/mmci.h | 8 + > drivers/mmc/host/mmci_stm32_sdmmc.c | 204 +++++++++++++++++- > 4 files changed, 248 insertions(+), 8 deletions(-) >
On Tue, 11 Feb 2020 at 15:47, Ludovic BARRE <ludovic.barre@st.com> wrote: > > hi Ulf > > Just a "gentleman ping" on this series > https://patchwork.kernel.org/project/linux-mmc/list/?series=234011 I will have a look later this week. The merge window closed yesterday and normally I don't queue anything but fixes during the merge window. Anyway, apologize for the delays. Kind regards Uffe > > Regards > Ludo > > Le 1/28/20 à 10:06 AM, Ludovic Barre a écrit : > > To support the sdr104 mode, sdmmc variant needs: > > -Hardware delay block support for sdmmc variant > > with tuning procedure > > -Voltage switch callbacks > > -sdmmc revision 2.0 > > > > V2: > > -regroup host->mmc_ops & mmc->ops assignment > > -add timeout define > > -rename prep_volt_switch to pre_sig_volt_switch > > -rename volt_switch to post_sig_volt_switch > > -add 'why' comment for "mmc: mmci: add volt_switch callbacks" > > > > Ludovic Barre (9): > > mmc: mmci: sdmmc: replace sg_dma_xxx macros > > mmc: mmci: sdmmc: rename sdmmc_priv struct to sdmmc_idma > > mmc: mmci: add a reference at mmc_host_ops in mmci struct > > mmc: mmci: add private pointer for variant > > dt-bindings: mmc: mmci: add delay block base register for sdmmc > > mmc: mmci: sdmmc: add execute tuning with delay block > > mmc: mmci: add volt_switch callbacks > > mmc: mmci: sdmmc: add voltage switch functions > > mmc: mmci: add sdmmc variant revision 2.0 > > > > .../devicetree/bindings/mmc/mmci.txt | 2 + > > drivers/mmc/host/mmci.c | 42 +++- > > drivers/mmc/host/mmci.h | 8 + > > drivers/mmc/host/mmci_stm32_sdmmc.c | 204 +++++++++++++++++- > > 4 files changed, 248 insertions(+), 8 deletions(-) > >
On Tue, 28 Jan 2020 at 10:06, Ludovic Barre <ludovic.barre@st.com> wrote: > > To support the sdr104 mode, sdmmc variant needs: > -Hardware delay block support for sdmmc variant > with tuning procedure > -Voltage switch callbacks > -sdmmc revision 2.0 > > V2: > -regroup host->mmc_ops & mmc->ops assignment > -add timeout define > -rename prep_volt_switch to pre_sig_volt_switch > -rename volt_switch to post_sig_volt_switch > -add 'why' comment for "mmc: mmci: add volt_switch callbacks" > > Ludovic Barre (9): > mmc: mmci: sdmmc: replace sg_dma_xxx macros > mmc: mmci: sdmmc: rename sdmmc_priv struct to sdmmc_idma > mmc: mmci: add a reference at mmc_host_ops in mmci struct > mmc: mmci: add private pointer for variant > dt-bindings: mmc: mmci: add delay block base register for sdmmc > mmc: mmci: sdmmc: add execute tuning with delay block > mmc: mmci: add volt_switch callbacks > mmc: mmci: sdmmc: add voltage switch functions > mmc: mmci: add sdmmc variant revision 2.0 > > .../devicetree/bindings/mmc/mmci.txt | 2 + > drivers/mmc/host/mmci.c | 42 +++- > drivers/mmc/host/mmci.h | 8 + > drivers/mmc/host/mmci_stm32_sdmmc.c | 204 +++++++++++++++++- > 4 files changed, 248 insertions(+), 8 deletions(-) > > -- > 2.17.1 > Applied for next, thanks! I took the liberty to do minor amendments to some of the changelogs, but in particular I have change some of prefixes for the commit message headers into "mmc: mmci_sdmmc:". Please tell, if there is anything that you want me to update. Kind regards Uffe
hi Ulf Le 2/19/20 à 11:28 AM, Ulf Hansson a écrit : > On Tue, 28 Jan 2020 at 10:06, Ludovic Barre <ludovic.barre@st.com> wrote: >> >> To support the sdr104 mode, sdmmc variant needs: >> -Hardware delay block support for sdmmc variant >> with tuning procedure >> -Voltage switch callbacks >> -sdmmc revision 2.0 >> >> V2: >> -regroup host->mmc_ops & mmc->ops assignment >> -add timeout define >> -rename prep_volt_switch to pre_sig_volt_switch >> -rename volt_switch to post_sig_volt_switch >> -add 'why' comment for "mmc: mmci: add volt_switch callbacks" >> >> Ludovic Barre (9): >> mmc: mmci: sdmmc: replace sg_dma_xxx macros >> mmc: mmci: sdmmc: rename sdmmc_priv struct to sdmmc_idma >> mmc: mmci: add a reference at mmc_host_ops in mmci struct >> mmc: mmci: add private pointer for variant >> dt-bindings: mmc: mmci: add delay block base register for sdmmc >> mmc: mmci: sdmmc: add execute tuning with delay block >> mmc: mmci: add volt_switch callbacks >> mmc: mmci: sdmmc: add voltage switch functions >> mmc: mmci: add sdmmc variant revision 2.0 >> >> .../devicetree/bindings/mmc/mmci.txt | 2 + >> drivers/mmc/host/mmci.c | 42 +++- >> drivers/mmc/host/mmci.h | 8 + >> drivers/mmc/host/mmci_stm32_sdmmc.c | 204 +++++++++++++++++- >> 4 files changed, 248 insertions(+), 8 deletions(-) >> >> -- >> 2.17.1 >> > > Applied for next, thanks! thanks Ulf. > > I took the liberty to do minor amendments to some of the changelogs, > but in particular I have change some of prefixes for the commit > message headers into "mmc: mmci_sdmmc:". Ok, I use this prefixe for next commit. > > Please tell, if there is anything that you want me to update. I tested your next branch, and it's ok for me. sdmmc upstream is almost finished, I just some recent fixes to send. > > Kind regards > Uffe >