mbox series

[v2,0/2] arm64 sigreturn unwinding fixes

Message ID 20200519162821.16857-1-will@kernel.org (mailing list archive)
Headers show
Series arm64 sigreturn unwinding fixes | expand

Message

Will Deacon May 19, 2020, 4:28 p.m. UTC
Hi again,

Hot off the press, here's v2 of the sigreturn unwinding fixes I sent out
early on today:

  https://lore.kernel.org/r/20200519121818.14511-1-will@kernel.org

Changes since v1 include:

  * Retain all CFI directives, as they are needed for unwinding after all
  * Add tonnes of comments
  * Squash the last two patches
  * Use SYM_CODE_{START,END} instead of open-coding it
  * Update Fixes: tag

Please have a look, and give it a spin with your favourite unwinder.

Ta,

Will

Cc: Dave Martin <dave.martin@arm.com>
Cc: Tamas Zsoldos <tamas.zsoldos@arm.com> 
Cc: Daniel Kiss <daniel.kiss@arm.com>
Cc: Mark Brown <broonie@kernel.org>
Cc: <kernel-team@android.com>

--->8

Will Deacon (2):
  arm64: vdso: Don't prefix sigreturn trampoline with a BTI C
    instruction
  arm64: vdso: Fix CFI directives in sigreturn trampoline

 arch/arm64/kernel/vdso/sigreturn.S   | 47 +++++++++++++++++++++++-----
 arch/arm64/kernel/vdso32/sigreturn.S | 16 +++++-----
 2 files changed, 48 insertions(+), 15 deletions(-)