Message ID | 20191030153837.18107-2-qais.yousef@arm.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | [01/12] arm64: hibernate.c: create a new function to handle cpu_up(sleep_cpu) | expand |
On Wed, 30 Oct 2019, Qais Yousef wrote: > > +int hibernation_bringup_sleep_cpu(unsigned int sleep_cpu) That function name is horrible. Aside of that I really have to ask how you end up hibernating on an offline CPU? > +{ > + int ret; > + > + if (!cpu_online(sleep_cpu)) { > + pr_info("Hibernated on a CPU that is offline! Bringing CPU up.\n"); > + ret = cpu_up(sleep_cpu); > + if (ret) { > + pr_err("Failed to bring hibernate-CPU up!\n"); > + return ret; > + } > + } > +} Thanks, tglx
On 11/19/19 23:31, Thomas Gleixner wrote: > On Wed, 30 Oct 2019, Qais Yousef wrote: > > > > +int hibernation_bringup_sleep_cpu(unsigned int sleep_cpu) > > That function name is horrible. Aside of that I really have to ask how you > end up hibernating on an offline CPU? James Morse can probably explain better. But AFAIU we could sleep on any CPU, but on the next cold boot that CPU could become offline as a side effect of using maxcpus= for example. How about bringup_hibernate_cpu() as a name? I could add the above as an explanation of why we need this call too. It does seem to me that this is a generic problem that we might be able to handle generically, but I'm not sure how. Thanks -- Qais Yousef
On Tue, 19 Nov 2019, Qais Yousef wrote: > On 11/19/19 23:31, Thomas Gleixner wrote: > > On Wed, 30 Oct 2019, Qais Yousef wrote: > > > > > > +int hibernation_bringup_sleep_cpu(unsigned int sleep_cpu) > > > > That function name is horrible. Aside of that I really have to ask how you > > end up hibernating on an offline CPU? > > James Morse can probably explain better. > > But AFAIU we could sleep on any CPU, but on the next cold boot that CPU could > become offline as a side effect of using maxcpus= for example. > > How about bringup_hibernate_cpu() as a name? I could add the above as an > explanation of why we need this call too. > > It does seem to me that this is a generic problem that we might be able to > handle generically, but I'm not sure how. Don't know about other architectures, but x86 does not have that issue as we force hibernation on CPU0 for historical reasons (Broken BIOSes etc.). Thanks, tglx
On 11/20/19 00:01, Thomas Gleixner wrote: > On Tue, 19 Nov 2019, Qais Yousef wrote: > > On 11/19/19 23:31, Thomas Gleixner wrote: > > > On Wed, 30 Oct 2019, Qais Yousef wrote: > > > > > > > > +int hibernation_bringup_sleep_cpu(unsigned int sleep_cpu) > > > > > > That function name is horrible. Aside of that I really have to ask how you > > > end up hibernating on an offline CPU? > > > > James Morse can probably explain better. > > > > But AFAIU we could sleep on any CPU, but on the next cold boot that CPU could > > become offline as a side effect of using maxcpus= for example. > > > > How about bringup_hibernate_cpu() as a name? I could add the above as an > > explanation of why we need this call too. > > > > It does seem to me that this is a generic problem that we might be able to > > handle generically, but I'm not sure how. > > Don't know about other architectures, but x86 does not have that issue as > we force hibernation on CPU0 for historical reasons (Broken BIOSes etc.). I'll avoid making this series bigger then. Thanks -- Qais Yousef
diff --git a/arch/arm64/kernel/hibernate.c b/arch/arm64/kernel/hibernate.c index e0a7fce0e01c..3b178055022f 100644 --- a/arch/arm64/kernel/hibernate.c +++ b/arch/arm64/kernel/hibernate.c @@ -166,14 +166,11 @@ int arch_hibernation_header_restore(void *addr) sleep_cpu = -EINVAL; return -EINVAL; } - if (!cpu_online(sleep_cpu)) { - pr_info("Hibernated on a CPU that is offline! Bringing CPU up.\n"); - ret = cpu_up(sleep_cpu); - if (ret) { - pr_err("Failed to bring hibernate-CPU up!\n"); - sleep_cpu = -EINVAL; - return ret; - } + + ret = hibernation_bringup_sleep_cpu(sleep_cpu); + if (ret) { + sleep_cpu = -EINVAL; + return ret; } resume_hdr = *hdr; diff --git a/include/linux/cpu.h b/include/linux/cpu.h index 88dc0c653925..3b1fbe192989 100644 --- a/include/linux/cpu.h +++ b/include/linux/cpu.h @@ -87,6 +87,7 @@ int cpu_up(unsigned int cpu); void notify_cpu_starting(unsigned int cpu); extern void cpu_maps_update_begin(void); extern void cpu_maps_update_done(void); +extern int hibernation_bringup_sleep_cpu(unsigned int sleep_cpu); #else /* CONFIG_SMP */ #define cpuhp_tasks_frozen 0 diff --git a/kernel/cpu.c b/kernel/cpu.c index e1967e9eddc2..219f9033f438 100644 --- a/kernel/cpu.c +++ b/kernel/cpu.c @@ -1197,6 +1197,20 @@ int cpu_up(unsigned int cpu) } EXPORT_SYMBOL_GPL(cpu_up); +int hibernation_bringup_sleep_cpu(unsigned int sleep_cpu) +{ + int ret; + + if (!cpu_online(sleep_cpu)) { + pr_info("Hibernated on a CPU that is offline! Bringing CPU up.\n"); + ret = cpu_up(sleep_cpu); + if (ret) { + pr_err("Failed to bring hibernate-CPU up!\n"); + return ret; + } + } +} + #ifdef CONFIG_PM_SLEEP_SMP static cpumask_var_t frozen_cpus;
In preparation to make cpu_up/down private - move the user in arm64 hibernate.c to use a new generic function that provides what arm64 needs. Signed-off-by: Qais Yousef <qais.yousef@arm.com> CC: Catalin Marinas <catalin.marinas@arm.com> CC: Will Deacon <will@kernel.org> CC: Steve Capper <steve.capper@arm.com> CC: Richard Fontana <rfontana@redhat.com> CC: James Morse <james.morse@arm.com> CC: Mark Rutland <mark.rutland@arm.com> CC: Thomas Gleixner <tglx@linutronix.de> CC: Josh Poimboeuf <jpoimboe@redhat.com> CC: Ingo Molnar <mingo@kernel.org> CC: "Peter Zijlstra (Intel)" <peterz@infradead.org> CC: Nicholas Piggin <npiggin@gmail.com> CC: Daniel Lezcano <daniel.lezcano@linaro.org> CC: Jiri Kosina <jkosina@suse.cz> CC: Pavankumar Kondeti <pkondeti@codeaurora.org> CC: Zhenzhong Duan <zhenzhong.duan@oracle.com> CC: linux-arm-kernel@lists.infradead.org CC: linux-kernel@vger.kernel.org --- AFAICT we can't use device_online() directly here because suspend happens via cpu_down() not device_offline(). If it is actually safe to use device_online() then that would be simpler than creating the new function. Although the operation seems generic enough to me and could benefit another arch user in the future so the new function makes sense. arch/arm64/kernel/hibernate.c | 13 +++++-------- include/linux/cpu.h | 1 + kernel/cpu.c | 14 ++++++++++++++ 3 files changed, 20 insertions(+), 8 deletions(-)