Message ID | 20201030100815.2269-9-daniel.vetter@ffwll.ch (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | follow_pfn and other iomap races | expand |
On Fri, Oct 30, 2020 at 11:08:08AM +0100, Daniel Vetter wrote: > Also mark up follow_pfn as EXPORT_SYMBOL_GPL. The only safe way to use > that by drivers/modules is together with an mmu_notifier, and that's > all _GPL stuff. I also think it also needs to be renamed to explicitly break any existing users out of tree or int the submission queue.
On Mon, Nov 2, 2020 at 8:29 AM Christoph Hellwig <hch@infradead.org> wrote: > > On Fri, Oct 30, 2020 at 11:08:08AM +0100, Daniel Vetter wrote: > > Also mark up follow_pfn as EXPORT_SYMBOL_GPL. The only safe way to use > > that by drivers/modules is together with an mmu_notifier, and that's > > all _GPL stuff. > > I also think it also needs to be renamed to explicitly break any existing > users out of tree or int the submission queue. Ok I looked at the mmu notifier locking again and noticed that mm->subscriptions has its own spinlock. Since there usually shouldn't be a huge pile of these I think it's feasible to check for the mmu notifier in follow_pfn. And that would stuff this gap for good. I'll throw that on top as a final patch and see what people think. -Daniel
On Mon, Nov 02, 2020 at 01:56:10PM +0100, Daniel Vetter wrote: > On Mon, Nov 2, 2020 at 8:29 AM Christoph Hellwig <hch@infradead.org> wrote: > > > > On Fri, Oct 30, 2020 at 11:08:08AM +0100, Daniel Vetter wrote: > > > Also mark up follow_pfn as EXPORT_SYMBOL_GPL. The only safe way to use > > > that by drivers/modules is together with an mmu_notifier, and that's > > > all _GPL stuff. > > > > I also think it also needs to be renamed to explicitly break any existing > > users out of tree or int the submission queue. > > Ok I looked at the mmu notifier locking again and noticed that > mm->subscriptions has its own spinlock. Since there usually shouldn't > be a huge pile of these I think it's feasible to check for the mmu > notifier in follow_pfn. And that would stuff this gap for good. I'll > throw that on top as a final patch and see what people think. Probably the simplest is to just check mm_has_notifiers() when in lockdep or something very simple like that Jason
On Mon, Nov 2, 2020 at 2:01 PM Jason Gunthorpe <jgg@ziepe.ca> wrote: > > On Mon, Nov 02, 2020 at 01:56:10PM +0100, Daniel Vetter wrote: > > On Mon, Nov 2, 2020 at 8:29 AM Christoph Hellwig <hch@infradead.org> wrote: > > > > > > On Fri, Oct 30, 2020 at 11:08:08AM +0100, Daniel Vetter wrote: > > > > Also mark up follow_pfn as EXPORT_SYMBOL_GPL. The only safe way to use > > > > that by drivers/modules is together with an mmu_notifier, and that's > > > > all _GPL stuff. > > > > > > I also think it also needs to be renamed to explicitly break any existing > > > users out of tree or int the submission queue. > > > > Ok I looked at the mmu notifier locking again and noticed that > > mm->subscriptions has its own spinlock. Since there usually shouldn't > > be a huge pile of these I think it's feasible to check for the mmu > > notifier in follow_pfn. And that would stuff this gap for good. I'll > > throw that on top as a final patch and see what people think. > > Probably the simplest is to just check mm_has_notifiers() when in > lockdep or something very simple like that lockdep feels wrong, was locking more at CONFIG_DEBUG_VM. And since generally you only have 1 mmu notifier (especially for kvm) I think we can also pay the 2nd cacheline miss and actually check the right mmu notifier is registered. -Daniel
On Mon, Nov 02, 2020 at 02:23:58PM +0100, Daniel Vetter wrote: > On Mon, Nov 2, 2020 at 2:01 PM Jason Gunthorpe <jgg@ziepe.ca> wrote: > > > > On Mon, Nov 02, 2020 at 01:56:10PM +0100, Daniel Vetter wrote: > > > On Mon, Nov 2, 2020 at 8:29 AM Christoph Hellwig <hch@infradead.org> wrote: > > > > > > > > On Fri, Oct 30, 2020 at 11:08:08AM +0100, Daniel Vetter wrote: > > > > > Also mark up follow_pfn as EXPORT_SYMBOL_GPL. The only safe way to use > > > > > that by drivers/modules is together with an mmu_notifier, and that's > > > > > all _GPL stuff. > > > > > > > > I also think it also needs to be renamed to explicitly break any existing > > > > users out of tree or int the submission queue. > > > > > > Ok I looked at the mmu notifier locking again and noticed that > > > mm->subscriptions has its own spinlock. Since there usually shouldn't > > > be a huge pile of these I think it's feasible to check for the mmu > > > notifier in follow_pfn. And that would stuff this gap for good. I'll > > > throw that on top as a final patch and see what people think. > > > > Probably the simplest is to just check mm_has_notifiers() when in > > lockdep or something very simple like that > > lockdep feels wrong, was locking more at CONFIG_DEBUG_VM. And since > generally you only have 1 mmu notifier (especially for kvm) I think we > can also pay the 2nd cacheline miss and actually check the right mmu > notifier is registered. Need to hold the lock to check that and there are two ways to register notifiers these days, so it feels to expensive to me. CH's 'export symbol only for kvm' really does seem the most robust way to handle this though. Jason
On Mon, Nov 02, 2020 at 11:52:56AM -0400, Jason Gunthorpe wrote: > Need to hold the lock to check that and there are two ways to register > notifiers these days, so it feels to expensive to me. > > CH's 'export symbol only for kvm' really does seem the most robust way > to handle this though. I hope I can get that done for this merge window, but I'm not sure. I still think we should at least have a new name for the old follow_pfn that no one should use. And it should sound more scary than unsafe_follow_pfn :)
On Mon, Nov 2, 2020 at 4:52 PM Jason Gunthorpe <jgg@ziepe.ca> wrote: > > On Mon, Nov 02, 2020 at 02:23:58PM +0100, Daniel Vetter wrote: > > On Mon, Nov 2, 2020 at 2:01 PM Jason Gunthorpe <jgg@ziepe.ca> wrote: > > > > > > On Mon, Nov 02, 2020 at 01:56:10PM +0100, Daniel Vetter wrote: > > > > On Mon, Nov 2, 2020 at 8:29 AM Christoph Hellwig <hch@infradead.org> wrote: > > > > > > > > > > On Fri, Oct 30, 2020 at 11:08:08AM +0100, Daniel Vetter wrote: > > > > > > Also mark up follow_pfn as EXPORT_SYMBOL_GPL. The only safe way to use > > > > > > that by drivers/modules is together with an mmu_notifier, and that's > > > > > > all _GPL stuff. > > > > > > > > > > I also think it also needs to be renamed to explicitly break any existing > > > > > users out of tree or int the submission queue. > > > > > > > > Ok I looked at the mmu notifier locking again and noticed that > > > > mm->subscriptions has its own spinlock. Since there usually shouldn't > > > > be a huge pile of these I think it's feasible to check for the mmu > > > > notifier in follow_pfn. And that would stuff this gap for good. I'll > > > > throw that on top as a final patch and see what people think. > > > > > > Probably the simplest is to just check mm_has_notifiers() when in > > > lockdep or something very simple like that > > > > lockdep feels wrong, was locking more at CONFIG_DEBUG_VM. And since > > generally you only have 1 mmu notifier (especially for kvm) I think we > > can also pay the 2nd cacheline miss and actually check the right mmu > > notifier is registered. > > Need to hold the lock to check that and there are two ways to register > notifiers these days, so it feels to expensive to me. Uh I mixed stuff up all along, struct mmu_notifier *subcription that all the mmu notifier users use has the ->mm pointer we want right there. That's good enough I think. Now I'm kinda lost in kvm code trying to wire it through, but it's looking ok-ish thus far :-) -Daniel > CH's 'export symbol only for kvm' really does seem the most robust way > to handle this though. > > Jason
On Mon, Nov 02, 2020 at 05:42:20PM +0100, Daniel Vetter wrote: > > Need to hold the lock to check that and there are two ways to register > > notifiers these days, so it feels to expensive to me. > > Uh I mixed stuff up all along, struct mmu_notifier *subcription that > all the mmu notifier users use has the ->mm pointer we want right > there. That's good enough I think. Yah, if you can pass in one of those instead of the raw mm it would be fine Jason
diff --git a/include/linux/mm.h b/include/linux/mm.h index 83d0be101a38..d0fe8bf46a9d 100644 --- a/include/linux/mm.h +++ b/include/linux/mm.h @@ -1661,6 +1661,8 @@ int follow_pte_pmd(struct mm_struct *mm, unsigned long address, pte_t **ptepp, pmd_t **pmdpp, spinlock_t **ptlp); int follow_pfn(struct vm_area_struct *vma, unsigned long address, unsigned long *pfn); +int unsafe_follow_pfn(struct vm_area_struct *vma, unsigned long address, + unsigned long *pfn); int follow_phys(struct vm_area_struct *vma, unsigned long address, unsigned int flags, unsigned long *prot, resource_size_t *phys); int generic_access_phys(struct vm_area_struct *vma, unsigned long addr, diff --git a/mm/memory.c b/mm/memory.c index ac32039ce941..0db0c5e233fd 100644 --- a/mm/memory.c +++ b/mm/memory.c @@ -4795,7 +4795,12 @@ EXPORT_SYMBOL(follow_pte_pmd); * @address: user virtual address * @pfn: location to store found PFN * - * Only IO mappings and raw PFN mappings are allowed. + * Only IO mappings and raw PFN mappings are allowed. Note that callers must + * ensure coherency with pte updates by using a &mmu_notifier to follow updates. + * If this is not feasible, or the access to the @pfn is only very short term, + * use follow_pte_pmd() instead and hold the pagetable lock for the duration of + * the access instead. Any caller not following these requirements must use + * unsafe_follow_pfn() instead. * * Return: zero and the pfn at @pfn on success, -ve otherwise. */ @@ -4816,7 +4821,32 @@ int follow_pfn(struct vm_area_struct *vma, unsigned long address, pte_unmap_unlock(ptep, ptl); return 0; } -EXPORT_SYMBOL(follow_pfn); +EXPORT_SYMBOL_GPL(follow_pfn); + +/** + * unsafe_follow_pfn - look up PFN at a user virtual address + * @vma: memory mapping + * @address: user virtual address + * @pfn: location to store found PFN + * + * Only IO mappings and raw PFN mappings are allowed. + * + * Returns zero and the pfn at @pfn on success, -ve otherwise. + */ +int unsafe_follow_pfn(struct vm_area_struct *vma, unsigned long address, + unsigned long *pfn) +{ + if (IS_ENABLED(CONFIG_STRICT_FOLLOW_PFN)) { + pr_info("unsafe follow_pfn usage rejected, see CONFIG_STRICT_FOLLOW_PFN\n"); + return -EINVAL; + } + + WARN_ONCE(1, "unsafe follow_pfn usage\n"); + add_taint(TAINT_USER, LOCKDEP_STILL_OK); + + return follow_pfn(vma, address, pfn); +} +EXPORT_SYMBOL(unsafe_follow_pfn); #ifdef CONFIG_HAVE_IOREMAP_PROT int follow_phys(struct vm_area_struct *vma, diff --git a/mm/nommu.c b/mm/nommu.c index 0faf39b32cdb..79fc98a6c94a 100644 --- a/mm/nommu.c +++ b/mm/nommu.c @@ -130,7 +130,32 @@ int follow_pfn(struct vm_area_struct *vma, unsigned long address, *pfn = address >> PAGE_SHIFT; return 0; } -EXPORT_SYMBOL(follow_pfn); +EXPORT_SYMBOL_GPL(follow_pfn); + +/** + * unsafe_follow_pfn - look up PFN at a user virtual address + * @vma: memory mapping + * @address: user virtual address + * @pfn: location to store found PFN + * + * Only IO mappings and raw PFN mappings are allowed. + * + * Returns zero and the pfn at @pfn on success, -ve otherwise. + */ +int unsafe_follow_pfn(struct vm_area_struct *vma, unsigned long address, + unsigned long *pfn) +{ + if (IS_ENABLED(CONFIG_STRICT_FOLLOW_PFN)) { + pr_info("unsafe follow_pfn usage rejected, see CONFIG_STRICT_FOLLOW_PFN\n"); + return -EINVAL; + } + + WARN_ONCE(1, "unsafe follow_pfn usage\n"); + add_taint(TAINT_USER, LOCKDEP_STILL_OK); + + return follow_pfn(vma, address, pfn); +} +EXPORT_SYMBOL(unsafe_follow_pfn); LIST_HEAD(vmap_area_list); diff --git a/security/Kconfig b/security/Kconfig index 7561f6f99f1d..48945402e103 100644 --- a/security/Kconfig +++ b/security/Kconfig @@ -230,6 +230,19 @@ config STATIC_USERMODEHELPER_PATH If you wish for all usermode helper programs to be disabled, specify an empty string here (i.e. ""). +config STRICT_FOLLOW_PFN + bool "Disable unsafe use of follow_pfn" + depends on MMU + help + Some functionality in the kernel follows userspace mappings to iomem + ranges in an unsafe matter. Examples include v4l userptr for zero-copy + buffers sharing. + + If this option is switched on, such access is rejected. Only enable + this option when you must run userspace which requires this. + + If in doubt, say Y. + source "security/selinux/Kconfig" source "security/smack/Kconfig" source "security/tomoyo/Kconfig"