Message ID | 20201204074036.23870-4-peng.fan@oss.nxp.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | remoteproc: imx_rproc: support iMX8MQ/M | expand |
On Fri 04 Dec 01:40 CST 2020, Peng Fan (OSS) wrote: > From: Peng Fan <peng.fan@nxp.com> > > It is using devm_ioremap, so not devm_ioremap_resource. Correct > the error message and print out sa/size. > > Acked-by: Richard Zhu <hongxing.zhu@nxp.com> > Reviewed-by: Mathieu Poirier <mathieu.poirier@linaro.org> > Signed-off-by: Peng Fan <peng.fan@nxp.com> > --- > drivers/remoteproc/imx_rproc.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/remoteproc/imx_rproc.c b/drivers/remoteproc/imx_rproc.c > index d1abb253b499..aa5fbd0c7768 100644 > --- a/drivers/remoteproc/imx_rproc.c > +++ b/drivers/remoteproc/imx_rproc.c > @@ -270,7 +270,7 @@ static int imx_rproc_addr_init(struct imx_rproc *priv, > priv->mem[b].cpu_addr = devm_ioremap(&pdev->dev, > att->sa, att->size); > if (!priv->mem[b].cpu_addr) { > - dev_err(dev, "devm_ioremap_resource failed\n"); > + dev_err(dev, "devm_ioremap failed\n"); I would prefer if this was expanded to a proper sentence, and I really like the second part of the commit message to be included in the change. So something like: dev_err(dev, "failed to remap %#x bytes from %#x\n", att->size, att->sa); And similarly below if mapping a memory-region fails. Thanks, Bjorn > return -ENOMEM; > } > priv->mem[b].sys_addr = att->sa; > -- > 2.28.0 >
> Subject: Re: [PATCH V3 3/7] remoteproc: imx_rproc: correct err message > > On Fri 04 Dec 01:40 CST 2020, Peng Fan (OSS) wrote: > > > From: Peng Fan <peng.fan@nxp.com> > > > > It is using devm_ioremap, so not devm_ioremap_resource. Correct the > > error message and print out sa/size. > > > > Acked-by: Richard Zhu <hongxing.zhu@nxp.com> > > Reviewed-by: Mathieu Poirier <mathieu.poirier@linaro.org> > > Signed-off-by: Peng Fan <peng.fan@nxp.com> > > --- > > drivers/remoteproc/imx_rproc.c | 2 +- > > 1 file changed, 1 insertion(+), 1 deletion(-) > > > > diff --git a/drivers/remoteproc/imx_rproc.c > > b/drivers/remoteproc/imx_rproc.c index d1abb253b499..aa5fbd0c7768 > > 100644 > > --- a/drivers/remoteproc/imx_rproc.c > > +++ b/drivers/remoteproc/imx_rproc.c > > @@ -270,7 +270,7 @@ static int imx_rproc_addr_init(struct imx_rproc > *priv, > > priv->mem[b].cpu_addr = devm_ioremap(&pdev->dev, > > att->sa, att->size); > > if (!priv->mem[b].cpu_addr) { > > - dev_err(dev, "devm_ioremap_resource failed\n"); > > + dev_err(dev, "devm_ioremap failed\n"); > > I would prefer if this was expanded to a proper sentence, and I really like the > second part of the commit message to be included in the change. > So something like: > > dev_err(dev, "failed to remap %#x bytes from %#x\n", > att->size, att->sa); > > > And similarly below if mapping a memory-region fails. ok, fix in v4. Thanks, Peng. > > Thanks, > Bjorn > > > return -ENOMEM; > > } > > priv->mem[b].sys_addr = att->sa; > > -- > > 2.28.0 > >
diff --git a/drivers/remoteproc/imx_rproc.c b/drivers/remoteproc/imx_rproc.c index d1abb253b499..aa5fbd0c7768 100644 --- a/drivers/remoteproc/imx_rproc.c +++ b/drivers/remoteproc/imx_rproc.c @@ -270,7 +270,7 @@ static int imx_rproc_addr_init(struct imx_rproc *priv, priv->mem[b].cpu_addr = devm_ioremap(&pdev->dev, att->sa, att->size); if (!priv->mem[b].cpu_addr) { - dev_err(dev, "devm_ioremap_resource failed\n"); + dev_err(dev, "devm_ioremap failed\n"); return -ENOMEM; } priv->mem[b].sys_addr = att->sa;