Message ID | 20210602114339.11223-3-thunder.leizhen@huawei.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | mfd: use DEVICE_ATTR_* macro to simplify code | expand |
On Wed, 02 Jun 2021, Zhen Lei wrote: > Use DEVICE_ATTR_RO macro helper instead of plain DEVICE_ATTR, which makes > the code a bit shorter and easier to read. > > Signed-off-by: Zhen Lei <thunder.leizhen@huawei.com> > --- > drivers/mfd/ucb1x00-assabet.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) Applied, thanks.
diff --git a/drivers/mfd/ucb1x00-assabet.c b/drivers/mfd/ucb1x00-assabet.c index ecc9e9fc331d6a3..6a389737c6153bc 100644 --- a/drivers/mfd/ucb1x00-assabet.c +++ b/drivers/mfd/ucb1x00-assabet.c @@ -28,7 +28,7 @@ static ssize_t name##_show(struct device *dev, struct device_attribute *attr, \ ucb1x00_adc_disable(ucb); \ return sprintf(buf, "%d\n", val); \ } \ -static DEVICE_ATTR(name,0444,name##_show,NULL) +static DEVICE_ATTR_RO(name) UCB1X00_ATTR(vbatt, UCB_ADC_INP_AD1); UCB1X00_ATTR(vcharger, UCB_ADC_INP_AD0);
Use DEVICE_ATTR_RO macro helper instead of plain DEVICE_ATTR, which makes the code a bit shorter and easier to read. Signed-off-by: Zhen Lei <thunder.leizhen@huawei.com> --- drivers/mfd/ucb1x00-assabet.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)