Message ID | 20210928171156.6353-1-luca@z3ntu.xyz (mailing list archive) |
---|---|
State | Not Applicable |
Headers | show |
Series | net: qrtr: combine nameservice into main module | expand |
On Tue 28 Sep 12:11 CDT 2021, Luca Weiss wrote: > Previously with CONFIG_QRTR=m a separate ns.ko would be built which > wasn't done on purpose and should be included in qrtr.ko. > > Rename qrtr.c to af_qrtr.c so we can build a qrtr.ko with both af_qrtr.c > and ns.c. > Nice, I don't think we ever intended to end up with "ns.ko" on its own. Reviewed-by: Bjorn Andersson <bjorn.andersson@linaro.org> Regards, Bjorn > Signed-off-by: Luca Weiss <luca@z3ntu.xyz> > --- > net/qrtr/Makefile | 3 ++- > net/qrtr/{qrtr.c => af_qrtr.c} | 0 > 2 files changed, 2 insertions(+), 1 deletion(-) > rename net/qrtr/{qrtr.c => af_qrtr.c} (100%) > > diff --git a/net/qrtr/Makefile b/net/qrtr/Makefile > index 1b1411d158a7..8e0605f88a73 100644 > --- a/net/qrtr/Makefile > +++ b/net/qrtr/Makefile > @@ -1,5 +1,6 @@ > # SPDX-License-Identifier: GPL-2.0-only > -obj-$(CONFIG_QRTR) := qrtr.o ns.o > +obj-$(CONFIG_QRTR) += qrtr.o > +qrtr-y := af_qrtr.o ns.o > > obj-$(CONFIG_QRTR_SMD) += qrtr-smd.o > qrtr-smd-y := smd.o > diff --git a/net/qrtr/qrtr.c b/net/qrtr/af_qrtr.c > similarity index 100% > rename from net/qrtr/qrtr.c > rename to net/qrtr/af_qrtr.c > -- > 2.33.0 >
On 9/28/21 12:11 PM, Luca Weiss wrote: > Previously with CONFIG_QRTR=m a separate ns.ko would be built which > wasn't done on purpose and should be included in qrtr.ko. > > Rename qrtr.c to af_qrtr.c so we can build a qrtr.ko with both af_qrtr.c > and ns.c. > > Signed-off-by: Luca Weiss <luca@z3ntu.xyz> > --- > net/qrtr/Makefile | 3 ++- > net/qrtr/{qrtr.c => af_qrtr.c} | 0 > 2 files changed, 2 insertions(+), 1 deletion(-) > rename net/qrtr/{qrtr.c => af_qrtr.c} (100%) > > diff --git a/net/qrtr/Makefile b/net/qrtr/Makefile > index 1b1411d158a7..8e0605f88a73 100644 > --- a/net/qrtr/Makefile > +++ b/net/qrtr/Makefile > @@ -1,5 +1,6 @@ > # SPDX-License-Identifier: GPL-2.0-only > -obj-$(CONFIG_QRTR) := qrtr.o ns.o > +obj-$(CONFIG_QRTR) += qrtr.o > +qrtr-y := af_qrtr.o ns.o > > obj-$(CONFIG_QRTR_SMD) += qrtr-smd.o > qrtr-smd-y := smd.o > diff --git a/net/qrtr/qrtr.c b/net/qrtr/af_qrtr.c > similarity index 100% > rename from net/qrtr/qrtr.c > rename to net/qrtr/af_qrtr.c Tested on the Lenovo Yoga C630 Tested-By: Steev Klimaszewski <steev@kali.org>
On Tue, Sep 28, 2021 at 07:11:57PM +0200, Luca Weiss wrote: > Previously with CONFIG_QRTR=m a separate ns.ko would be built which > wasn't done on purpose and should be included in qrtr.ko. > Yes, that's not intentional. Good catch! > Rename qrtr.c to af_qrtr.c so we can build a qrtr.ko with both af_qrtr.c > and ns.c. > > Signed-off-by: Luca Weiss <luca@z3ntu.xyz> Reviewed-by: Manivannan Sadhasivam <mani@kernel.org> Thanks, Mani > --- > net/qrtr/Makefile | 3 ++- > net/qrtr/{qrtr.c => af_qrtr.c} | 0 > 2 files changed, 2 insertions(+), 1 deletion(-) > rename net/qrtr/{qrtr.c => af_qrtr.c} (100%) > > diff --git a/net/qrtr/Makefile b/net/qrtr/Makefile > index 1b1411d158a7..8e0605f88a73 100644 > --- a/net/qrtr/Makefile > +++ b/net/qrtr/Makefile > @@ -1,5 +1,6 @@ > # SPDX-License-Identifier: GPL-2.0-only > -obj-$(CONFIG_QRTR) := qrtr.o ns.o > +obj-$(CONFIG_QRTR) += qrtr.o > +qrtr-y := af_qrtr.o ns.o > > obj-$(CONFIG_QRTR_SMD) += qrtr-smd.o > qrtr-smd-y := smd.o > diff --git a/net/qrtr/qrtr.c b/net/qrtr/af_qrtr.c > similarity index 100% > rename from net/qrtr/qrtr.c > rename to net/qrtr/af_qrtr.c > -- > 2.33.0 >
Hello: This patch was applied to netdev/net-next.git (refs/heads/master): On Tue, 28 Sep 2021 19:11:57 +0200 you wrote: > Previously with CONFIG_QRTR=m a separate ns.ko would be built which > wasn't done on purpose and should be included in qrtr.ko. > > Rename qrtr.c to af_qrtr.c so we can build a qrtr.ko with both af_qrtr.c > and ns.c. > > Signed-off-by: Luca Weiss <luca@z3ntu.xyz> > > [...] Here is the summary with links: - net: qrtr: combine nameservice into main module https://git.kernel.org/netdev/net-next/c/a365023a76f2 You are awesome, thank you! -- Deet-doot-dot, I am a bot. https://korg.docs.kernel.org/patchwork/pwbot.html
diff --git a/net/qrtr/Makefile b/net/qrtr/Makefile index 1b1411d158a7..8e0605f88a73 100644 --- a/net/qrtr/Makefile +++ b/net/qrtr/Makefile @@ -1,5 +1,6 @@ # SPDX-License-Identifier: GPL-2.0-only -obj-$(CONFIG_QRTR) := qrtr.o ns.o +obj-$(CONFIG_QRTR) += qrtr.o +qrtr-y := af_qrtr.o ns.o obj-$(CONFIG_QRTR_SMD) += qrtr-smd.o qrtr-smd-y := smd.o diff --git a/net/qrtr/qrtr.c b/net/qrtr/af_qrtr.c similarity index 100% rename from net/qrtr/qrtr.c rename to net/qrtr/af_qrtr.c
Previously with CONFIG_QRTR=m a separate ns.ko would be built which wasn't done on purpose and should be included in qrtr.ko. Rename qrtr.c to af_qrtr.c so we can build a qrtr.ko with both af_qrtr.c and ns.c. Signed-off-by: Luca Weiss <luca@z3ntu.xyz> --- net/qrtr/Makefile | 3 ++- net/qrtr/{qrtr.c => af_qrtr.c} | 0 2 files changed, 2 insertions(+), 1 deletion(-) rename net/qrtr/{qrtr.c => af_qrtr.c} (100%)