mbox series

[V3,0/6] nvmet: passthru fixes and improvements

Message ID 20201022010234.8304-1-chaitanya.kulkarni@wdc.com (mailing list archive)
Headers show
Series nvmet: passthru fixes and improvements | expand

Message

Chaitanya Kulkarni Oct. 22, 2020, 1:02 a.m. UTC
Hi,

This patch series has several small trivial fixes and few code
optimizations.

Regards,
Chaitanya

Changes from V2:-

1. Remove "nvme-core: annotate nvme_alloc_request()" patch and
   split the nvme_alloc_request() into nvme_alloc_request_qid_any()
   and nvme_alloc_request_qid() with addition of the prep patch for
   the same.
2. Remove the cleanup patches and trim down the series.
3. Remove the code for setting up the op_flags for passthru.  
4. Rebase and retest on the nvme-5.10.

Changes from V1:-

1. Remove the sg_cnt check and nvmet_passthru_sg_map() annotation.
2. Add annotations and performance numbers for newly added patch #1.
3. Move ctrl refcount and module refcount into nvme_dev_open() and
   nvme_dev_release(). Add prepration patch for the same.
4. Add reviewed-by tags.

Chaitanya Kulkarni (6):
  nvme-core: add a helper to init req from nvme cmd
  nvme-core: split nvme_alloc_request()
  nvmet: remove op_flags for passthru commands
  block: move blk_rq_bio_prep() to linux/blk-mq.h
  nvmet: use minimized version of blk_rq_append_bio
  nvmet: use inline bio for passthru fast path

 block/blk.h                    | 12 --------
 drivers/nvme/host/core.c       | 56 +++++++++++++++++++++++-----------
 drivers/nvme/host/lightnvm.c   |  5 ++-
 drivers/nvme/host/nvme.h       |  4 +--
 drivers/nvme/host/pci.c        |  6 ++--
 drivers/nvme/target/nvmet.h    |  1 +
 drivers/nvme/target/passthru.c | 38 +++++++++++++----------
 include/linux/blk-mq.h         | 12 ++++++++
 8 files changed, 81 insertions(+), 53 deletions(-)

Comments

Christoph Hellwig Nov. 3, 2020, 6:32 p.m. UTC | #1
Btw, what is fixed by the series?  It looks like just (useful) cleanups
to me.
Chaitanya Kulkarni Nov. 3, 2020, 11:50 p.m. UTC | #2
On 11/3/20 10:32, Christoph Hellwig wrote:
> Btw, what is fixed by the series?  It looks like just (useful) cleanups
> to me.
>
No fixes as we did the separate series for that, will remove it.