Message ID | 20180206160529.20713-2-jack@suse.cz (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
diff --git a/block/genhd.c b/block/genhd.c index 96a66f671720..22f4fc340a3a 100644 --- a/block/genhd.c +++ b/block/genhd.c @@ -802,7 +802,10 @@ struct gendisk *get_gendisk(dev_t devt, int *partno) } if (disk && unlikely(disk->flags & GENHD_FL_HIDDEN)) { + struct module *owner = disk->fops->owner; + put_disk(disk); + module_put(owner); disk = NULL; } return disk;
Commit 8ddcd653257c "block: introduce GENHD_FL_HIDDEN" added handling of hidden devices to get_gendisk() but forgot to drop module reference which is also acquired by get_disk(). Drop the reference as necessary. Arguably the function naming here is misleading as put_disk() is *not* the counterpart of get_disk() but let's fix that in the follow up commit since that will be more intrusive. Fixes: 8ddcd653257c18a669fcb75ee42c37054908e0d6 CC: Christoph Hellwig <hch@lst.de> Signed-off-by: Jan Kara <jack@suse.cz> --- block/genhd.c | 3 +++ 1 file changed, 3 insertions(+)