Message ID | 20200702134650.16550-1-nborisov@suse.com (mailing list archive) |
---|---|
Headers | show |
Series | A bunch of misc cleanups | expand |
On Thu, Jul 02, 2020 at 04:46:40PM +0300, Nikolay Borisov wrote: > Here's an assortment of little quality-of-life patches that I created while > looking into the raid56 code. They should bear no functional changes and have > tested them with xfstest and nothing fell over so should be rather low risk. > > Patch 1 moves code in __btrfs_map_block, essentially assigning tgtdev_map/raid_map > closet to where space for them is allocated. This also neccesiated moving the > call to sort_parity_stripes. The end result is (hopefully) slightly easier to > follow __btrfs_map_block. > > Next 5 patches cleanup minor things in raid56.c such as removing redundant checks, > making code interacting with bio_list more in line with what the rest of the > kernel is doing. Finally it's using some macros/functions instead of open-coding > them. Really just a bunch of low hanging fruit. > > Final 4 patches gradually remove all labels in btrfs_submit_compressed_read. > Current failures can be handled "inline" so to speak, without the need for > extra labels. This likely will change once the BUG_ONs are removed but we are > not there yet. > > Nikolay Borisov (10): > btrfs: Always initialize btrfs_bio::tgtdev_map/raid_map pointers > btrfs: raid56: Remove redundant check in rbio_add_io_page > btrfs: raid56: Assign bio in while() > btrfs: raid56: Remove out label in __raid56_parity_recover > btrfs: raid56: Use in_range where applicable > btrfs: raid56: Don't opencode swap() > btrfs: Remove fail label in check_compressed_csum > btrfs: Remove fail1 label in btrfs_submit_compressed_read > btrfs: Remove fail2 label from btrfs_submit_compressed_read > btrfs: Remove out label in btrfs_submit_compressed_read Except patches 4, 8, 9, 10, series merged to misc-next. We can have a look at the label/return cleanups next week, the other cleanups are good so I don't want to stall this patchset. Thanks.