mbox series

[0/9] btrfs: metadata_uuid refactors part1

Message ID cover.1684826246.git.anand.jain@oracle.com (mailing list archive)
Headers show
Series btrfs: metadata_uuid refactors part1 | expand

Message

Anand Jain May 23, 2023, 10:03 a.m. UTC
The metadata_uuid feature added later has significantly impacted code
readability due to the numerous conditions that need to be checked.

This patch set aims to improve code organization and prepares for
streamlining of the metadata_uuid checks and some simple fixes.

Anand Jain (9):
  btrfs: reduce struct btrfs_fs_devices size relocate fsid_change
  btrfs: streamline fsid checks in alloc_fs_devices
  btrfs: localise has_metadata_uuid check in alloc_fs_devices args
  btrfs: add comment about metadata_uuid in btrfs_fs_devices
  btrfs: simplify check_tree_block_fsid return arg to bool
  btrfs: refactor with memcmp_fsid_fs_devices helper
  btrfs: refactor with memcmp_fsid_changed helper
  btrfs: consolidate uuid memcmp in btrfs_validate_super
  btrfs: fix source code style in find_fsid

 fs/btrfs/disk-io.c |  24 +++++-----
 fs/btrfs/volumes.c | 114 +++++++++++++++++++++++++--------------------
 fs/btrfs/volumes.h |  21 +++++++--
 3 files changed, 94 insertions(+), 65 deletions(-)

Comments

David Sterba May 23, 2023, 9:33 p.m. UTC | #1
On Tue, May 23, 2023 at 06:03:14PM +0800, Anand Jain wrote:
> The metadata_uuid feature added later has significantly impacted code
> readability due to the numerous conditions that need to be checked.
> 
> This patch set aims to improve code organization and prepares for
> streamlining of the metadata_uuid checks and some simple fixes.

In general the cleanups look good, the checks get simplified. Please
fix the coding style, thanks.