Message ID | 0e94449a7f999c37d1a69809d49857f0855bfdec.1486995885.git.dsterba@suse.com (mailing list archive) |
---|---|
State | Accepted |
Headers | show |
At 02/13/2017 10:30 PM, David Sterba wrote: > Make ulist_fini externally visible so the ulist API is complete. Looks good to me. While I'm not pretty sure if the name "ulist_fini" is good enough. Maybe "ulist_finish" or "ulist_release" (just like release_path and free_path)? Thanks, Qu > > Signed-off-by: David Sterba <dsterba@suse.com> > --- > fs/btrfs/ulist.c | 2 +- > fs/btrfs/ulist.h | 1 + > 2 files changed, 2 insertions(+), 1 deletion(-) > > diff --git a/fs/btrfs/ulist.c b/fs/btrfs/ulist.c > index b1434bb57e36..5deee56434fc 100644 > --- a/fs/btrfs/ulist.c > +++ b/fs/btrfs/ulist.c > @@ -58,7 +58,7 @@ void ulist_init(struct ulist *ulist) > * This is useful in cases where the base 'struct ulist' has been statically > * allocated. > */ > -static void ulist_fini(struct ulist *ulist) > +void ulist_fini(struct ulist *ulist) > { > struct ulist_node *node; > struct ulist_node *next; > diff --git a/fs/btrfs/ulist.h b/fs/btrfs/ulist.h > index 007b22fff3f9..1a4130443d7e 100644 > --- a/fs/btrfs/ulist.h > +++ b/fs/btrfs/ulist.h > @@ -44,6 +44,7 @@ struct ulist { > }; > > void ulist_init(struct ulist *ulist); > +void ulist_fini(struct ulist *ulist); > void ulist_reinit(struct ulist *ulist); > struct ulist *ulist_alloc(gfp_t gfp_mask); > void ulist_free(struct ulist *ulist); > -- To unsubscribe from this list: send the line "unsubscribe linux-btrfs" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
On Tue, Feb 14, 2017 at 05:29:14PM +0800, Qu Wenruo wrote: > > > At 02/13/2017 10:30 PM, David Sterba wrote: > > Make ulist_fini externally visible so the ulist API is complete. > > Looks good to me. > > While I'm not pretty sure if the name "ulist_fini" is good enough. > > Maybe "ulist_finish" or "ulist_release" (just like release_path and > free_path)? Yeah, I don't like the name either, ulist_release sounds ok to me. -- To unsubscribe from this list: send the line "unsubscribe linux-btrfs" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
diff --git a/fs/btrfs/ulist.c b/fs/btrfs/ulist.c index b1434bb57e36..5deee56434fc 100644 --- a/fs/btrfs/ulist.c +++ b/fs/btrfs/ulist.c @@ -58,7 +58,7 @@ void ulist_init(struct ulist *ulist) * This is useful in cases where the base 'struct ulist' has been statically * allocated. */ -static void ulist_fini(struct ulist *ulist) +void ulist_fini(struct ulist *ulist) { struct ulist_node *node; struct ulist_node *next; diff --git a/fs/btrfs/ulist.h b/fs/btrfs/ulist.h index 007b22fff3f9..1a4130443d7e 100644 --- a/fs/btrfs/ulist.h +++ b/fs/btrfs/ulist.h @@ -44,6 +44,7 @@ struct ulist { }; void ulist_init(struct ulist *ulist); +void ulist_fini(struct ulist *ulist); void ulist_reinit(struct ulist *ulist); struct ulist *ulist_alloc(gfp_t gfp_mask); void ulist_free(struct ulist *ulist);
Make ulist_fini externally visible so the ulist API is complete. Signed-off-by: David Sterba <dsterba@suse.com> --- fs/btrfs/ulist.c | 2 +- fs/btrfs/ulist.h | 1 + 2 files changed, 2 insertions(+), 1 deletion(-)