diff mbox series

[16/18] btrfs: finish the rename of btrfs_fs_info::sectorsize

Message ID 11e2dc8b9f5745bec215d5c0fc38e35b00d65a74.1734514696.git.wqu@suse.com (mailing list archive)
State New
Headers show
Series btrfs: migrate to "block size" to describe the | expand

Commit Message

Qu Wenruo Dec. 18, 2024, 9:41 a.m. UTC
Now every user of btrfs_fs_info::sectorsize is migrated to use
btrfs_fs_info::blocksize, we can finish the rename by removing the
@sectorsize/@sectorsize_bits/@sectors_per_page aliases now.

Signed-off-by: Qu Wenruo <wqu@suse.com>
---
 fs/btrfs/fs.h | 10 ++--------
 1 file changed, 2 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/fs/btrfs/fs.h b/fs/btrfs/fs.h
index 9f8324ae3800..e2aafdc50498 100644
--- a/fs/btrfs/fs.h
+++ b/fs/btrfs/fs.h
@@ -797,15 +797,9 @@  struct btrfs_fs_info {
 
 	/* Cached block sizes */
 	u32 nodesize;
-	union {
-		u32 sectorsize;
-		u32 blocksize;
-	};
+	u32 blocksize;
 	/* ilog2 of blocksize, use to avoid 64bit division */
-	union {
-		u32 sectorsize_bits;
-		u32 blocksize_bits;
-	};
+	u32 blocksize_bits;
 	u32 csum_size;
 	u32 csums_per_leaf;
 	u32 stripesize;