Message ID | 20161122083811.12636-2-quwenruo@cn.fujitsu.com (mailing list archive) |
---|---|
State | Not Applicable |
Headers | show |
On Tue, Nov 22, 2016 at 04:38:09PM +0800, Qu Wenruo wrote: > Rename _require_btrfs() to _require_btrfs_subcommand() to avoid > confusion, as all other _require_btrfs_* has a quite clear suffix, like > _require_btrfs_mkfs_feature() or _require_btrfs_fs_feature(). > > Signed-off-by: Qu Wenruo <quwenruo@cn.fujitsu.com> > --- > common/rc | 2 +- > tests/btrfs/004 | 2 +- > tests/btrfs/048 | 2 +- > tests/btrfs/059 | 2 +- > tests/btrfs/131 | 2 +- > 5 files changed, 5 insertions(+), 5 deletions(-) > > diff --git a/common/rc b/common/rc > index e3b54ec..6d333dd 100644 > --- a/common/rc > +++ b/common/rc > @@ -3017,7 +3017,7 @@ _require_deletable_scratch_dev_pool() > } > > # We check for btrfs and (optionally) features of the btrfs command > -_require_btrfs() > +_require_btrfs_subcommand() _require_btrfs_command seems good enough. And it should be improved to handle subcommands like dump-tree (like what _require_xfs_io_command does), otherwise tests fail if old version of btrfs-progs is installed where inspect-internal doesn't have dump-tree support. Thanks, Eryu -- To unsubscribe from this list: send the line "unsubscribe linux-btrfs" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
diff --git a/common/rc b/common/rc index e3b54ec..6d333dd 100644 --- a/common/rc +++ b/common/rc @@ -3017,7 +3017,7 @@ _require_deletable_scratch_dev_pool() } # We check for btrfs and (optionally) features of the btrfs command -_require_btrfs() +_require_btrfs_subcommand() { cmd=$1 _require_command "$BTRFS_UTIL_PROG" btrfs diff --git a/tests/btrfs/004 b/tests/btrfs/004 index 905770a..2ce628e 100755 --- a/tests/btrfs/004 +++ b/tests/btrfs/004 @@ -51,7 +51,7 @@ _supported_fs btrfs _supported_os Linux _require_scratch _require_no_large_scratch_dev -_require_btrfs inspect-internal +_require_btrfs_subcommand inspect-internal _require_command "/usr/sbin/filefrag" filefrag rm -f $seqres.full diff --git a/tests/btrfs/048 b/tests/btrfs/048 index 0b907b0..ac731d1 100755 --- a/tests/btrfs/048 +++ b/tests/btrfs/048 @@ -48,7 +48,7 @@ _supported_fs btrfs _supported_os Linux _require_test _require_scratch -_require_btrfs "property" +_require_btrfs_subcommand "property" send_files_dir=$TEST_DIR/btrfs-test-$seq diff --git a/tests/btrfs/059 b/tests/btrfs/059 index 8f106d2..fd67ebb 100755 --- a/tests/btrfs/059 +++ b/tests/btrfs/059 @@ -51,7 +51,7 @@ _supported_fs btrfs _supported_os Linux _require_test _require_scratch -_require_btrfs "property" +_require_btrfs_subcommand "property" rm -f $seqres.full diff --git a/tests/btrfs/131 b/tests/btrfs/131 index d1a11d2..ff1dbdd 100755 --- a/tests/btrfs/131 +++ b/tests/btrfs/131 @@ -48,7 +48,7 @@ rm -f $seqres.full _supported_fs btrfs _supported_os Linux _require_scratch -_require_btrfs inspect-internal +_require_btrfs_subcommand inspect-internal mkfs_v1() {
Rename _require_btrfs() to _require_btrfs_subcommand() to avoid confusion, as all other _require_btrfs_* has a quite clear suffix, like _require_btrfs_mkfs_feature() or _require_btrfs_fs_feature(). Signed-off-by: Qu Wenruo <quwenruo@cn.fujitsu.com> --- common/rc | 2 +- tests/btrfs/004 | 2 +- tests/btrfs/048 | 2 +- tests/btrfs/059 | 2 +- tests/btrfs/131 | 2 +- 5 files changed, 5 insertions(+), 5 deletions(-)