Message ID | 5174C82D.1080901@redhat.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
On Mon, Apr 22, 2013 at 12:18:37AM -0500, Eric Sandeen wrote: > There was a time when sprinkling #ifdefs around was > bad form. We can clean up the code a bit by moving > the leak-list adds/removes into functions and make things > more readable. > > Signed-off-by: Eric Sandeen <sandeen@redhat.com> > --- > > V2: remove extra semicolons on no-op #defines, > thanks Roger! > > p.s. maybe _debug_ should be in the function names? > *shrug* I agree with that, makes things clear in the code, one does not need to look into that function. The leak_list members of extent_state and extent_buffer are present even without LEAK_DEBUG and are taking space, I'd like to see them moved under an #ifdef, but as the define is now local to the .c file this would need to add eg. a CONFIG_ option or a comment that describes how it should be used. Bug I'm fine with changing just the function names right now, the rest is optional and nice to have. Reviewed-by: David Sterba <dsterba@suse.cz> -- To unsubscribe from this list: send the line "unsubscribe linux-btrfs" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
On 4/22/13 10:22 AM, David Sterba wrote: > On Mon, Apr 22, 2013 at 12:18:37AM -0500, Eric Sandeen wrote: >> There was a time when sprinkling #ifdefs around was >> bad form. We can clean up the code a bit by moving >> the leak-list adds/removes into functions and make things >> more readable. >> >> Signed-off-by: Eric Sandeen <sandeen@redhat.com> >> --- >> >> V2: remove extra semicolons on no-op #defines, >> thanks Roger! >> >> p.s. maybe _debug_ should be in the function names? >> *shrug* > > I agree with that, makes things clear in the code, one does not need to > look into that function. > > The leak_list members of extent_state and extent_buffer are present even > without LEAK_DEBUG and are taking space, I'd like to see them moved > under an #ifdef, but as the define is now local to the .c file this > would need to add eg. a CONFIG_ option or a comment that describes how > it should be used. Yep I noticed that too, I'd be happy to elevate it to a CONFIG_ option if it's really something that will be kept around for a while. Could maybe be lumped in to a CONFIG_BTRFS_DEBUG that catches other #define DEBUG behaviors as well? -Eric > Bug I'm fine with changing just the function names right now, the rest > is optional and nice to have. > > Reviewed-by: David Sterba <dsterba@suse.cz> > -- To unsubscribe from this list: send the line "unsubscribe linux-btrfs" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
On Mon, Apr 22, 2013 at 10:27:11AM -0500, Eric Sandeen wrote: > Yep I noticed that too, I'd be happy to elevate it to a CONFIG_ option if > it's really something that will be kept around for a while. We have (and will have) more code for debugging aid. > Could maybe be lumped in to a CONFIG_BTRFS_DEBUG that catches other > #define DEBUG behaviors as well? Yes please, feel free to use this https://patchwork.kernel.org/patch/846462/ If there are really heavy debug checks we may separate them, but a single option should be fine for now. thanks, david -- To unsubscribe from this list: send the line "unsubscribe linux-btrfs" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
diff --git a/fs/btrfs/extent_io.c b/fs/btrfs/extent_io.c index 223aa6a..c4f163c 100644 --- a/fs/btrfs/extent_io.c +++ b/fs/btrfs/extent_io.c @@ -30,6 +30,29 @@ static LIST_HEAD(states); #define LEAK_DEBUG 0 #if LEAK_DEBUG static DEFINE_SPINLOCK(leak_lock); + +static inline +void btrfs_leak_list_add(struct list_head *new, struct list_head *head) +{ + unsigned long flags; + + spin_lock_irqsave(&leak_lock, flags); + list_add(new, head); + spin_unlock_irqrestore(&leak_lock, flags); +} + +static inline +void btrfs_leak_list_del(struct list_head *entry) +{ + unsigned long flags; + + spin_lock_irqsave(&leak_lock, flags); + list_del(entry); + spin_unlock_irqrestore(&leak_lock, flags); +} +#else +#define btrfs_leak_list_add(new, head) do {} while (0) +#define btrfs_leak_list_del(entry) do {} while (0) #endif #define BUFFER_LRU_MAX 64 @@ -96,7 +119,6 @@ void extent_io_exit(void) state->state, state->tree, atomic_read(&state->refs)); list_del(&state->leak_list); kmem_cache_free(extent_state_cache, state); - } while (!list_empty(&buffers)) { @@ -134,9 +156,6 @@ void extent_io_tree_init(struct extent_io_tree *tree, static struct extent_state *alloc_extent_state(gfp_t mask) { struct extent_state *state; -#if LEAK_DEBUG - unsigned long flags; -#endif state = kmem_cache_alloc(extent_state_cache, mask); if (!state) @@ -144,11 +163,7 @@ static struct extent_state *alloc_extent_state(gfp_t mask) state->state = 0; state->private = 0; state->tree = NULL; -#if LEAK_DEBUG - spin_lock_irqsave(&leak_lock, flags); - list_add(&state->leak_list, &states); - spin_unlock_irqrestore(&leak_lock, flags); -#endif + btrfs_leak_list_add(&state->leak_list, &states); atomic_set(&state->refs, 1); init_waitqueue_head(&state->wq); trace_alloc_extent_state(state, mask, _RET_IP_); @@ -160,15 +175,8 @@ void free_extent_state(struct extent_state *state) if (!state) return; if (atomic_dec_and_test(&state->refs)) { -#if LEAK_DEBUG - unsigned long flags; -#endif WARN_ON(state->tree); -#if LEAK_DEBUG - spin_lock_irqsave(&leak_lock, flags); - list_del(&state->leak_list); - spin_unlock_irqrestore(&leak_lock, flags); -#endif + btrfs_leak_list_del(&state->leak_list); trace_free_extent_state(state, _RET_IP_); kmem_cache_free(extent_state_cache, state); } @@ -4010,12 +4018,7 @@ out: static void __free_extent_buffer(struct extent_buffer *eb) { -#if LEAK_DEBUG - unsigned long flags; - spin_lock_irqsave(&leak_lock, flags); - list_del(&eb->leak_list); - spin_unlock_irqrestore(&leak_lock, flags); -#endif + btrfs_leak_list_del(&eb->leak_list); kmem_cache_free(extent_buffer_cache, eb); } @@ -4025,9 +4028,6 @@ static struct extent_buffer *__alloc_extent_buffer(struct extent_io_tree *tree, gfp_t mask) { struct extent_buffer *eb = NULL; -#if LEAK_DEBUG - unsigned long flags; -#endif eb = kmem_cache_zalloc(extent_buffer_cache, mask); if (eb == NULL) @@ -4047,11 +4047,8 @@ static struct extent_buffer *__alloc_extent_buffer(struct extent_io_tree *tree, init_waitqueue_head(&eb->write_lock_wq); init_waitqueue_head(&eb->read_lock_wq); -#if LEAK_DEBUG - spin_lock_irqsave(&leak_lock, flags); - list_add(&eb->leak_list, &buffers); - spin_unlock_irqrestore(&leak_lock, flags); -#endif + btrfs_leak_list_add(&eb->leak_list, &buffers); + spin_lock_init(&eb->refs_lock); atomic_set(&eb->refs, 1); atomic_set(&eb->io_pages, 0);
There was a time when sprinkling #ifdefs around was bad form. We can clean up the code a bit by moving the leak-list adds/removes into functions and make things more readable. Signed-off-by: Eric Sandeen <sandeen@redhat.com> --- V2: remove extra semicolons on no-op #defines, thanks Roger! p.s. maybe _debug_ should be in the function names? *shrug* -- To unsubscribe from this list: send the line "unsubscribe linux-btrfs" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html