Message ID | 20140109201642.28381.82141.stgit@viggo.jf.intel.com (mailing list archive) |
---|---|
State | Superseded |
Headers | show |
On Thu, Jan 9, 2014 at 3:16 PM, Dan Williams <dan.j.williams@intel.com> wrote: > net_dma was the only external user so this can become local to tcp.c > again. ... > -void tcp_cleanup_rbuf(struct sock *sk, int copied) > +static void cleanup_rbuf(struct sock *sk, int copied) I would vote to keep the tcp_ prefix. In the TCP code base that is the more common idiom, even for internal/static TCP functions, and personally I find it easier to read and work with in stack traces, etc. My 2 cents. neal -- To unsubscribe from this list: send the line "unsubscribe dmaengine" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
On Thu, Jan 9, 2014 at 12:26 PM, Neal Cardwell <ncardwell@google.com> wrote: > On Thu, Jan 9, 2014 at 3:16 PM, Dan Williams <dan.j.williams@intel.com> wrote: >> net_dma was the only external user so this can become local to tcp.c >> again. > ... >> -void tcp_cleanup_rbuf(struct sock *sk, int copied) >> +static void cleanup_rbuf(struct sock *sk, int copied) > > I would vote to keep the tcp_ prefix. In the TCP code base that is the > more common idiom, even for internal/static TCP functions, and > personally I find it easier to read and work with in stack traces, > etc. My 2 cents. > Ok. It was cleanup_rbuf() in a former life, but one vote for leaving the name as is is enough for me. -- Dan -- To unsubscribe from this list: send the line "unsubscribe dmaengine" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
From: Dan Williams <dan.j.williams@intel.com> Date: Thu, 9 Jan 2014 12:33:29 -0800 > On Thu, Jan 9, 2014 at 12:26 PM, Neal Cardwell <ncardwell@google.com> wrote: >> On Thu, Jan 9, 2014 at 3:16 PM, Dan Williams <dan.j.williams@intel.com> wrote: >>> net_dma was the only external user so this can become local to tcp.c >>> again. >> ... >>> -void tcp_cleanup_rbuf(struct sock *sk, int copied) >>> +static void cleanup_rbuf(struct sock *sk, int copied) >> >> I would vote to keep the tcp_ prefix. In the TCP code base that is the >> more common idiom, even for internal/static TCP functions, and >> personally I find it easier to read and work with in stack traces, >> etc. My 2 cents. >> > > Ok. It was cleanup_rbuf() in a former life, but one vote for leaving > the name as is is enough for me. You can make that two votes :) -- To unsubscribe from this list: send the line "unsubscribe dmaengine" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
From: David Miller ... > > On Thu, Jan 9, 2014 at 12:26 PM, Neal Cardwell <ncardwell@google.com> wrote: > >> On Thu, Jan 9, 2014 at 3:16 PM, Dan Williams <dan.j.williams@intel.com> wrote: > >>> net_dma was the only external user so this can become local to tcp.c > >>> again. > >> ... > >>> -void tcp_cleanup_rbuf(struct sock *sk, int copied) > >>> +static void cleanup_rbuf(struct sock *sk, int copied) > >> > >> I would vote to keep the tcp_ prefix. In the TCP code base that is the > >> more common idiom, even for internal/static TCP functions, and > >> personally I find it easier to read and work with in stack traces, > >> etc. My 2 cents. > >> > > > > Ok. It was cleanup_rbuf() in a former life, but one vote for leaving > > the name as is is enough for me. > > You can make that two votes :) I suspect DM adds 2000 votes :-) Keeping the prefix makes it easier to grep for, and makes it more obvious that it isn't a generic function (when being called). David -- To unsubscribe from this list: send the line "unsubscribe dmaengine" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
diff --git a/include/net/tcp.h b/include/net/tcp.h index 084c163e9d40..571036b3bead 100644 --- a/include/net/tcp.h +++ b/include/net/tcp.h @@ -370,7 +370,6 @@ int tcp_rcv_state_process(struct sock *sk, struct sk_buff *skb, void tcp_rcv_established(struct sock *sk, struct sk_buff *skb, const struct tcphdr *th, unsigned int len); void tcp_rcv_space_adjust(struct sock *sk); -void tcp_cleanup_rbuf(struct sock *sk, int copied); int tcp_twsk_unique(struct sock *sk, struct sock *sktw, void *twp); void tcp_twsk_destructor(struct sock *sk); ssize_t tcp_splice_read(struct socket *sk, loff_t *ppos, diff --git a/net/ipv4/tcp.c b/net/ipv4/tcp.c index 8dc913dfbaef..70c905a7d2b8 100644 --- a/net/ipv4/tcp.c +++ b/net/ipv4/tcp.c @@ -1332,7 +1332,7 @@ static int tcp_peek_sndq(struct sock *sk, struct msghdr *msg, int len) * calculation of whether or not we must ACK for the sake of * a window update. */ -void tcp_cleanup_rbuf(struct sock *sk, int copied) +static void cleanup_rbuf(struct sock *sk, int copied) { struct tcp_sock *tp = tcp_sk(sk); bool time_to_ack = false; @@ -1507,7 +1507,7 @@ int tcp_read_sock(struct sock *sk, read_descriptor_t *desc, /* Clean up data we have read: This will do ACK frames. */ if (copied > 0) { tcp_recv_skb(sk, seq, &offset); - tcp_cleanup_rbuf(sk, copied); + cleanup_rbuf(sk, copied); } return copied; } @@ -1658,7 +1658,7 @@ int tcp_recvmsg(struct kiocb *iocb, struct sock *sk, struct msghdr *msg, } } - tcp_cleanup_rbuf(sk, copied); + cleanup_rbuf(sk, copied); if (!sysctl_tcp_low_latency && tp->ucopy.task == user_recv) { /* Install new reader */ @@ -1831,7 +1831,7 @@ skip_copy: */ /* Clean up data we have read: This will do ACK frames. */ - tcp_cleanup_rbuf(sk, copied); + cleanup_rbuf(sk, copied); release_sock(sk); return copied; @@ -2494,7 +2494,7 @@ static int do_tcp_setsockopt(struct sock *sk, int level, (TCPF_ESTABLISHED | TCPF_CLOSE_WAIT) && inet_csk_ack_scheduled(sk)) { icsk->icsk_ack.pending |= ICSK_ACK_PUSHED; - tcp_cleanup_rbuf(sk, 1); + cleanup_rbuf(sk, 1); if (!(val & 1)) icsk->icsk_ack.pingpong = 1; }
net_dma was the only external user so this can become local to tcp.c again. Cc: James Morris <jmorris@namei.org> Cc: Patrick McHardy <kaber@trash.net> Cc: David S. Miller <davem@davemloft.net> Cc: Alexey Kuznetsov <kuznet@ms2.inr.ac.ru> Cc: Hideaki YOSHIFUJI <yoshfuji@linux-ipv6.org> Signed-off-by: Dan Williams <dan.j.williams@intel.com> --- New in v2 include/net/tcp.h | 1 - net/ipv4/tcp.c | 10 +++++----- 2 files changed, 5 insertions(+), 6 deletions(-) -- To unsubscribe from this list: send the line "unsubscribe dmaengine" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html