mbox series

[v3,0/2] fix the fallback implementation of get_name

Message ID 170438430288.129184.6116374966267668617.stgit@bazille.1015granger.net (mailing list archive)
Headers show
Series fix the fallback implementation of get_name | expand

Message

Chuck Lever Jan. 4, 2024, 4:18 p.m. UTC
I've set up a testing topic branch for exportfs in my kernel.org
git repo:

 https://git.kernel.org/pub/scm/linux/kernel/git/cel/linux.git

branch: exportfs-next

Note that I currently don't expect 1/2 to be backported to stable.
Please speak up if you believe a stable backport of 1/2 might be
necessary.

Changes since v2:
- Capture the open-coded "is_dot_dotdot" implementation in
  lookup_one_common()

Changes since v1:
- Fixes: was dropped from 1/2
- Added a patch to hoist is_dot_dotdot() into linux/fs.h

---

Chuck Lever (1):
      fs: Create a generic is_dot_dotdot() utility

Trond Myklebust (1):
      exportfs: fix the fallback implementation of the get_name export operation


 fs/crypto/fname.c    |  8 +-------
 fs/ecryptfs/crypto.c | 10 ----------
 fs/exportfs/expfs.c  |  2 +-
 fs/f2fs/f2fs.h       | 11 -----------
 fs/namei.c           |  6 ++----
 include/linux/fs.h   | 15 +++++++++++++++
 6 files changed, 19 insertions(+), 33 deletions(-)

--
Chuck Lever