Message ID | 20231207123825.4011620-2-amir73il@gmail.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | Prepare for fsnotify pre-content permission events | expand |
> +static inline long splice_copy_file_range(struct file *in, loff_t pos_in, > + struct file *out, loff_t pos_out, > + size_t len) > +{ > + return splice_file_range(in, &pos_in, out, &pos_out, > + min_t(size_t, len, MAX_RW_COUNT)); > +} We should really cleanup the return values of the all the splice helpers. Most callers of splice_file_range() use ssize_t already. So does splice_direct_to_actor() and splice_to_socket(). IMO, all of the splice helpers should just be changed to return ssize_t instead of long. Doesn't have to be in this series though.
On Thu 07-12-23 14:38:22, Amir Goldstein wrote: > generic_copy_file_range() is just a wrapper around splice_file_range(). > Move the wrapper to splice.h and rename it to splice_copy_file_range(). > > Suggested-by: Christoph Hellwig <hch@lst.de> > Link: https://lore.kernel.org/linux-fsdevel/20231204083849.GC32438@lst.de/ > Signed-off-by: Amir Goldstein <amir73il@gmail.com> Looks good. Feel free to add: Reviewed-by: Jan Kara <jack@suse.cz> Honza > --- > fs/ceph/file.c | 4 ++-- > fs/fuse/file.c | 5 +++-- > fs/nfs/nfs4file.c | 5 +++-- > fs/read_write.c | 34 ---------------------------------- > fs/smb/client/cifsfs.c | 5 +++-- > fs/splice.c | 2 +- > include/linux/fs.h | 3 --- > include/linux/splice.h | 8 ++++++++ > 8 files changed, 20 insertions(+), 46 deletions(-) > > diff --git a/fs/ceph/file.c b/fs/ceph/file.c > index f11de6e1f1c1..d380d9dad0e0 100644 > --- a/fs/ceph/file.c > +++ b/fs/ceph/file.c > @@ -3090,8 +3090,8 @@ static ssize_t ceph_copy_file_range(struct file *src_file, loff_t src_off, > len, flags); > > if (ret == -EOPNOTSUPP || ret == -EXDEV) > - ret = generic_copy_file_range(src_file, src_off, dst_file, > - dst_off, len, flags); > + ret = splice_copy_file_range(src_file, src_off, dst_file, > + dst_off, len); > return ret; > } > > diff --git a/fs/fuse/file.c b/fs/fuse/file.c > index a660f1f21540..148a71b8b4d0 100644 > --- a/fs/fuse/file.c > +++ b/fs/fuse/file.c > @@ -19,6 +19,7 @@ > #include <linux/uio.h> > #include <linux/fs.h> > #include <linux/filelock.h> > +#include <linux/splice.h> > > static int fuse_send_open(struct fuse_mount *fm, u64 nodeid, > unsigned int open_flags, int opcode, > @@ -3195,8 +3196,8 @@ static ssize_t fuse_copy_file_range(struct file *src_file, loff_t src_off, > len, flags); > > if (ret == -EOPNOTSUPP || ret == -EXDEV) > - ret = generic_copy_file_range(src_file, src_off, dst_file, > - dst_off, len, flags); > + ret = splice_copy_file_range(src_file, src_off, dst_file, > + dst_off, len); > return ret; > } > > diff --git a/fs/nfs/nfs4file.c b/fs/nfs/nfs4file.c > index 02788c3c85e5..e238abc78a13 100644 > --- a/fs/nfs/nfs4file.c > +++ b/fs/nfs/nfs4file.c > @@ -10,6 +10,7 @@ > #include <linux/mount.h> > #include <linux/nfs_fs.h> > #include <linux/nfs_ssc.h> > +#include <linux/splice.h> > #include "delegation.h" > #include "internal.h" > #include "iostat.h" > @@ -195,8 +196,8 @@ static ssize_t nfs4_copy_file_range(struct file *file_in, loff_t pos_in, > ret = __nfs4_copy_file_range(file_in, pos_in, file_out, pos_out, count, > flags); > if (ret == -EOPNOTSUPP || ret == -EXDEV) > - ret = generic_copy_file_range(file_in, pos_in, file_out, > - pos_out, count, flags); > + ret = splice_copy_file_range(file_in, pos_in, file_out, > + pos_out, count); > return ret; > } > > diff --git a/fs/read_write.c b/fs/read_write.c > index 01a14570015b..97a9d5c7ad96 100644 > --- a/fs/read_write.c > +++ b/fs/read_write.c > @@ -1396,40 +1396,6 @@ COMPAT_SYSCALL_DEFINE4(sendfile64, int, out_fd, int, in_fd, > } > #endif > > -/** > - * generic_copy_file_range - copy data between two files > - * @file_in: file structure to read from > - * @pos_in: file offset to read from > - * @file_out: file structure to write data to > - * @pos_out: file offset to write data to > - * @len: amount of data to copy > - * @flags: copy flags > - * > - * This is a generic filesystem helper to copy data from one file to another. > - * It has no constraints on the source or destination file owners - the files > - * can belong to different superblocks and different filesystem types. Short > - * copies are allowed. > - * > - * This should be called from the @file_out filesystem, as per the > - * ->copy_file_range() method. > - * > - * Returns the number of bytes copied or a negative error indicating the > - * failure. > - */ > - > -ssize_t generic_copy_file_range(struct file *file_in, loff_t pos_in, > - struct file *file_out, loff_t pos_out, > - size_t len, unsigned int flags) > -{ > - /* May only be called from within ->copy_file_range() methods */ > - if (WARN_ON_ONCE(flags)) > - return -EINVAL; > - > - return splice_file_range(file_in, &pos_in, file_out, &pos_out, > - min_t(size_t, len, MAX_RW_COUNT)); > -} > -EXPORT_SYMBOL(generic_copy_file_range); > - > /* > * Performs necessary checks before doing a file copy > * > diff --git a/fs/smb/client/cifsfs.c b/fs/smb/client/cifsfs.c > index ea3a7a668b45..ee461bf0ef63 100644 > --- a/fs/smb/client/cifsfs.c > +++ b/fs/smb/client/cifsfs.c > @@ -25,6 +25,7 @@ > #include <linux/freezer.h> > #include <linux/namei.h> > #include <linux/random.h> > +#include <linux/splice.h> > #include <linux/uuid.h> > #include <linux/xattr.h> > #include <uapi/linux/magic.h> > @@ -1362,8 +1363,8 @@ static ssize_t cifs_copy_file_range(struct file *src_file, loff_t off, > free_xid(xid); > > if (rc == -EOPNOTSUPP || rc == -EXDEV) > - rc = generic_copy_file_range(src_file, off, dst_file, > - destoff, len, flags); > + rc = splice_copy_file_range(src_file, off, dst_file, > + destoff, len); > return rc; > } > > diff --git a/fs/splice.c b/fs/splice.c > index 7cda013e5a1e..24bd93f8e4c3 100644 > --- a/fs/splice.c > +++ b/fs/splice.c > @@ -1243,7 +1243,7 @@ EXPORT_SYMBOL(do_splice_direct); > * @len: number of bytes to splice > * > * Description: > - * For use by generic_copy_file_range() and ->copy_file_range() methods. > + * For use by ->copy_file_range() methods. > * Like do_splice_direct(), but vfs_copy_file_range() already holds > * start_file_write() on @out file. > * > diff --git a/include/linux/fs.h b/include/linux/fs.h > index 04422a0eccdd..900d0cd55b50 100644 > --- a/include/linux/fs.h > +++ b/include/linux/fs.h > @@ -2090,9 +2090,6 @@ extern ssize_t vfs_read(struct file *, char __user *, size_t, loff_t *); > extern ssize_t vfs_write(struct file *, const char __user *, size_t, loff_t *); > extern ssize_t vfs_copy_file_range(struct file *, loff_t , struct file *, > loff_t, size_t, unsigned int); > -extern ssize_t generic_copy_file_range(struct file *file_in, loff_t pos_in, > - struct file *file_out, loff_t pos_out, > - size_t len, unsigned int flags); > int __generic_remap_file_range_prep(struct file *file_in, loff_t pos_in, > struct file *file_out, loff_t pos_out, > loff_t *len, unsigned int remap_flags, > diff --git a/include/linux/splice.h b/include/linux/splice.h > index 49532d5dda52..b92c4676c59b 100644 > --- a/include/linux/splice.h > +++ b/include/linux/splice.h > @@ -89,6 +89,14 @@ long do_splice_direct(struct file *in, loff_t *ppos, struct file *out, > long splice_file_range(struct file *in, loff_t *ppos, struct file *out, > loff_t *opos, size_t len); > > +static inline long splice_copy_file_range(struct file *in, loff_t pos_in, > + struct file *out, loff_t pos_out, > + size_t len) > +{ > + return splice_file_range(in, &pos_in, out, &pos_out, > + min_t(size_t, len, MAX_RW_COUNT)); > +} > + > extern long do_tee(struct file *in, struct file *out, size_t len, > unsigned int flags); > extern ssize_t splice_to_socket(struct pipe_inode_info *pipe, struct file *out, > -- > 2.34.1 >
On Fri, Dec 8, 2023 at 7:33 PM Christian Brauner <brauner@kernel.org> wrote: > > > +static inline long splice_copy_file_range(struct file *in, loff_t pos_in, > > + struct file *out, loff_t pos_out, > > + size_t len) > > +{ > > + return splice_file_range(in, &pos_in, out, &pos_out, > > + min_t(size_t, len, MAX_RW_COUNT)); > > +} > > We should really cleanup the return values of the all the splice > helpers. Most callers of splice_file_range() use ssize_t already. So > does splice_direct_to_actor() and splice_to_socket(). IMO, all of the > splice helpers should just be changed to return ssize_t instead of long. > Doesn't have to be in this series though. I agree. This is very annoying. I will add this cleanup patch to v2. Thanks, Amir.
diff --git a/fs/ceph/file.c b/fs/ceph/file.c index f11de6e1f1c1..d380d9dad0e0 100644 --- a/fs/ceph/file.c +++ b/fs/ceph/file.c @@ -3090,8 +3090,8 @@ static ssize_t ceph_copy_file_range(struct file *src_file, loff_t src_off, len, flags); if (ret == -EOPNOTSUPP || ret == -EXDEV) - ret = generic_copy_file_range(src_file, src_off, dst_file, - dst_off, len, flags); + ret = splice_copy_file_range(src_file, src_off, dst_file, + dst_off, len); return ret; } diff --git a/fs/fuse/file.c b/fs/fuse/file.c index a660f1f21540..148a71b8b4d0 100644 --- a/fs/fuse/file.c +++ b/fs/fuse/file.c @@ -19,6 +19,7 @@ #include <linux/uio.h> #include <linux/fs.h> #include <linux/filelock.h> +#include <linux/splice.h> static int fuse_send_open(struct fuse_mount *fm, u64 nodeid, unsigned int open_flags, int opcode, @@ -3195,8 +3196,8 @@ static ssize_t fuse_copy_file_range(struct file *src_file, loff_t src_off, len, flags); if (ret == -EOPNOTSUPP || ret == -EXDEV) - ret = generic_copy_file_range(src_file, src_off, dst_file, - dst_off, len, flags); + ret = splice_copy_file_range(src_file, src_off, dst_file, + dst_off, len); return ret; } diff --git a/fs/nfs/nfs4file.c b/fs/nfs/nfs4file.c index 02788c3c85e5..e238abc78a13 100644 --- a/fs/nfs/nfs4file.c +++ b/fs/nfs/nfs4file.c @@ -10,6 +10,7 @@ #include <linux/mount.h> #include <linux/nfs_fs.h> #include <linux/nfs_ssc.h> +#include <linux/splice.h> #include "delegation.h" #include "internal.h" #include "iostat.h" @@ -195,8 +196,8 @@ static ssize_t nfs4_copy_file_range(struct file *file_in, loff_t pos_in, ret = __nfs4_copy_file_range(file_in, pos_in, file_out, pos_out, count, flags); if (ret == -EOPNOTSUPP || ret == -EXDEV) - ret = generic_copy_file_range(file_in, pos_in, file_out, - pos_out, count, flags); + ret = splice_copy_file_range(file_in, pos_in, file_out, + pos_out, count); return ret; } diff --git a/fs/read_write.c b/fs/read_write.c index 01a14570015b..97a9d5c7ad96 100644 --- a/fs/read_write.c +++ b/fs/read_write.c @@ -1396,40 +1396,6 @@ COMPAT_SYSCALL_DEFINE4(sendfile64, int, out_fd, int, in_fd, } #endif -/** - * generic_copy_file_range - copy data between two files - * @file_in: file structure to read from - * @pos_in: file offset to read from - * @file_out: file structure to write data to - * @pos_out: file offset to write data to - * @len: amount of data to copy - * @flags: copy flags - * - * This is a generic filesystem helper to copy data from one file to another. - * It has no constraints on the source or destination file owners - the files - * can belong to different superblocks and different filesystem types. Short - * copies are allowed. - * - * This should be called from the @file_out filesystem, as per the - * ->copy_file_range() method. - * - * Returns the number of bytes copied or a negative error indicating the - * failure. - */ - -ssize_t generic_copy_file_range(struct file *file_in, loff_t pos_in, - struct file *file_out, loff_t pos_out, - size_t len, unsigned int flags) -{ - /* May only be called from within ->copy_file_range() methods */ - if (WARN_ON_ONCE(flags)) - return -EINVAL; - - return splice_file_range(file_in, &pos_in, file_out, &pos_out, - min_t(size_t, len, MAX_RW_COUNT)); -} -EXPORT_SYMBOL(generic_copy_file_range); - /* * Performs necessary checks before doing a file copy * diff --git a/fs/smb/client/cifsfs.c b/fs/smb/client/cifsfs.c index ea3a7a668b45..ee461bf0ef63 100644 --- a/fs/smb/client/cifsfs.c +++ b/fs/smb/client/cifsfs.c @@ -25,6 +25,7 @@ #include <linux/freezer.h> #include <linux/namei.h> #include <linux/random.h> +#include <linux/splice.h> #include <linux/uuid.h> #include <linux/xattr.h> #include <uapi/linux/magic.h> @@ -1362,8 +1363,8 @@ static ssize_t cifs_copy_file_range(struct file *src_file, loff_t off, free_xid(xid); if (rc == -EOPNOTSUPP || rc == -EXDEV) - rc = generic_copy_file_range(src_file, off, dst_file, - destoff, len, flags); + rc = splice_copy_file_range(src_file, off, dst_file, + destoff, len); return rc; } diff --git a/fs/splice.c b/fs/splice.c index 7cda013e5a1e..24bd93f8e4c3 100644 --- a/fs/splice.c +++ b/fs/splice.c @@ -1243,7 +1243,7 @@ EXPORT_SYMBOL(do_splice_direct); * @len: number of bytes to splice * * Description: - * For use by generic_copy_file_range() and ->copy_file_range() methods. + * For use by ->copy_file_range() methods. * Like do_splice_direct(), but vfs_copy_file_range() already holds * start_file_write() on @out file. * diff --git a/include/linux/fs.h b/include/linux/fs.h index 04422a0eccdd..900d0cd55b50 100644 --- a/include/linux/fs.h +++ b/include/linux/fs.h @@ -2090,9 +2090,6 @@ extern ssize_t vfs_read(struct file *, char __user *, size_t, loff_t *); extern ssize_t vfs_write(struct file *, const char __user *, size_t, loff_t *); extern ssize_t vfs_copy_file_range(struct file *, loff_t , struct file *, loff_t, size_t, unsigned int); -extern ssize_t generic_copy_file_range(struct file *file_in, loff_t pos_in, - struct file *file_out, loff_t pos_out, - size_t len, unsigned int flags); int __generic_remap_file_range_prep(struct file *file_in, loff_t pos_in, struct file *file_out, loff_t pos_out, loff_t *len, unsigned int remap_flags, diff --git a/include/linux/splice.h b/include/linux/splice.h index 49532d5dda52..b92c4676c59b 100644 --- a/include/linux/splice.h +++ b/include/linux/splice.h @@ -89,6 +89,14 @@ long do_splice_direct(struct file *in, loff_t *ppos, struct file *out, long splice_file_range(struct file *in, loff_t *ppos, struct file *out, loff_t *opos, size_t len); +static inline long splice_copy_file_range(struct file *in, loff_t pos_in, + struct file *out, loff_t pos_out, + size_t len) +{ + return splice_file_range(in, &pos_in, out, &pos_out, + min_t(size_t, len, MAX_RW_COUNT)); +} + extern long do_tee(struct file *in, struct file *out, size_t len, unsigned int flags); extern ssize_t splice_to_socket(struct pipe_inode_info *pipe, struct file *out,
generic_copy_file_range() is just a wrapper around splice_file_range(). Move the wrapper to splice.h and rename it to splice_copy_file_range(). Suggested-by: Christoph Hellwig <hch@lst.de> Link: https://lore.kernel.org/linux-fsdevel/20231204083849.GC32438@lst.de/ Signed-off-by: Amir Goldstein <amir73il@gmail.com> --- fs/ceph/file.c | 4 ++-- fs/fuse/file.c | 5 +++-- fs/nfs/nfs4file.c | 5 +++-- fs/read_write.c | 34 ---------------------------------- fs/smb/client/cifsfs.c | 5 +++-- fs/splice.c | 2 +- include/linux/fs.h | 3 --- include/linux/splice.h | 8 ++++++++ 8 files changed, 20 insertions(+), 46 deletions(-)