Message ID | 2f135856.6709.14e9a5e7d5a.Coremail.kernelpatch@126.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
diff --git a/fs/f2fs/data.c b/fs/f2fs/data.c index b621c08..0219bd0 100644 --- a/fs/f2fs/data.c +++ b/fs/f2fs/data.c @@ -1214,9 +1214,7 @@ continue_unlock: goto continue_unlock; } - if (step == 0 && !is_cold_data(page)) - goto continue_unlock; - if (step == 1 && is_cold_data(page)) + if (step == is_cold_data(page)) goto continue_unlock; if (PageWriteback(page)) {
The if statement "goto continue_unlock" is exactly the same when each if condition is true that is depended on the value of both "step" and "is_cold_data(page)" are 0 or 1. That means when the value of "step" equals to "is_cold_data(page)", the if condition is true and the if statement "goto continue_unlock" appears only once, so it can be optimized to reduce the duplicated code. Signed-off-by: Tiezhu Yang <kernelpatch@126.com> --- fs/f2fs/data.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-)