diff mbox series

[v2] sparc: Replace one-element array with flexible array member

Message ID 20241111204724.165263-2-thorsten.blum@linux.dev (mailing list archive)
State Mainlined
Commit 8467d8b282b54d87121f70ce78061af004471d0c
Headers show
Series [v2] sparc: Replace one-element array with flexible array member | expand

Commit Message

Thorsten Blum Nov. 11, 2024, 8:47 p.m. UTC
Replace the deprecated one-element array with a modern flexible array
member in the struct hvtramp_descr.

Additionally, 15 unnecessary bytes were allocated for hdesc, but instead
of fixing the parentheses in the open-coded version, use struct_size()
to calculate the correct number of bytes.

Link: https://github.com/KSPP/linux/issues/79
Signed-off-by: Thorsten Blum <thorsten.blum@linux.dev>
---
Changes in v2:
- Fix the number of mappings after feedback from Gustavo A. R. Silva
- Link to v1: https://lore.kernel.org/r/20241111200155.164621-3-thorsten.blum@linux.dev/
---
 arch/sparc/include/asm/hvtramp.h | 2 +-
 arch/sparc/kernel/smp_64.c       | 4 +---
 2 files changed, 2 insertions(+), 4 deletions(-)

Comments

Thorsten Blum Nov. 12, 2024, 11:03 a.m. UTC | #1
On 11. Nov 2024, at 21:47, Thorsten Blum wrote:
> Replace the deprecated one-element array with a modern flexible array
> member in the struct hvtramp_descr.
> 
> Additionally, 15 unnecessary bytes were allocated for hdesc, but instead
> of fixing the parentheses in the open-coded version, use struct_size()
> to calculate the correct number of bytes.
> 
> Link: https://github.com/KSPP/linux/issues/79
> Signed-off-by: Thorsten Blum <thorsten.blum@linux.dev>
> ---

If this justifies a Fixes: tag, it should probably be:

Fixes: 64658743fdd4 ("[SPARC64]: Remove most limitations to kernel image size.")

Thanks,
Thorsten
Andreas Larsson Nov. 16, 2024, 8:26 a.m. UTC | #2
On 2024-11-12 12:03, Thorsten Blum wrote:
> On 11. Nov 2024, at 21:47, Thorsten Blum wrote:
>> Replace the deprecated one-element array with a modern flexible array
>> member in the struct hvtramp_descr.
>>
>> Additionally, 15 unnecessary bytes were allocated for hdesc, but instead
>> of fixing the parentheses in the open-coded version, use struct_size()
>> to calculate the correct number of bytes.
>>
>> Link: https://github.com/KSPP/linux/issues/79
>> Signed-off-by: Thorsten Blum <thorsten.blum@linux.dev>
>> ---
> 
> If this justifies a Fixes: tag, it should probably be:
> 
> Fixes: 64658743fdd4 ("[SPARC64]: Remove most limitations to kernel image size.")

Reviewed-by: Andreas Larsson <andreas@gaisler.com>

Picking this up to my for-next.

Thanks,
Andreas
diff mbox series

Patch

diff --git a/arch/sparc/include/asm/hvtramp.h b/arch/sparc/include/asm/hvtramp.h
index 688ea43af0f5..ce2453ea4f2b 100644
--- a/arch/sparc/include/asm/hvtramp.h
+++ b/arch/sparc/include/asm/hvtramp.h
@@ -17,7 +17,7 @@  struct hvtramp_descr {
 	__u64			fault_info_va;
 	__u64			fault_info_pa;
 	__u64			thread_reg;
-	struct hvtramp_mapping	maps[1];
+	struct hvtramp_mapping	maps[];
 };
 
 void hv_cpu_startup(unsigned long hvdescr_pa);
diff --git a/arch/sparc/kernel/smp_64.c b/arch/sparc/kernel/smp_64.c
index e40c395db202..24d980220bf1 100644
--- a/arch/sparc/kernel/smp_64.c
+++ b/arch/sparc/kernel/smp_64.c
@@ -297,9 +297,7 @@  static void ldom_startcpu_cpuid(unsigned int cpu, unsigned long thread_reg,
 	unsigned long hv_err;
 	int i;
 
-	hdesc = kzalloc(sizeof(*hdesc) +
-			(sizeof(struct hvtramp_mapping) *
-			 num_kernel_image_mappings - 1),
+	hdesc = kzalloc(struct_size(hdesc, maps, num_kernel_image_mappings),
 			GFP_KERNEL);
 	if (!hdesc) {
 		printk(KERN_ERR "ldom_startcpu_cpuid: Cannot allocate "