Message ID | AS8PR02MB7237B94B9A9F4580E79BAC0C8BFE2@AS8PR02MB7237.eurprd02.prod.outlook.com (mailing list archive) |
---|---|
State | Mainlined |
Commit | 632691ad83197227adc902793a2a3e10c04fe9b8 |
Headers | show |
Series | auxdisplay: Use sizeof(*pointer) instead of sizeof(type) | expand |
On Sun, Jun 2, 2024 at 10:49 AM Erick Archer <erick.archer@outlook.com> wrote: > It is preferred to use sizeof(*pointer) instead of sizeof(type) > due to the type of the variable can change and one needs not > change the former (unlike the latter). This patch has no effect > on runtime behavior. > > Signed-off-by: Erick Archer <erick.archer@outlook.com> Reviewed-by: Geert Uytterhoeven <geert@linux-m68k.org> Gr{oetje,eeting}s, Geert
On Mon, Jun 03, 2024 at 09:52:57AM +0200, Geert Uytterhoeven wrote: > On Sun, Jun 2, 2024 at 10:49 AM Erick Archer <erick.archer@outlook.com> wrote: > > It is preferred to use sizeof(*pointer) instead of sizeof(type) > > due to the type of the variable can change and one needs not > > change the former (unlike the latter). This patch has no effect > > on runtime behavior. > > > > Signed-off-by: Erick Archer <erick.archer@outlook.com> > > Reviewed-by: Geert Uytterhoeven <geert@linux-m68k.org> Pushed to my review and testing queue, thanks!
diff --git a/drivers/auxdisplay/arm-charlcd.c b/drivers/auxdisplay/arm-charlcd.c index 0b1c99cca733..a7eae99a48f7 100644 --- a/drivers/auxdisplay/arm-charlcd.c +++ b/drivers/auxdisplay/arm-charlcd.c @@ -270,7 +270,7 @@ static int __init charlcd_probe(struct platform_device *pdev) struct charlcd *lcd; struct resource *res; - lcd = kzalloc(sizeof(struct charlcd), GFP_KERNEL); + lcd = kzalloc(sizeof(*lcd), GFP_KERNEL); if (!lcd) return -ENOMEM; diff --git a/drivers/auxdisplay/hd44780.c b/drivers/auxdisplay/hd44780.c index 7ac0b1b1d548..025dc6855cb2 100644 --- a/drivers/auxdisplay/hd44780.c +++ b/drivers/auxdisplay/hd44780.c @@ -230,7 +230,7 @@ static int hd44780_probe(struct platform_device *pdev) if (!lcd) goto fail1; - hd = kzalloc(sizeof(struct hd44780), GFP_KERNEL); + hd = kzalloc(sizeof(*hd), GFP_KERNEL); if (!hd) goto fail2;
It is preferred to use sizeof(*pointer) instead of sizeof(type) due to the type of the variable can change and one needs not change the former (unlike the latter). This patch has no effect on runtime behavior. Signed-off-by: Erick Archer <erick.archer@outlook.com> --- drivers/auxdisplay/arm-charlcd.c | 2 +- drivers/auxdisplay/hd44780.c | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-)