Message ID | 1502403586-20549-2-git-send-email-eajames@linux.vnet.ibm.com (mailing list archive) |
---|---|
State | Superseded |
Headers | show |
On Thu, Aug 10, 2017 at 05:19:44PM -0500, Eddie James wrote: > From: "Edward A. James" <eajames@us.ibm.com> > > Signed-off-by: Edward A. James <eajames@us.ibm.com> > --- > .../devicetree/bindings/i2c/ibm,power-ps.txt | 21 +++++++++++++++++++++ > 1 file changed, 21 insertions(+) > create mode 100644 Documentation/devicetree/bindings/i2c/ibm,power-ps.txt > > diff --git a/Documentation/devicetree/bindings/i2c/ibm,power-ps.txt b/Documentation/devicetree/bindings/i2c/ibm,power-ps.txt > new file mode 100644 > index 0000000..2ea8ea2 > --- /dev/null > +++ b/Documentation/devicetree/bindings/i2c/ibm,power-ps.txt > @@ -0,0 +1,21 @@ > +Device-tree bindings for IBM POWER system power supplies > +-------------------------------------------------------- > + > +Required properties: > + - compatible = "ibm,power-ps"; > + - reg = < I2C bus address >; : Address of the power supply on the > + I2C bus. > + > +Example: > + > + i2c-bus@100 { > + #address-cells = <1>; > + #size-cells = <0>; > + #interrupt-cells = <1>; > + < more properties > > + > + power_ps@68 { Don't use '_' in node names. Should be a generic name too if possible. Perhaps "power-supply". > + compatible = "ibm,power-ps"; > + reg = <0x68>; > + }; > + }; > -- > 1.8.3.1 > -- To unsubscribe from this list: send the line "unsubscribe linux-hwmon" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
On 08/17/2017 10:11 AM, Rob Herring wrote: > On Thu, Aug 10, 2017 at 05:19:44PM -0500, Eddie James wrote: >> From: "Edward A. James" <eajames@us.ibm.com> >> >> Signed-off-by: Edward A. James <eajames@us.ibm.com> >> --- >> .../devicetree/bindings/i2c/ibm,power-ps.txt | 21 +++++++++++++++++++++ >> 1 file changed, 21 insertions(+) >> create mode 100644 Documentation/devicetree/bindings/i2c/ibm,power-ps.txt >> >> diff --git a/Documentation/devicetree/bindings/i2c/ibm,power-ps.txt b/Documentation/devicetree/bindings/i2c/ibm,power-ps.txt >> new file mode 100644 >> index 0000000..2ea8ea2 >> --- /dev/null >> +++ b/Documentation/devicetree/bindings/i2c/ibm,power-ps.txt >> @@ -0,0 +1,21 @@ >> +Device-tree bindings for IBM POWER system power supplies >> +-------------------------------------------------------- >> + >> +Required properties: >> + - compatible = "ibm,power-ps"; >> + - reg = < I2C bus address >; : Address of the power supply on the >> + I2C bus. >> + >> +Example: >> + >> + i2c-bus@100 { >> + #address-cells = <1>; >> + #size-cells = <0>; >> + #interrupt-cells = <1>; >> + < more properties > >> + >> + power_ps@68 { > Don't use '_' in node names. Should be a generic name too if possible. > Perhaps "power-supply". Yes, the latest patch set switched this to power-supply. The driver name changed in v3, sorry for the confusion. Thanks, Eddie > >> + compatible = "ibm,power-ps"; >> + reg = <0x68>; >> + }; >> + }; >> -- >> 1.8.3.1 >> -- To unsubscribe from this list: send the line "unsubscribe linux-hwmon" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
diff --git a/Documentation/devicetree/bindings/i2c/ibm,power-ps.txt b/Documentation/devicetree/bindings/i2c/ibm,power-ps.txt new file mode 100644 index 0000000..2ea8ea2 --- /dev/null +++ b/Documentation/devicetree/bindings/i2c/ibm,power-ps.txt @@ -0,0 +1,21 @@ +Device-tree bindings for IBM POWER system power supplies +-------------------------------------------------------- + +Required properties: + - compatible = "ibm,power-ps"; + - reg = < I2C bus address >; : Address of the power supply on the + I2C bus. + +Example: + + i2c-bus@100 { + #address-cells = <1>; + #size-cells = <0>; + #interrupt-cells = <1>; + < more properties > + + power_ps@68 { + compatible = "ibm,power-ps"; + reg = <0x68>; + }; + };