diff mbox series

[2/2] hwmon: lm75: Add another name for NXP LM75B to of_match list

Message ID 20210130103823.28914-2-matwey@sai.msu.ru (mailing list archive)
State Changes Requested
Headers show
Series [1/2] hwmon: lm75: Add NXP LM75A to of_match list | expand

Commit Message

Matwey V. Kornilov Jan. 30, 2021, 10:38 a.m. UTC
NXP LM75B is compatible with original LM75A while it has improved
11-bit precision.

https://www.nxp.com/docs/en/data-sheet/LM75B.pdf

NXP LM75B support was added in

    799fc6021430 ("hwmon: (lm75) Add support for the NXP LM75B")

OF compatible string "national,lm75b" for LM75B was created in

    e97a45f1b460 ("hwmon: (lm75) Add OF device ID table")

Since the previous commit introduces "nxp,lm75a" compatible string
for LM75A, there is a reason to add another alias for LM75B.

Signed-off-by: Matwey V. Kornilov <matwey@sai.msu.ru>
---
 drivers/hwmon/lm75.c | 4 ++++
 1 file changed, 4 insertions(+)
diff mbox series

Patch

diff --git a/drivers/hwmon/lm75.c b/drivers/hwmon/lm75.c
index 37dc903ebf54..6cd951e062f0 100644
--- a/drivers/hwmon/lm75.c
+++ b/drivers/hwmon/lm75.c
@@ -703,6 +703,10 @@  static const struct of_device_id __maybe_unused lm75_of_match[] = {
 		.compatible = "nxp,lm75a",
 		.data = (void *)lm75b
 	},
+	{
+		.compatible = "nxp,lm75b",
+		.data = (void *)lm75b
+	},
 	{
 		.compatible = "maxim,max6625",
 		.data = (void *)max6625