Message ID | 1506336008-4480-3-git-send-email-harinath922@gmail.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Am 25.09.2017 12:40 schrieb Harinath Nampally: > Improves code readability, no impact on functionality. > > Signed-off-by: Harinath Nampally <harinath922@gmail.com> Please make the headline shorter and put some of it in the git commit message. (And please just resend it "--in-reply-to" this conversation, this patch nr 2 of 3) -- To unsubscribe from this list: send the line "unsubscribe linux-iio" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
On Wed, 27 Sep 2017 08:51:26 +0200 Martin Kepplinger <martink@posteo.de> wrote: > Am 25.09.2017 12:40 schrieb Harinath Nampally: > > Improves code readability, no impact on functionality. > > > > Signed-off-by: Harinath Nampally <harinath922@gmail.com> > > Please make the headline shorter and put some of it in the git commit > message. > (And please just resend it "--in-reply-to" this conversation, this patch > nr 2 of 3) From a patch management point of view I actually disagree with this. I would prefer to see a clean fresh series. Otherwise it very rapidly gets hard to be sure that I am picking up the latest versions. Obviously drop any patches that have already been taken. In this case it will be a v4 series containing patches 1 and 2 only. Thanks Jonathan > -- > To unsubscribe from this list: send the line "unsubscribe linux-iio" in > the body of a message to majordomo@vger.kernel.org > More majordomo info at http://vger.kernel.org/majordomo-info.html -- To unsubscribe from this list: send the line "unsubscribe linux-iio" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
> Obviously drop any patches that have already been taken. > In this case it will be a v4 series containing patches 1 and 2 only. Sure will do. Thanks, Harinath On Sat, Sep 30, 2017 at 2:05 PM, Jonathan Cameron <jic23@kernel.org> wrote: > On Wed, 27 Sep 2017 08:51:26 +0200 > Martin Kepplinger <martink@posteo.de> wrote: > >> Am 25.09.2017 12:40 schrieb Harinath Nampally: >> > Improves code readability, no impact on functionality. >> > >> > Signed-off-by: Harinath Nampally <harinath922@gmail.com> >> >> Please make the headline shorter and put some of it in the git commit >> message. >> (And please just resend it "--in-reply-to" this conversation, this patch >> nr 2 of 3) > > From a patch management point of view I actually disagree with this. > I would prefer to see a clean fresh series. Otherwise it very rapidly > gets hard to be sure that I am picking up the latest versions. > > Obviously drop any patches that have already been taken. > In this case it will be a v4 series containing patches 1 and 2 only. > > Thanks > > Jonathan >> -- >> To unsubscribe from this list: send the line "unsubscribe linux-iio" in >> the body of a message to majordomo@vger.kernel.org >> More majordomo info at http://vger.kernel.org/majordomo-info.html > -- To unsubscribe from this list: send the line "unsubscribe linux-iio" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
diff --git a/drivers/iio/accel/mma8452.c b/drivers/iio/accel/mma8452.c index 3472e7e..74b6221 100644 --- a/drivers/iio/accel/mma8452.c +++ b/drivers/iio/accel/mma8452.c @@ -284,7 +284,7 @@ static const int mma8452_samp_freq[8][2] = { }; /* Datasheet table: step time "Relationship with the ODR" (sample frequency) */ -static const unsigned int mma8452_transient_time_step_us[4][8] = { +static const unsigned int mma8452_time_step_us[4][8] = { { 1250, 2500, 5000, 10000, 20000, 20000, 20000, 20000 }, /* normal */ { 1250, 2500, 5000, 10000, 20000, 80000, 80000, 80000 }, /* l p l n */ { 1250, 2500, 2500, 2500, 2500, 2500, 2500, 2500 }, /* high res*/ @@ -826,7 +826,7 @@ static int mma8452_read_thresh(struct iio_dev *indio_dev, if (power_mode < 0) return power_mode; - us = ret * mma8452_transient_time_step_us[power_mode][ + us = ret * mma8452_time_step_us[power_mode][ mma8452_get_odr_index(data)]; *val = us / USEC_PER_SEC; *val2 = us % USEC_PER_SEC; @@ -883,7 +883,7 @@ static int mma8452_write_thresh(struct iio_dev *indio_dev, return ret; steps = (val * USEC_PER_SEC + val2) / - mma8452_transient_time_step_us[ret][ + mma8452_time_step_us[ret][ mma8452_get_odr_index(data)]; if (steps < 0 || steps > 0xff)
Improves code readability, no impact on functionality. Signed-off-by: Harinath Nampally <harinath922@gmail.com> --- drivers/iio/accel/mma8452.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-)