From patchwork Tue Aug 2 10:50:58 2016 Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit X-Patchwork-Submitter: "baolex.ni" X-Patchwork-Id: 9259955 Return-Path: Received: from mail.wl.linuxfoundation.org (pdx-wl-mail.web.codeaurora.org [172.30.200.125]) by pdx-korg-patchwork.web.codeaurora.org (Postfix) with ESMTP id AFEAF6077C for ; Tue, 2 Aug 2016 18:15:39 +0000 (UTC) Received: from mail.wl.linuxfoundation.org (localhost [127.0.0.1]) by mail.wl.linuxfoundation.org (Postfix) with ESMTP id A953D284F3 for ; Tue, 2 Aug 2016 18:15:39 +0000 (UTC) Received: by mail.wl.linuxfoundation.org (Postfix, from userid 486) id 9D6E6284F6; Tue, 2 Aug 2016 18:15:39 +0000 (UTC) X-Spam-Checker-Version: SpamAssassin 3.3.1 (2010-03-16) on pdx-wl-mail.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-6.9 required=2.0 tests=BAYES_00,RCVD_IN_DNSWL_HI autolearn=ham version=3.3.1 Received: from vger.kernel.org (vger.kernel.org [209.132.180.67]) by mail.wl.linuxfoundation.org (Postfix) with ESMTP id 4E76A284F3 for ; Tue, 2 Aug 2016 18:15:39 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755529AbcHBSPg (ORCPT ); Tue, 2 Aug 2016 14:15:36 -0400 Received: from mga14.intel.com ([192.55.52.115]:51452 "EHLO mga14.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1755298AbcHBL2k (ORCPT ); Tue, 2 Aug 2016 07:28:40 -0400 Received: from fmsmga004.fm.intel.com ([10.253.24.48]) by fmsmga103.fm.intel.com with ESMTP; 02 Aug 2016 04:28:39 -0700 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="149292288" Received: from shsibuild003.sh.intel.com ([10.239.146.225]) by fmsmga004.fm.intel.com with ESMTP; 02 Aug 2016 04:28:36 -0700 From: Baole Ni To: bonbons@linux-vserver.org, jikos@kernel.org, benjamin.tissoires@redhat.com, airlied@linux.ie, kgene@kernel.org, k.kozlowski@samsung.com, dougthompson@xmission.com, bp@alien8.de Cc: linux-input@vger.kernel.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com, alexander.deucher@amd.com, ville.syrjala@linux.intel.com Subject: [PATCH 0222/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 18:50:58 +0800 Message-Id: <20160802105058.28551-1-baolex.ni@intel.com> X-Mailer: git-send-email 2.9.2 Sender: linux-input-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-input@vger.kernel.org X-Virus-Scanned: ClamAV using ClamSMTP I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/hid/hid-picolcd_core.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/hid/hid-picolcd_core.c b/drivers/hid/hid-picolcd_core.c index c1b29a9..894d884 100644 --- a/drivers/hid/hid-picolcd_core.c +++ b/drivers/hid/hid-picolcd_core.c @@ -306,7 +306,7 @@ static ssize_t picolcd_operation_mode_store(struct device *dev, return count; } -static DEVICE_ATTR(operation_mode, 0644, picolcd_operation_mode_show, +static DEVICE_ATTR(operation_mode, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH, picolcd_operation_mode_show, picolcd_operation_mode_store); /* @@ -334,7 +334,7 @@ static ssize_t picolcd_operation_mode_delay_store(struct device *dev, return count; } -static DEVICE_ATTR(operation_mode_delay, 0644, picolcd_operation_mode_delay_show, +static DEVICE_ATTR(operation_mode_delay, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH, picolcd_operation_mode_delay_show, picolcd_operation_mode_delay_store); /*