Message ID | d225a837c50e2b19a41555a8f7ce0f94b1689aa4.1689600353.git.geert+renesas@glider.be (mailing list archive) |
---|---|
State | Mainlined |
Commit | 904ef2c47d8f3d0f0c7d5c0dd68ecc95908d7360 |
Headers | show |
Series | [resend,2] Input: gpio-keys - convert to dev_err_probe() | expand |
On Mon, Jul 17, 2023 at 03:27:05PM +0200, Geert Uytterhoeven wrote: > Use the dev_err_probe() helper, instead of open-coding the same > operation. > > While at it, invert the error checking logic to simplify code flow. > > Signed-off-by: Geert Uytterhoeven <geert+renesas@glider.be> Applied, thank you.
diff --git a/drivers/input/keyboard/gpio_keys.c b/drivers/input/keyboard/gpio_keys.c index 20250b072a7a01c5..7e8342ef7a79b17f 100644 --- a/drivers/input/keyboard/gpio_keys.c +++ b/drivers/input/keyboard/gpio_keys.c @@ -523,18 +523,15 @@ static int gpio_keys_setup_key(struct platform_device *pdev, NULL, GPIOD_IN, desc); if (IS_ERR(bdata->gpiod)) { error = PTR_ERR(bdata->gpiod); - if (error == -ENOENT) { - /* - * GPIO is optional, we may be dealing with - * purely interrupt-driven setup. - */ - bdata->gpiod = NULL; - } else { - if (error != -EPROBE_DEFER) - dev_err(dev, "failed to get gpio: %d\n", - error); - return error; - } + if (error != -ENOENT) + return dev_err_probe(dev, error, + "failed to get gpio\n"); + + /* + * GPIO is optional, we may be dealing with + * purely interrupt-driven setup. + */ + bdata->gpiod = NULL; } } else if (gpio_is_valid(button->gpio)) { /*
Use the dev_err_probe() helper, instead of open-coding the same operation. While at it, invert the error checking logic to simplify code flow. Signed-off-by: Geert Uytterhoeven <geert+renesas@glider.be> --- drivers/input/keyboard/gpio_keys.c | 21 +++++++++------------ 1 file changed, 9 insertions(+), 12 deletions(-)