diff mbox series

kbuild: Remove -Waggregate-return from scripts/Makefile.extrawarn

Message ID 20190529080434.1409-1-malat@debian.org (mailing list archive)
State New, archived
Headers show
Series kbuild: Remove -Waggregate-return from scripts/Makefile.extrawarn | expand

Commit Message

Mathieu Malaterre May 29, 2019, 8:04 a.m. UTC
It makes little sense to pass -Waggregate-return these days since large
part of the linux kernel rely on returning struct(s). For instance:

  ../include/linux/timekeeping.h: In function 'show_uptime':
  ../include/linux/ktime.h:91:34: error: function call has aggregate value [-Werror=aggregate-return]
   #define ktime_to_timespec64(kt)  ns_to_timespec64((kt))
                                    ^~~~~~~~~~~~~~~~~~~~~~
  ../include/linux/timekeeping.h:166:8: note: in expansion of macro 'ktime_to_timespec64'
    *ts = ktime_to_timespec64(ktime_get_coarse_boottime());

Remove this warning from W=2 completely.

Signed-off-by: Mathieu Malaterre <malat@debian.org>
---
 scripts/Makefile.extrawarn | 1 -
 1 file changed, 1 deletion(-)

Comments

Masahiro Yamada June 4, 2019, 5:09 p.m. UTC | #1
On Wed, May 29, 2019 at 5:16 PM Mathieu Malaterre <malat@debian.org> wrote:
>
> It makes little sense to pass -Waggregate-return these days since large
> part of the linux kernel rely on returning struct(s). For instance:
>
>   ../include/linux/timekeeping.h: In function 'show_uptime':
>   ../include/linux/ktime.h:91:34: error: function call has aggregate value [-Werror=aggregate-return]
>    #define ktime_to_timespec64(kt)  ns_to_timespec64((kt))
>                                     ^~~~~~~~~~~~~~~~~~~~~~
>   ../include/linux/timekeeping.h:166:8: note: in expansion of macro 'ktime_to_timespec64'
>     *ts = ktime_to_timespec64(ktime_get_coarse_boottime());
>
> Remove this warning from W=2 completely.
>
> Signed-off-by: Mathieu Malaterre <malat@debian.org>
> ---

Applied to linux-kbuild. Thanks.



>  scripts/Makefile.extrawarn | 1 -
>  1 file changed, 1 deletion(-)
>
> diff --git a/scripts/Makefile.extrawarn b/scripts/Makefile.extrawarn
> index 3ab8d1a303cd..98081ab300e5 100644
> --- a/scripts/Makefile.extrawarn
> +++ b/scripts/Makefile.extrawarn
> @@ -34,7 +34,6 @@ warning-1 += $(call cc-option, -Wstringop-truncation)
>  warning-1 += -Wno-missing-field-initializers
>  warning-1 += -Wno-sign-compare
>
> -warning-2 := -Waggregate-return
>  warning-2 += -Wcast-align
>  warning-2 += -Wdisabled-optimization
>  warning-2 += -Wnested-externs
> --
> 2.20.1
>
diff mbox series

Patch

diff --git a/scripts/Makefile.extrawarn b/scripts/Makefile.extrawarn
index 3ab8d1a303cd..98081ab300e5 100644
--- a/scripts/Makefile.extrawarn
+++ b/scripts/Makefile.extrawarn
@@ -34,7 +34,6 @@  warning-1 += $(call cc-option, -Wstringop-truncation)
 warning-1 += -Wno-missing-field-initializers
 warning-1 += -Wno-sign-compare
 
-warning-2 := -Waggregate-return
 warning-2 += -Wcast-align
 warning-2 += -Wdisabled-optimization
 warning-2 += -Wnested-externs