mbox series

[-next,v3,00/10] cleanup in Huawei hinic driver

Message ID 20220921123358.63442-1-shaozhengchao@huawei.com (mailing list archive)
Headers show
Series cleanup in Huawei hinic driver | expand

Message

shaozhengchao Sept. 21, 2022, 12:33 p.m. UTC
Do code cleanup in Huawei hinic driver.

Zhengchao Shao (10):
  net: hinic: modify kernel doc comments
  net: hinic: change type of function to be static
  net: hinic: remove unused functions
  net: hinic: remove unused macro
  net: hinic: remove duplicate macro definition
  net: hinic: simplify code logic
  net: hinic: change hinic_deinit_vf_hw() to void
  net: hinic: remove unused enumerated value
  net: hinic: replace magic numbers with macro
  net: hinic: remove the unused input parameter prod_idx in
    sq_prepare_ctrl()

 .../net/ethernet/huawei/hinic/hinic_debugfs.h |  1 -
 .../net/ethernet/huawei/hinic/hinic_ethtool.c |  1 -
 .../net/ethernet/huawei/hinic/hinic_hw_cmdq.c |  9 ++---
 .../net/ethernet/huawei/hinic/hinic_hw_cmdq.h |  3 --
 .../net/ethernet/huawei/hinic/hinic_hw_csr.h  |  1 -
 .../net/ethernet/huawei/hinic/hinic_hw_dev.c  | 17 ++-------
 .../net/ethernet/huawei/hinic/hinic_hw_dev.h  |  5 ---
 .../net/ethernet/huawei/hinic/hinic_hw_if.c   | 35 -------------------
 .../net/ethernet/huawei/hinic/hinic_hw_if.h   |  9 -----
 .../net/ethernet/huawei/hinic/hinic_hw_mbox.c |  9 ++---
 .../net/ethernet/huawei/hinic/hinic_hw_mbox.h |  4 ---
 .../net/ethernet/huawei/hinic/hinic_hw_qp.c   | 11 +++---
 .../net/ethernet/huawei/hinic/hinic_hw_qp.h   |  5 ++-
 .../net/ethernet/huawei/hinic/hinic_hw_wq.c   |  2 --
 .../net/ethernet/huawei/hinic/hinic_hw_wqe.h  | 25 -------------
 .../net/ethernet/huawei/hinic/hinic_main.c    |  4 ---
 drivers/net/ethernet/huawei/hinic/hinic_rx.c  |  2 +-
 drivers/net/ethernet/huawei/hinic/hinic_rx.h  |  2 --
 .../net/ethernet/huawei/hinic/hinic_sriov.c   | 15 ++++----
 .../net/ethernet/huawei/hinic/hinic_sriov.h   |  2 --
 drivers/net/ethernet/huawei/hinic/hinic_tx.c  |  6 ++--
 drivers/net/ethernet/huawei/hinic/hinic_tx.h  |  2 --
 22 files changed, 23 insertions(+), 147 deletions(-)

Comments

patchwork-bot+netdevbpf@kernel.org Sept. 23, 2022, 1:10 a.m. UTC | #1
Hello:

This series was applied to netdev/net-next.git (master)
by Jakub Kicinski <kuba@kernel.org>:

On Wed, 21 Sep 2022 20:33:48 +0800 you wrote:
> Do code cleanup in Huawei hinic driver.
> 
> Zhengchao Shao (10):
>   net: hinic: modify kernel doc comments
>   net: hinic: change type of function to be static
>   net: hinic: remove unused functions
>   net: hinic: remove unused macro
>   net: hinic: remove duplicate macro definition
>   net: hinic: simplify code logic
>   net: hinic: change hinic_deinit_vf_hw() to void
>   net: hinic: remove unused enumerated value
>   net: hinic: replace magic numbers with macro
>   net: hinic: remove the unused input parameter prod_idx in
>     sq_prepare_ctrl()
> 
> [...]

Here is the summary with links:
  - [-next,v3,01/10] net: hinic: modify kernel doc comments
    https://git.kernel.org/netdev/net-next/c/15b209cde263
  - [-next,v3,02/10] net: hinic: change type of function to be static
    https://git.kernel.org/netdev/net-next/c/73f25f16cc3c
  - [-next,v3,03/10] net: hinic: remove unused functions
    https://git.kernel.org/netdev/net-next/c/2b291ee6dd6e
  - [-next,v3,04/10] net: hinic: remove unused macro
    https://git.kernel.org/netdev/net-next/c/2fa1cd3b4a0d
  - [-next,v3,05/10] net: hinic: remove duplicate macro definition
    https://git.kernel.org/netdev/net-next/c/97d6a3e642bf
  - [-next,v3,06/10] net: hinic: simplify code logic
    https://git.kernel.org/netdev/net-next/c/4f304250c39b
  - [-next,v3,07/10] net: hinic: change hinic_deinit_vf_hw() to void
    https://git.kernel.org/netdev/net-next/c/dcbe72d25594
  - [-next,v3,08/10] net: hinic: remove unused enumerated value
    https://git.kernel.org/netdev/net-next/c/566ad0ed6b12
  - [-next,v3,09/10] net: hinic: replace magic numbers with macro
    https://git.kernel.org/netdev/net-next/c/57ac57154d83
  - [-next,v3,10/10] net: hinic: remove the unused input parameter prod_idx in sq_prepare_ctrl()
    https://git.kernel.org/netdev/net-next/c/c706df6d8f6e

You are awesome, thank you!