Message ID | 20240420-bpf_wq-v2-0-6c986a5a741f@kernel.org (mailing list archive) |
---|---|
Headers | show |
Series | Introduce bpf_wq | expand |
Hello: This series was applied to bpf/bpf-next.git (master) by Alexei Starovoitov <ast@kernel.org>: On Sat, 20 Apr 2024 11:09:00 +0200 you wrote: > This is a followup of sleepable bpf_timer[0]. > > When discussing sleepable bpf_timer, it was thought that we should give > a try to bpf_wq, as the 2 APIs are similar but distinct enough to > justify a new one. > > So here it is. > > [...] Here is the summary with links: - [bpf-next,v2,01/16] bpf: make timer data struct more generic https://git.kernel.org/bpf/bpf-next/c/be2749beff62 - [bpf-next,v2,02/16] bpf: replace bpf_timer_init with a generic helper https://git.kernel.org/bpf/bpf-next/c/56b4a177ae63 - [bpf-next,v2,03/16] bpf: replace bpf_timer_set_callback with a generic helper https://git.kernel.org/bpf/bpf-next/c/073f11b02643 - [bpf-next,v2,04/16] bpf: replace bpf_timer_cancel_and_free with a generic helper https://git.kernel.org/bpf/bpf-next/c/fc22d9495f0b - [bpf-next,v2,05/16] bpf: add support for bpf_wq user type https://git.kernel.org/bpf/bpf-next/c/d56b63cf0c0f - [bpf-next,v2,06/16] tools: sync include/uapi/linux/bpf.h https://git.kernel.org/bpf/bpf-next/c/f1d0a2fbb008 - [bpf-next,v2,07/16] bpf: verifier: bail out if the argument is not a map https://git.kernel.org/bpf/bpf-next/c/ad2c03e691be - [bpf-next,v2,08/16] bpf: add support for KF_ARG_PTR_TO_WORKQUEUE https://git.kernel.org/bpf/bpf-next/c/d940c9b94d7e - [bpf-next,v2,09/16] bpf: allow struct bpf_wq to be embedded in arraymaps and hashmaps https://git.kernel.org/bpf/bpf-next/c/246331e3f1ea - [bpf-next,v2,10/16] selftests/bpf: add bpf_wq tests https://git.kernel.org/bpf/bpf-next/c/b4abee7c1ae3 - [bpf-next,v2,11/16] bpf: wq: add bpf_wq_init https://git.kernel.org/bpf/bpf-next/c/eb48f6cd41a0 - [bpf-next,v2,12/16] selftests/bpf: wq: add bpf_wq_init() checks https://git.kernel.org/bpf/bpf-next/c/e3d9eac99afd - [bpf-next,v2,13/16] bpf: wq: add bpf_wq_set_callback_impl https://git.kernel.org/bpf/bpf-next/c/81f1d7a583fa - [bpf-next,v2,14/16] selftests/bpf: add checks for bpf_wq_set_callback() https://git.kernel.org/bpf/bpf-next/c/01b7b1c5f3cc - [bpf-next,v2,15/16] bpf: add bpf_wq_start https://git.kernel.org/bpf/bpf-next/c/8e83da9732d9 - [bpf-next,v2,16/16] selftests/bpf: wq: add bpf_wq_start() checks https://git.kernel.org/bpf/bpf-next/c/8290dba51910 You are awesome, thank you!
This is a followup of sleepable bpf_timer[0]. When discussing sleepable bpf_timer, it was thought that we should give a try to bpf_wq, as the 2 APIs are similar but distinct enough to justify a new one. So here it is. I tried to keep as much as possible common code in kernel/bpf/helpers.c but I couldn't get away with code duplication in kernel/bpf/verifier.c. This series introduces a basic bpf_wq support: - creation is supported - assignment is supported - running a simple bpf_wq is also supported. We will probably need to extend the API further with: - a full delayed_work API (can be piggy backed on top with a correct flag) - bpf_wq_cancel() <- apparently not, this is shooting ourself in the foot - bpf_wq_cancel_sync() (for sleepable programs) - documentation --- For reference, the use cases I have in mind: --- Basically, I need to be able to defer a HID-BPF program for the following reasons (from the aforementioned patch): 1. defer an event: Sometimes we receive an out of proximity event, but the device can not be trusted enough, and we need to ensure that we won't receive another one in the following n milliseconds. So we need to wait those n milliseconds, and eventually re-inject that event in the stack. 2. inject new events in reaction to one given event: We might want to transform one given event into several. This is the case for macro keys where a single key press is supposed to send a sequence of key presses. But this could also be used to patch a faulty behavior, if a device forgets to send a release event. 3. communicate with the device in reaction to one event: We might want to communicate back to the device after a given event. For example a device might send us an event saying that it came back from sleeping state and needs to be re-initialized. Currently we can achieve that by keeping a userspace program around, raise a bpf event, and let that userspace program inject the events and commands. However, we are just keeping that program alive as a daemon for just scheduling commands. There is no logic in it, so it doesn't really justify an actual userspace wakeup. So a kernel workqueue seems simpler to handle. bpf_timers are currently running in a soft IRQ context, this patch series implements a sleppable context for them. Cheers, Benjamin To: Alexei Starovoitov <ast@kernel.org> To: Daniel Borkmann <daniel@iogearbox.net> To: Andrii Nakryiko <andrii@kernel.org> To: Martin KaFai Lau <martin.lau@linux.dev> To: Eduard Zingerman <eddyz87@gmail.com> To: Song Liu <song@kernel.org> To: Yonghong Song <yonghong.song@linux.dev> To: John Fastabend <john.fastabend@gmail.com> To: KP Singh <kpsingh@kernel.org> To: Stanislav Fomichev <sdf@google.com> To: Hao Luo <haoluo@google.com> To: Jiri Olsa <jolsa@kernel.org> To: Mykola Lysenko <mykolal@fb.com> To: Shuah Khan <shuah@kernel.org> Cc: <bpf@vger.kernel.org> Cc: <linux-kernel@vger.kernel.org> Cc: <linux-kselftest@vger.kernel.org> Signed-off-by: Benjamin Tissoires <bentiss@kernel.org> [0] https://lore.kernel.org/all/20240408-hid-bpf-sleepable-v6-0-0499ddd91b94@kernel.org/ --- Changes in v2: - took previous review into account - mainly dropped BPF_F_WQ_SLEEPABLE - Link to v1: https://lore.kernel.org/r/20240416-bpf_wq-v1-0-c9e66092f842@kernel.org --- Benjamin Tissoires (16): bpf: make timer data struct more generic bpf: replace bpf_timer_init with a generic helper bpf: replace bpf_timer_set_callback with a generic helper bpf: replace bpf_timer_cancel_and_free with a generic helper bpf: add support for bpf_wq user type tools: sync include/uapi/linux/bpf.h bpf: verifier: bail out if the argument is not a map bpf: add support for KF_ARG_PTR_TO_WORKQUEUE bpf: allow struct bpf_wq to be embedded in arraymaps and hashmaps selftests/bpf: add bpf_wq tests bpf: wq: add bpf_wq_init selftests/bpf: wq: add bpf_wq_init() checks bpf: wq: add bpf_wq_set_callback_impl selftests/bpf: add checks for bpf_wq_set_callback() bpf: add bpf_wq_start selftests/bpf: wq: add bpf_wq_start() checks include/linux/bpf.h | 13 +- include/linux/bpf_verifier.h | 1 + include/uapi/linux/bpf.h | 4 + kernel/bpf/arraymap.c | 18 +- kernel/bpf/btf.c | 17 + kernel/bpf/hashtab.c | 55 +++- kernel/bpf/helpers.c | 348 ++++++++++++++++----- kernel/bpf/syscall.c | 15 +- kernel/bpf/verifier.c | 154 ++++++++- tools/include/uapi/linux/bpf.h | 4 + tools/testing/selftests/bpf/bpf_experimental.h | 7 + .../selftests/bpf/bpf_testmod/bpf_testmod.c | 5 + .../selftests/bpf/bpf_testmod/bpf_testmod_kfunc.h | 1 + tools/testing/selftests/bpf/prog_tests/wq.c | 41 +++ tools/testing/selftests/bpf/progs/wq.c | 186 +++++++++++ tools/testing/selftests/bpf/progs/wq_failures.c | 144 +++++++++ 16 files changed, 910 insertions(+), 103 deletions(-) --- base-commit: ffa6b26b4d8a0520b78636ca9373ab842cb3b1a8 change-id: 20240411-bpf_wq-fe24e8d24f5e Best regards,