diff mbox series

rtc: Rename lib_test to rtc_lib_test

Message ID 8edd0c09fe12d1225e2b830f8a55e7c830da078b.1743090053.git.geert@linux-m68k.org (mailing list archive)
State New
Headers show
Series rtc: Rename lib_test to rtc_lib_test | expand

Commit Message

Geert Uytterhoeven March 27, 2025, 3:42 p.m. UTC
When compiling the RTC library functions test as a module, the module
has the non-descriptive name "lib_test.ko".  Fix this by adding the
subsystem's name as a prefix.

Signed-off-by: Geert Uytterhoeven <geert@linux-m68k.org>
---
 drivers/rtc/Makefile                       | 2 +-
 drivers/rtc/{lib_test.c => rtc_lib_test.c} | 0
 2 files changed, 1 insertion(+), 1 deletion(-)
 rename drivers/rtc/{lib_test.c => rtc_lib_test.c} (100%)
diff mbox series

Patch

diff --git a/drivers/rtc/Makefile b/drivers/rtc/Makefile
index 489b4ab07068c758..c0ccbbfe2739c1aa 100644
--- a/drivers/rtc/Makefile
+++ b/drivers/rtc/Makefile
@@ -15,7 +15,7 @@  rtc-core-$(CONFIG_RTC_INTF_DEV)		+= dev.o
 rtc-core-$(CONFIG_RTC_INTF_PROC)	+= proc.o
 rtc-core-$(CONFIG_RTC_INTF_SYSFS)	+= sysfs.o
 
-obj-$(CONFIG_RTC_LIB_KUNIT_TEST)	+= lib_test.o
+obj-$(CONFIG_RTC_LIB_KUNIT_TEST)	+= rtc_lib_test.o
 
 # Keep the list ordered.
 
diff --git a/drivers/rtc/lib_test.c b/drivers/rtc/rtc_lib_test.c
similarity index 100%
rename from drivers/rtc/lib_test.c
rename to drivers/rtc/rtc_lib_test.c