From patchwork Sat Jun 13 09:13:47 2020 Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: 7bit X-Patchwork-Submitter: Dafna Hirschfeld X-Patchwork-Id: 11602699 Return-Path: Received: from mail.kernel.org (pdx-korg-mail-1.web.codeaurora.org [172.30.200.123]) by pdx-korg-patchwork-2.web.codeaurora.org (Postfix) with ESMTP id 3123A13B1 for ; Sat, 13 Jun 2020 09:14:28 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id 190B120836 for ; Sat, 13 Jun 2020 09:14:28 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1726381AbgFMJOU (ORCPT ); Sat, 13 Jun 2020 05:14:20 -0400 Received: from lindbergh.monkeyblade.net ([23.128.96.19]:58124 "EHLO lindbergh.monkeyblade.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1726308AbgFMJOR (ORCPT ); Sat, 13 Jun 2020 05:14:17 -0400 Received: from bhuna.collabora.co.uk (bhuna.collabora.co.uk [IPv6:2a00:1098:0:82:1000:25:2eeb:e3e3]) by lindbergh.monkeyblade.net (Postfix) with ESMTPS id C8F2DC08C5C1 for ; Sat, 13 Jun 2020 02:14:16 -0700 (PDT) Received: from [127.0.0.1] (localhost [127.0.0.1]) (Authenticated sender: dafna) with ESMTPSA id 705492A0D2F From: Dafna Hirschfeld To: linux-media@vger.kernel.org, laurent.pinchart@ideasonboard.com Cc: dafna.hirschfeld@collabora.com, helen.koike@collabora.com, ezequiel@collabora.com, hverkuil@xs4all.nl, kernel@collabora.com, dafna3@gmail.com, sakari.ailus@linux.intel.com, linux-rockchip@lists.infradead.org, mchehab@kernel.org, tfiga@chromium.org Subject: [RESEND PATCH v3 0/6] media: staging: rkisp1: bugs fixes and vars renames Date: Sat, 13 Jun 2020 11:13:47 +0200 Message-Id: <20200613091353.12689-1-dafna.hirschfeld@collabora.com> X-Mailer: git-send-email 2.17.1 Sender: linux-media-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-media@vger.kernel.org RESEND the patchset because I forgot to add the first two patches to the set (now also dropping CC to stable) The first two patches in this patchset are two bug fixes related to the enumeration and settings of the sink format of the resizer entity. The next 3 patches are renaming/removing macros and variables. patch 6 adds documentation to the struct rkisp1_isp_mbus_info changes from v2: - patch 3 is new - remove macro RKISP1_DIR_SINK_SRC since the code is more readable without it. - patch 5 - rename 'direction' to 'isp_pads_mask' instead of 'isp_pads_flags' - patch 6 is new - add documentation of the struct 'rkisp1_isp_mbus_info' changes from v1: - added "Fixes: 56e3b29f9f6b "media: staging: rkisp1: add streaming paths" to the commit log of the first two patches. - added two patches. One patch rename the macros "RKISP1_DIR_*" to "RKISP1_ISP_SD_*", another that rename the field 'direction' in 'struct rkisp1_isp_mbus_info' to 'isp_pads_flags' Dafna Hirschfeld (6): media: staging: rkisp1: rsz: supported formats are the isp's src formats, not sink formats media: staging: rkisp1: rsz: set default format if the given format is not RKISP1_DIR_SRC media: staging: rkisp1: remove macro RKISP1_DIR_SINK_SRC media: staging: rkisp1: rename macros 'RKISP1_DIR_*' to 'RKISP1_ISP_SD_*' media: staging: rkisp1: rename the field 'direction' in 'rkisp1_isp_mbus_info' to 'isp_pads_mask' media: staging: rkisp1: common: add documentation for struct rkisp1_isp_mbus_info drivers/staging/media/rkisp1/rkisp1-common.h | 18 ++++++- drivers/staging/media/rkisp1/rkisp1-isp.c | 50 +++++++++---------- drivers/staging/media/rkisp1/rkisp1-resizer.c | 6 +-- 3 files changed, 43 insertions(+), 31 deletions(-)