Message ID | 1236934923-32216-1-git-send-email-chaithrika@ti.com (mailing list archive) |
---|---|
State | RFC |
Headers | show |
On Friday 13 March 2009, chaithrika@ti.com wrote: > Â > +config DISPLAY_DAVINCI_DM646X_EVM > + Â Â Â Â tristate "DM646x EVM Video Display" > + Â Â Â Â depends on VIDEO_DEV && MACH_DAVINCI_DM646X_EVM > + Â Â Â Â select VIDEOBUF_DMA_CONTIG > + Â Â Â Â select VIDEO_DAVINCI_VPIF > + Â Â Â Â select VIDEO_ADV7343 > + Â Â Â Â select VIDEO_THS7303 A quick glance at the dm646x_display.c code in patch 7 suggests that the file name is generic, but the code is full of EVM-specific bits. I suggest either making the code generic (and maybe move most of that VPIF code into the VPIF driver) so other dm646x boards can reuse it ... or renaming it. Generic would IMO be preferrable. > +config VIDEO_DAVINCI_VPIF > + Â Â Â Â tristate "DaVinci VPIF Driver" > + Â Â Â Â depends on DISPLAY_DAVINCI_DM646X_EVM Please have the Kconfig helptext here explain what a VPIF is and does. Surely the driver is usable for any dm646x board, not just the EVM hardware; so, "depends on ARCH_DAVINCI_DM646x". And, patch style point, most of us like to see one patch adding an entire driver ... C source, headers, and its associated Kconfig and Kbuild support. Make sure that the kernel continues building between patches; in this case, the build will break after patch #5 since the source code it tries to build hasn't been added yet. -- To unsubscribe from this list: send the line "unsubscribe linux-media" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html
diff --git a/drivers/media/video/Kconfig b/drivers/media/video/Kconfig index b3b591d..9d3c0c7 100644 --- a/drivers/media/video/Kconfig +++ b/drivers/media/video/Kconfig @@ -471,6 +471,28 @@ config VIDEO_UPD64083 endmenu # encoder / decoder chips +config DISPLAY_DAVINCI_DM646X_EVM + tristate "DM646x EVM Video Display" + depends on VIDEO_DEV && MACH_DAVINCI_DM646X_EVM + select VIDEOBUF_DMA_CONTIG + select VIDEO_DAVINCI_VPIF + select VIDEO_ADV7343 + select VIDEO_THS7303 + help + Support for DaVinci based display device. + + To compile this driver as a module, choose M here: the + module will be called davincihd_display. + +config VIDEO_DAVINCI_VPIF + tristate "DaVinci VPIF Driver" + depends on DISPLAY_DAVINCI_DM646X_EVM + help + Support for DaVinci VPIF Driver. + + To compile this driver as a module, choose M here: the + module will be called vpif. + config VIDEO_VIVI tristate "Virtual Video Driver" depends on VIDEO_DEV && VIDEO_V4L2 && !SPARC32 && !SPARC64 diff --git a/drivers/media/video/Makefile b/drivers/media/video/Makefile index 1ed9c2c..7f0b7dc 100644 --- a/drivers/media/video/Makefile +++ b/drivers/media/video/Makefile @@ -151,6 +151,8 @@ obj-$(CONFIG_VIDEO_AU0828) += au0828/ obj-$(CONFIG_USB_VIDEO_CLASS) += uvc/ +obj-$(CONFIG_ARCH_DAVINCI) += davinci/ + EXTRA_CFLAGS += -Idrivers/media/dvb/dvb-core EXTRA_CFLAGS += -Idrivers/media/dvb/frontends EXTRA_CFLAGS += -Idrivers/media/common/tuners diff --git a/drivers/media/video/davinci/Makefile b/drivers/media/video/davinci/Makefile new file mode 100644 index 0000000..5134585 --- /dev/null +++ b/drivers/media/video/davinci/Makefile @@ -0,0 +1,9 @@ +# +# Makefile for the davinci video device drivers. +# + +# VPIF +obj-$(CONFIG_VIDEO_DAVINCI_VPIF) += vpif.o + +#DM646x EVM Display driver +obj-$(CONFIG_DISPLAY_DAVINCI_DM646X_EVM) += dm646x_display.o