Message ID | 20241031141747.4697-1-sakari.ailus@linux.intel.com (mailing list archive) |
---|---|
State | New |
Headers | show |
Series | [1/1] media: mc: Rename pad as origin in __media_pipeline_start() | expand |
Hi Sakari, Thank you for the patch. On Thu, Oct 31, 2024 at 04:17:47PM +0200, Sakari Ailus wrote: > Rename the pad field in __media_pipeline_start() to both better describe > what it is and avoid masking it during the loop. > > Signed-off-by: Sakari Ailus <sakari.ailus@linux.intel.com> > --- > drivers/media/mc/mc-entity.c | 8 ++++---- > 1 file changed, 4 insertions(+), 4 deletions(-) > > diff --git a/drivers/media/mc/mc-entity.c b/drivers/media/mc/mc-entity.c > index 96dd0f6ccd0d..0df9fc90cf33 100644 > --- a/drivers/media/mc/mc-entity.c > +++ b/drivers/media/mc/mc-entity.c > @@ -768,10 +768,10 @@ static int media_pipeline_populate(struct media_pipeline *pipe, > return ret; > } > > -__must_check int __media_pipeline_start(struct media_pad *pad, > +__must_check int __media_pipeline_start(struct media_pad *origin, > struct media_pipeline *pipe) You need to also update the documentation in include/media/media-entity.h. With that fixed, Reviewed-by: Laurent Pinchart <laurent.pinchart+renesas@ideasonboard.com> I believe the media CI builds the documentation, did it fail to catch the issue ? > { > - struct media_device *mdev = pad->graph_obj.mdev; > + struct media_device *mdev = origin->graph_obj.mdev; > struct media_pipeline_pad *err_ppad; > struct media_pipeline_pad *ppad; > int ret; > @@ -782,7 +782,7 @@ __must_check int __media_pipeline_start(struct media_pad *pad, > * If the pad is already part of a pipeline, that pipeline must be the > * same as the pipe given to media_pipeline_start(). > */ > - if (WARN_ON(pad->pipe && pad->pipe != pipe)) > + if (WARN_ON(origin->pipe && origin->pipe != pipe)) > return -EINVAL; > > /* > @@ -799,7 +799,7 @@ __must_check int __media_pipeline_start(struct media_pad *pad, > * with media_pipeline_pad instances for each pad found during graph > * walk. > */ > - ret = media_pipeline_populate(pipe, pad); > + ret = media_pipeline_populate(pipe, origin); > if (ret) > return ret; >
diff --git a/drivers/media/mc/mc-entity.c b/drivers/media/mc/mc-entity.c index 96dd0f6ccd0d..0df9fc90cf33 100644 --- a/drivers/media/mc/mc-entity.c +++ b/drivers/media/mc/mc-entity.c @@ -768,10 +768,10 @@ static int media_pipeline_populate(struct media_pipeline *pipe, return ret; } -__must_check int __media_pipeline_start(struct media_pad *pad, +__must_check int __media_pipeline_start(struct media_pad *origin, struct media_pipeline *pipe) { - struct media_device *mdev = pad->graph_obj.mdev; + struct media_device *mdev = origin->graph_obj.mdev; struct media_pipeline_pad *err_ppad; struct media_pipeline_pad *ppad; int ret; @@ -782,7 +782,7 @@ __must_check int __media_pipeline_start(struct media_pad *pad, * If the pad is already part of a pipeline, that pipeline must be the * same as the pipe given to media_pipeline_start(). */ - if (WARN_ON(pad->pipe && pad->pipe != pipe)) + if (WARN_ON(origin->pipe && origin->pipe != pipe)) return -EINVAL; /* @@ -799,7 +799,7 @@ __must_check int __media_pipeline_start(struct media_pad *pad, * with media_pipeline_pad instances for each pad found during graph * walk. */ - ret = media_pipeline_populate(pipe, pad); + ret = media_pipeline_populate(pipe, origin); if (ret) return ret;
Rename the pad field in __media_pipeline_start() to both better describe what it is and avoid masking it during the loop. Signed-off-by: Sakari Ailus <sakari.ailus@linux.intel.com> --- drivers/media/mc/mc-entity.c | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-)