Message ID | 20210318122722.13135-1-linmiaohe@huawei.com (mailing list archive) |
---|---|
Headers | show |
Series | Some cleanups for huge_memory | expand |
On Thu, Mar 18, 2021 at 08:27:16AM -0400, Miaohe Lin wrote: > Hi all, > This series contains cleanups to rework some function logics to make it > more readable, use helper function and so on. More details can be found > in the respective changelogs. Thanks! > > v2->v3: > use ALIGN/ALIGN_DOWN too against HPAGE_PMD_SIZE per Peter. > > v1->v2: > rename try_to_split_huge_pmd_address and move up comments. > > Miaohe Lin (6): > mm/huge_memory.c: rework the function vma_adjust_trans_huge() > mm/huge_memory.c: make get_huge_zero_page() return bool > mm/huge_memory.c: rework the function do_huge_pmd_numa_page() slightly > mm/huge_memory.c: remove redundant PageCompound() check > mm/huge_memory.c: remove unused macro > TRANSPARENT_HUGEPAGE_DEBUG_COW_FLAG > mm/huge_memory.c: use helper function migration_entry_to_page() Reviewed-by: Peter Xu <peterx@redhat.com>