mbox series

[00/16] A few cleanup and fixup patches for migration

Message ID 20220304093409.25829-1-linmiaohe@huawei.com (mailing list archive)
Headers show
Series A few cleanup and fixup patches for migration | expand

Message

Miaohe Lin March 4, 2022, 9:33 a.m. UTC
Hi everyone,
This series contains a few patches to remove unneeded variables, jump
label and use helper to simplify the code. Also we fix some bugs such
as page refcounts leak , pte_unmap on an not mapped pte and so on. More
details can be found in the respective changelogs. Thanks!

Miaohe Lin (16):
  mm/migration: remove unneeded local variable mapping_locked
  mm/migration: remove unneeded out label
  mm/migration: remove unneeded local variable page_lru
  mm/migration: reduce the rcu lock duration
  mm/migration: fix the confusing PageTransHuge check
  mm/migration: use helper function vma_lookup() in
    add_page_for_migration
  mm/migration: use helper macro min_t in do_pages_stat
  mm/migration: avoid unneeded nodemask_t initialization
  mm/migration: remove some duplicated codes in migrate_pages
  mm/migration: remove PG_writeback handle in folio_migrate_flags
  mm/migration: remove unneeded lock page and PageMovable check
  mm/migration: fix potential page refcounts leak in migrate_pages
  mm/migration: return errno when isolate_huge_page failed
  mm/migration: fix potential invalid node access for reclaim-based
    migration
  mm/migration: fix possible do_pages_stat_array racing with memory
    offline
  mm/migration: fix potential pte_unmap on an not mapped pte

 include/linux/migrate.h |   2 +-
 include/linux/swapops.h |   4 +-
 mm/filemap.c            |  10 +--
 mm/hugetlb.c            |   2 +-
 mm/migrate.c            | 138 ++++++++++++++++------------------------
 5 files changed, 65 insertions(+), 91 deletions(-)