mbox series

[mm-unstable,0/2] mm_init: rename *init_reserved_page* functions

Message ID 20250225083017.567649-1-rppt@kernel.org (mailing list archive)
Headers show
Series mm_init: rename *init_reserved_page* functions | expand

Message

Mike Rapoport Feb. 25, 2025, 8:30 a.m. UTC
From: "Mike Rapoport (Microsoft)" <rppt@kernel.org>

Hi,

Following Wei's comments on my patch that renamed init_reserved_page() to
init_deferred_page(), I think it makes sense to pull that patch out of KHO
series and merge it now.

To take into account the refactoring of that function in mm-unstable there
is also a patch that renames __init_reserved_page_zone() to
__init_page_from_nid().

[1] https://lore.kernel.org/linux-mm/Z71z9fO6tE5Px8rT@kernel.org/

Mike Rapoport (Microsoft) (2):
  mm/mm_init: rename __init_reserved_page_zone to __init_page_from_nid
  mm/mm_init: rename init_reserved_page to init_deferred_page

 mm/hugetlb.c  |  2 +-
 mm/internal.h |  2 +-
 mm/mm_init.c  | 10 +++++-----
 3 files changed, 7 insertions(+), 7 deletions(-)