Message ID | 1581919110-29575-1-git-send-email-kernelfans@gmail.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | [PATCHv2] mm/sparse: rename pfn_present() as pfn_in_present_section() | expand |
On 17.02.20 06:58, Pingfan Liu wrote: > After introducing mem sub section concept, pfn_present() loses its literal > meaning, and will not be necessary a truth on partial populated mem section. > > Since all of the callers use it to judge an absent section, it is better to > rename pfn_present() as pfn_in_present_section(). > > Signed-off-by: Pingfan Liu <kernelfans@gmail.com> > Cc: Dan Williams <dan.j.williams@intel.com> > Cc: Michal Hocko <mhocko@kernel.org> > Cc: Benjamin Herrenschmidt <benh@kernel.crashing.org> > Cc: Paul Mackerras <paulus@samba.org> > Cc: Michael Ellerman <mpe@ellerman.id.au> > Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org> > Cc: "Rafael J. Wysocki" <rafael@kernel.org> > Cc: Andrew Morton <akpm@linux-foundation.org> > Cc: David Hildenbrand <david@redhat.com> > Cc: Leonardo Bras <leonardo@linux.ibm.com> > Cc: Nathan Fontenot <nfont@linux.vnet.ibm.com> > Cc: Nathan Lynch <nathanl@linux.ibm.com> > To: linux-mm@kvack.org > --- > v1 -> v2: adopt David's suggestion, rename it as pfn_in_present_section() > arch/powerpc/platforms/pseries/hotplug-memory.c | 2 +- > drivers/base/node.c | 2 +- > include/linux/mmzone.h | 4 ++-- > mm/page_ext.c | 2 +- > mm/shuffle.c | 2 +- > 5 files changed, 6 insertions(+), 6 deletions(-) > > diff --git a/arch/powerpc/platforms/pseries/hotplug-memory.c b/arch/powerpc/platforms/pseries/hotplug-memory.c > index a4d40a3..f3ed1ba 100644 > --- a/arch/powerpc/platforms/pseries/hotplug-memory.c > +++ b/arch/powerpc/platforms/pseries/hotplug-memory.c > @@ -360,7 +360,7 @@ static bool lmb_is_removable(struct drmem_lmb *lmb) > > for (i = 0; i < scns_per_block; i++) { > pfn = PFN_DOWN(phys_addr); > - if (!pfn_present(pfn)) { > + if (!pfn_in_present_section(pfn)) { > phys_addr += MIN_MEMORY_BLOCK_SIZE; > continue; > } > diff --git a/drivers/base/node.c b/drivers/base/node.c > index 98a31ba..10d7e81 100644 > --- a/drivers/base/node.c > +++ b/drivers/base/node.c > @@ -772,7 +772,7 @@ static int register_mem_sect_under_node(struct memory_block *mem_blk, > * memory block could have several absent sections from start. > * skip pfn range from absent section > */ > - if (!pfn_present(pfn)) { > + if (!pfn_in_present_section(pfn)) { > pfn = round_down(pfn + PAGES_PER_SECTION, > PAGES_PER_SECTION) - 1; > continue; > diff --git a/include/linux/mmzone.h b/include/linux/mmzone.h > index 462f687..f6ceebdb 100644 > --- a/include/linux/mmzone.h > +++ b/include/linux/mmzone.h > @@ -1372,7 +1372,7 @@ static inline int pfn_valid(unsigned long pfn) > } > #endif > > -static inline int pfn_present(unsigned long pfn) > +static inline int pfn_in_present_section(unsigned long pfn) > { > if (pfn_to_section_nr(pfn) >= NR_MEM_SECTIONS) > return 0; > @@ -1409,7 +1409,7 @@ void sparse_init(void); > #else > #define sparse_init() do {} while (0) > #define sparse_index_init(_sec, _nid) do {} while (0) > -#define pfn_present pfn_valid > +#define pfn_in_present_section pfn_valid > #define subsection_map_init(_pfn, _nr_pages) do {} while (0) > #endif /* CONFIG_SPARSEMEM */ > > diff --git a/mm/page_ext.c b/mm/page_ext.c > index 4ade843..08ded03 100644 > --- a/mm/page_ext.c > +++ b/mm/page_ext.c > @@ -304,7 +304,7 @@ static int __meminit online_page_ext(unsigned long start_pfn, > } > > for (pfn = start; !fail && pfn < end; pfn += PAGES_PER_SECTION) { > - if (!pfn_present(pfn)) > + if (!pfn_in_present_section(pfn)) > continue; This check should be gone in -next already. Reviewed-by: David Hildenbrand <david@redhat.com>
Pingfan Liu <kernelfans@gmail.com> writes: > After introducing mem sub section concept, pfn_present() loses its literal > meaning, and will not be necessary a truth on partial populated mem section. > > Since all of the callers use it to judge an absent section, it is better to > rename pfn_present() as pfn_in_present_section(). > > Signed-off-by: Pingfan Liu <kernelfans@gmail.com> > Cc: Dan Williams <dan.j.williams@intel.com> > Cc: Michal Hocko <mhocko@kernel.org> > Cc: Benjamin Herrenschmidt <benh@kernel.crashing.org> > Cc: Paul Mackerras <paulus@samba.org> > Cc: Michael Ellerman <mpe@ellerman.id.au> > Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org> > Cc: "Rafael J. Wysocki" <rafael@kernel.org> > Cc: Andrew Morton <akpm@linux-foundation.org> > Cc: David Hildenbrand <david@redhat.com> > Cc: Leonardo Bras <leonardo@linux.ibm.com> > Cc: Nathan Fontenot <nfont@linux.vnet.ibm.com> > Cc: Nathan Lynch <nathanl@linux.ibm.com> > To: linux-mm@kvack.org > --- > v1 -> v2: adopt David's suggestion, rename it as pfn_in_present_section() > arch/powerpc/platforms/pseries/hotplug-memory.c | 2 +- > drivers/base/node.c | 2 +- > include/linux/mmzone.h | 4 ++-- > mm/page_ext.c | 2 +- > mm/shuffle.c | 2 +- > 5 files changed, 6 insertions(+), 6 deletions(-) > > diff --git a/arch/powerpc/platforms/pseries/hotplug-memory.c b/arch/powerpc/platforms/pseries/hotplug-memory.c > index a4d40a3..f3ed1ba 100644 > --- a/arch/powerpc/platforms/pseries/hotplug-memory.c > +++ b/arch/powerpc/platforms/pseries/hotplug-memory.c > @@ -360,7 +360,7 @@ static bool lmb_is_removable(struct drmem_lmb *lmb) > > for (i = 0; i < scns_per_block; i++) { > pfn = PFN_DOWN(phys_addr); > - if (!pfn_present(pfn)) { > + if (!pfn_in_present_section(pfn)) { > phys_addr += MIN_MEMORY_BLOCK_SIZE; > continue; > } Fine by me: Acked-by: Michael Ellerman <mpe@ellerman.id.au> (powerpc) cheers
diff --git a/arch/powerpc/platforms/pseries/hotplug-memory.c b/arch/powerpc/platforms/pseries/hotplug-memory.c index a4d40a3..f3ed1ba 100644 --- a/arch/powerpc/platforms/pseries/hotplug-memory.c +++ b/arch/powerpc/platforms/pseries/hotplug-memory.c @@ -360,7 +360,7 @@ static bool lmb_is_removable(struct drmem_lmb *lmb) for (i = 0; i < scns_per_block; i++) { pfn = PFN_DOWN(phys_addr); - if (!pfn_present(pfn)) { + if (!pfn_in_present_section(pfn)) { phys_addr += MIN_MEMORY_BLOCK_SIZE; continue; } diff --git a/drivers/base/node.c b/drivers/base/node.c index 98a31ba..10d7e81 100644 --- a/drivers/base/node.c +++ b/drivers/base/node.c @@ -772,7 +772,7 @@ static int register_mem_sect_under_node(struct memory_block *mem_blk, * memory block could have several absent sections from start. * skip pfn range from absent section */ - if (!pfn_present(pfn)) { + if (!pfn_in_present_section(pfn)) { pfn = round_down(pfn + PAGES_PER_SECTION, PAGES_PER_SECTION) - 1; continue; diff --git a/include/linux/mmzone.h b/include/linux/mmzone.h index 462f687..f6ceebdb 100644 --- a/include/linux/mmzone.h +++ b/include/linux/mmzone.h @@ -1372,7 +1372,7 @@ static inline int pfn_valid(unsigned long pfn) } #endif -static inline int pfn_present(unsigned long pfn) +static inline int pfn_in_present_section(unsigned long pfn) { if (pfn_to_section_nr(pfn) >= NR_MEM_SECTIONS) return 0; @@ -1409,7 +1409,7 @@ void sparse_init(void); #else #define sparse_init() do {} while (0) #define sparse_index_init(_sec, _nid) do {} while (0) -#define pfn_present pfn_valid +#define pfn_in_present_section pfn_valid #define subsection_map_init(_pfn, _nr_pages) do {} while (0) #endif /* CONFIG_SPARSEMEM */ diff --git a/mm/page_ext.c b/mm/page_ext.c index 4ade843..08ded03 100644 --- a/mm/page_ext.c +++ b/mm/page_ext.c @@ -304,7 +304,7 @@ static int __meminit online_page_ext(unsigned long start_pfn, } for (pfn = start; !fail && pfn < end; pfn += PAGES_PER_SECTION) { - if (!pfn_present(pfn)) + if (!pfn_in_present_section(pfn)) continue; fail = init_section_page_ext(pfn, nid); } diff --git a/mm/shuffle.c b/mm/shuffle.c index b3fe97f..c716059 100644 --- a/mm/shuffle.c +++ b/mm/shuffle.c @@ -72,7 +72,7 @@ static struct page * __meminit shuffle_valid_page(unsigned long pfn, int order) return NULL; /* ...is the pfn in a present section or a hole? */ - if (!pfn_present(pfn)) + if (!pfn_in_present_section(pfn)) return NULL; /* ...is the page free and currently on a free_area list? */
After introducing mem sub section concept, pfn_present() loses its literal meaning, and will not be necessary a truth on partial populated mem section. Since all of the callers use it to judge an absent section, it is better to rename pfn_present() as pfn_in_present_section(). Signed-off-by: Pingfan Liu <kernelfans@gmail.com> Cc: Dan Williams <dan.j.williams@intel.com> Cc: Michal Hocko <mhocko@kernel.org> Cc: Benjamin Herrenschmidt <benh@kernel.crashing.org> Cc: Paul Mackerras <paulus@samba.org> Cc: Michael Ellerman <mpe@ellerman.id.au> Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org> Cc: "Rafael J. Wysocki" <rafael@kernel.org> Cc: Andrew Morton <akpm@linux-foundation.org> Cc: David Hildenbrand <david@redhat.com> Cc: Leonardo Bras <leonardo@linux.ibm.com> Cc: Nathan Fontenot <nfont@linux.vnet.ibm.com> Cc: Nathan Lynch <nathanl@linux.ibm.com> To: linux-mm@kvack.org --- v1 -> v2: adopt David's suggestion, rename it as pfn_in_present_section() arch/powerpc/platforms/pseries/hotplug-memory.c | 2 +- drivers/base/node.c | 2 +- include/linux/mmzone.h | 4 ++-- mm/page_ext.c | 2 +- mm/shuffle.c | 2 +- 5 files changed, 6 insertions(+), 6 deletions(-)