Message ID | 1582989949-9939-1-git-send-email-qiwuchen55@gmail.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | mm: fix ambiguous comments for better code readability | expand |
On Sat, Feb 29, 2020 at 11:25:49PM +0800, qiwuchen55@gmail.com wrote: > +++ b/mm/memory.c > @@ -1948,8 +1948,8 @@ static inline int remap_p4d_range(struct mm_struct *mm, pgd_t *pgd, > * remap_pfn_range - remap kernel memory to userspace > * @vma: user vma to map to > * @addr: target user address to start at > - * @pfn: physical address of kernel memory > - * @size: size of map area > + * @pfn: remap pfn converted by physical address of kernel memory I think that's actually worse. How about: * @pfn: Page Frame Number of memory.
On Sat, Feb 29, 2020 at 07:31:23AM -0800, Matthew Wilcox wrote: > On Sat, Feb 29, 2020 at 11:25:49PM +0800, qiwuchen55@gmail.com wrote: > > +++ b/mm/memory.c > > @@ -1948,8 +1948,8 @@ static inline int remap_p4d_range(struct mm_struct *mm, pgd_t *pgd, > > * remap_pfn_range - remap kernel memory to userspace > > * @vma: user vma to map to > > * @addr: target user address to start at > > - * @pfn: physical address of kernel memory > > - * @size: size of map area > > + * @pfn: remap pfn converted by physical address of kernel memory > > I think that's actually worse. How about: > > * @pfn: Page Frame Number of memory. Hmm... I think "Page Frame Number of kernel memory" should be better. >
On Sat, Feb 29, 2020 at 11:43:17PM +0800, chenqiwu wrote: > On Sat, Feb 29, 2020 at 07:31:23AM -0800, Matthew Wilcox wrote: > > On Sat, Feb 29, 2020 at 11:25:49PM +0800, qiwuchen55@gmail.com wrote: > > > +++ b/mm/memory.c > > > @@ -1948,8 +1948,8 @@ static inline int remap_p4d_range(struct mm_struct *mm, pgd_t *pgd, > > > * remap_pfn_range - remap kernel memory to userspace > > > * @vma: user vma to map to > > > * @addr: target user address to start at > > > - * @pfn: physical address of kernel memory > > > - * @size: size of map area > > > + * @pfn: remap pfn converted by physical address of kernel memory > > > > I think that's actually worse. How about: > > > > * @pfn: Page Frame Number of memory. > > Hmm... I think "Page Frame Number of kernel memory" should be better. I disagree. We already know the memory is kernel memory from the first line. Repeating this information in the parameter description isn't particularly helpful.
diff --git a/include/linux/mm_types.h b/include/linux/mm_types.h index dd555e6..4aba6c0 100644 --- a/include/linux/mm_types.h +++ b/include/linux/mm_types.h @@ -289,8 +289,8 @@ struct vm_userfaultfd_ctx { #endif /* CONFIG_USERFAULTFD */ /* - * This struct defines a memory VMM memory area. There is one of these - * per VM-area/task. A VM area is any part of the process virtual memory + * This struct describes a virtual memory area. There is one of these + * per VM-area/task. A VM area is any part of the process virtual memory * space that has a special rule for the page-fault handlers (ie a shared * library, the executable area etc). */ diff --git a/mm/memory.c b/mm/memory.c index ce4b2b9..778aa00 100644 --- a/mm/memory.c +++ b/mm/memory.c @@ -1948,8 +1948,8 @@ static inline int remap_p4d_range(struct mm_struct *mm, pgd_t *pgd, * remap_pfn_range - remap kernel memory to userspace * @vma: user vma to map to * @addr: target user address to start at - * @pfn: physical address of kernel memory - * @size: size of map area + * @pfn: remap pfn converted by physical address of kernel memory + * @size: size of mapping area * @prot: page protection flags for this mapping * * Note: this is only safe if the mm semaphore is held when called.