diff mbox series

[v3,3/5] mm/page_alloc.c: rename free_pages_check_bad() to check_free_page_bad()

Message ID 20200411220357.9636-4-richard.weiyang@gmail.com (mailing list archive)
State New, archived
Headers show
Series mm/page_alloc.c: cleanup on check page | expand

Commit Message

Wei Yang April 11, 2020, 10:03 p.m. UTC
Function free_pages_check_bad() is the counterpart of
check_new_page_bad(). Rename it to use the same name convention.

Signed-off-by: Wei Yang <richard.weiyang@gmail.com>
---
 mm/page_alloc.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/mm/page_alloc.c b/mm/page_alloc.c
index 0648127af872..85d7aec5fb45 100644
--- a/mm/page_alloc.c
+++ b/mm/page_alloc.c
@@ -1013,7 +1013,7 @@  static inline bool page_expected_state(struct page *page,
 	return true;
 }
 
-static void free_pages_check_bad(struct page *page)
+static void check_free_page_bad(struct page *page)
 {
 	const char *bad_reason = NULL;
 
@@ -1038,7 +1038,7 @@  static inline int free_pages_check(struct page *page)
 		return 0;
 
 	/* Something has gone sideways, find it */
-	free_pages_check_bad(page);
+	check_free_page_bad(page);
 	return 1;
 }