diff mbox series

[15/24] mm/list_lru.c: Rename kvfree_rcu() to local variant

Message ID 20200427111113.5956-15-urezki@gmail.com (mailing list archive)
State New, archived
Headers show
Series None | expand

Commit Message

Uladzislau Rezki April 27, 2020, 11:11 a.m. UTC
Rename kvfree_rcu() function to the kvfree_rcu_local() one. The aim is
to introduce the public API that would conflict with this one. So we
temporarily rename it and remove it in a later commit.

Cc: linux-mm@kvack.org
Cc: Andrew Morton <akpm@linux-foundation.org>
Cc: rcu@vger.kernel.org
Signed-off-by: Uladzislau Rezki (Sony) <urezki@gmail.com>
Reviewed-by: Joel Fernandes (Google) <joel@joelfernandes.org>
Signed-off-by: Joel Fernandes (Google) <joel@joelfernandes.org>
---
 mm/list_lru.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Uladzislau Rezki April 27, 2020, 11:22 a.m. UTC | #1
Hello.

I apologize. Please ignore this patch and email. Wanted to send it to one
person,
instead git send-email also handled some emails from commit footer.

--
Vlad Rezki

On Mon, Apr 27, 2020 at 1:11 PM Uladzislau Rezki (Sony) <urezki@gmail.com>
wrote:

> Rename kvfree_rcu() function to the kvfree_rcu_local() one. The aim is
> to introduce the public API that would conflict with this one. So we
> temporarily rename it and remove it in a later commit.
>
> Cc: linux-mm@kvack.org
> Cc: Andrew Morton <akpm@linux-foundation.org>
> Cc: rcu@vger.kernel.org
> Signed-off-by: Uladzislau Rezki (Sony) <urezki@gmail.com>
> Reviewed-by: Joel Fernandes (Google) <joel@joelfernandes.org>
> Signed-off-by: Joel Fernandes (Google) <joel@joelfernandes.org>
> ---
>  mm/list_lru.c | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/mm/list_lru.c b/mm/list_lru.c
> index 4d5294c39bba..42c95bcb53ca 100644
> --- a/mm/list_lru.c
> +++ b/mm/list_lru.c
> @@ -373,14 +373,14 @@ static void memcg_destroy_list_lru_node(struct
> list_lru_node *nlru)
>         struct list_lru_memcg *memcg_lrus;
>         /*
>          * This is called when shrinker has already been unregistered,
> -        * and nobody can use it. So, there is no need to use kvfree_rcu().
> +        * and nobody can use it. So, there is no need to use
> kvfree_rcu_local().
>          */
>         memcg_lrus = rcu_dereference_protected(nlru->memcg_lrus, true);
>         __memcg_destroy_list_lru_node(memcg_lrus, 0, memcg_nr_cache_ids);
>         kvfree(memcg_lrus);
>  }
>
> -static void kvfree_rcu(struct rcu_head *head)
> +static void kvfree_rcu_local(struct rcu_head *head)
>  {
>         struct list_lru_memcg *mlru;
>
> @@ -419,7 +419,7 @@ static int memcg_update_list_lru_node(struct
> list_lru_node *nlru,
>         rcu_assign_pointer(nlru->memcg_lrus, new);
>         spin_unlock_irq(&nlru->lock);
>
> -       call_rcu(&old->rcu, kvfree_rcu);
> +       call_rcu(&old->rcu, kvfree_rcu_local);
>         return 0;
>  }
>
> --
> 2.20.1
>
>
diff mbox series

Patch

diff --git a/mm/list_lru.c b/mm/list_lru.c
index 4d5294c39bba..42c95bcb53ca 100644
--- a/mm/list_lru.c
+++ b/mm/list_lru.c
@@ -373,14 +373,14 @@  static void memcg_destroy_list_lru_node(struct list_lru_node *nlru)
 	struct list_lru_memcg *memcg_lrus;
 	/*
 	 * This is called when shrinker has already been unregistered,
-	 * and nobody can use it. So, there is no need to use kvfree_rcu().
+	 * and nobody can use it. So, there is no need to use kvfree_rcu_local().
 	 */
 	memcg_lrus = rcu_dereference_protected(nlru->memcg_lrus, true);
 	__memcg_destroy_list_lru_node(memcg_lrus, 0, memcg_nr_cache_ids);
 	kvfree(memcg_lrus);
 }
 
-static void kvfree_rcu(struct rcu_head *head)
+static void kvfree_rcu_local(struct rcu_head *head)
 {
 	struct list_lru_memcg *mlru;
 
@@ -419,7 +419,7 @@  static int memcg_update_list_lru_node(struct list_lru_node *nlru,
 	rcu_assign_pointer(nlru->memcg_lrus, new);
 	spin_unlock_irq(&nlru->lock);
 
-	call_rcu(&old->rcu, kvfree_rcu);
+	call_rcu(&old->rcu, kvfree_rcu_local);
 	return 0;
 }