Message ID | 20201002084049.556824-3-jhubbard@nvidia.com (mailing list archive) |
---|---|
State | New, archived |
Headers | show |
Series | selftests/vm: fix up executable bits, and a file name | expand |
On Fri, 2 Oct 2020 01:40:49 -0700 John Hubbard <jhubbard@nvidia.com> wrote: > commit cb2ab76685d7 ("selftests/vm: rename run_vmtests --> > run_vmtests.sh") changed the name of run_vmtests to run_vmtest.sh, but > inadvertently dropped the executable bits. We cannot depend on the x bit. Because downloading linux-foo.patch.gz and installing it with patch(1) is a supported way of obtaining Linux. And patch(1) loses the x bit. If $(CONFIG_SHELL) is unavailable then invoking the script with "/bin/sh foo.sh" should do the trick. > Somehow the name is missing an "s", too. Fix both of these problems by > renaming, and restoring the executable bits. But that's what your patch did! tools/testing/selftests/vm/{run_vmtests => run_vmtest.sh} | 0 Here: https://lkml.kernel.org/r/20200929212747.251804-4-jhubbard@nvidia.com So all confused. I'll drop this version - please redo and resend when convenient?
On 10/2/20 2:59 PM, Andrew Morton wrote: > On Fri, 2 Oct 2020 01:40:49 -0700 John Hubbard <jhubbard@nvidia.com> wrote: > >> commit cb2ab76685d7 ("selftests/vm: rename run_vmtests --> >> run_vmtests.sh") changed the name of run_vmtests to run_vmtest.sh, but >> inadvertently dropped the executable bits. > > We cannot depend on the x bit. Because downloading linux-foo.patch.gz > and installing it with patch(1) is a supported way of obtaining Linux. > And patch(1) loses the x bit. OK. I was just hoping that, within our processes here, there's still some way to get something committed that does have the bit set. Because it's a nice touch to be able to do ./run_vmtests.sh Not a big deal of course. > > If $(CONFIG_SHELL) is unavailable then invoking the script with > "/bin/sh foo.sh" should do the trick. OK, I'll use that for the Makefile. > >> Somehow the name is missing an "s", too. Fix both of these problems by >> renaming, and restoring the executable bits. > > But that's what your patch did! > > tools/testing/selftests/vm/{run_vmtests => run_vmtest.sh} | 0 > > Here: https://lkml.kernel.org/r/20200929212747.251804-4-jhubbard@nvidia.com > Yes, the dropped "s" is my mistake! > > So all confused. I'll drop this version - please redo and resend when > convenient? > Coming up, sorry about the mess here! thanks,
diff --git a/tools/testing/selftests/vm/run_vmtest.sh b/tools/testing/selftests/vm/run_vmtests.sh
old mode 100644
new mode 100755
similarity index 100%
rename from tools/testing/selftests/vm/run_vmtest.sh
rename to tools/testing/selftests/vm/run_vmtests.sh
commit cb2ab76685d7 ("selftests/vm: rename run_vmtests --> run_vmtests.sh") changed the name of run_vmtests to run_vmtest.sh, but inadvertently dropped the executable bits. Somehow the name is missing an "s", too. Fix both of these problems by renaming, and restoring the executable bits. Fixes: cb2ab76685d7 ("selftests/vm: rename run_vmtests --> run_vmtests.sh") Signed-off-by: John Hubbard <jhubbard@nvidia.com> --- tools/testing/selftests/vm/{run_vmtest.sh => run_vmtests.sh} | 0 1 file changed, 0 insertions(+), 0 deletions(-) rename tools/testing/selftests/vm/{run_vmtest.sh => run_vmtests.sh} (100%) mode change 100644 => 100755